Nach apt-Update Problem mit Perl-Paket

snake*sl
Posts: 37
Joined: 2004-10-21 18:04
Location: Iserlohn

Nach apt-Update Problem mit Perl-Paket

Post by snake*sl »

Hi.

Sorry für Crossposting, hab das schon woanders gepostet, aber es wusste bisher keiner eine Lösung:

Nachdem vor ein paar Tagen ein Perl-Update rauskam, wollte ich den Server updaten und stieß auf folgende Fehlermeldung:

Code: Select all

server:~# apt-get update && apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  perl: Depends: perl-base (= 5.8.8-7etch1) but 5.8.8-7 is installed
E: Unmet dependencies. Try using -f.


apt -f install hab ich dann auch probiert und es kam:

Code: Select all

server:~# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  perl-base
The following packages will be upgraded:
  perl-base
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 0B/762kB of archives.
After unpacking 147kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 33194 files and directories currently installed.)
Preparing to replace perl-base 5.8.8-7 (using .../perl-base_5.8.8-7etch1_i386.deb) ...
Unpacking replacement perl-base ...
dpkg: error processing /var/cache/apt/archives/perl-base_5.8.8-7etch1_i386.deb (--unpack):
 trying to overwrite `/usr/share/perl/5.8', which is also in package libmime-base64-perl
Errors were encountered while processing:
 /var/cache/apt/archives/perl-base_5.8.8-7etch1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Wenn ich das richtig verstehe, kann er die Perl-Dateien nicht überschreiben, weil sie von libmime-base64-perl genutzt werden. Soll ich den Prozess vorher stoppen? Oder liege ich komplett falsch?
Hat jemand eine Idee?

PS: apt-get remove libmime-base64-perl gibt den gleichen Fehler wie apt-get upgrade
Top

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Nach apt-Update Problem mit Perl-Paket

Post by sledge0303 »

PS: apt-get remove libmime-base64-perl gibt den gleichen Fehler wie apt-get upgrade


Code: Select all

apt-get remove --purge libmime-base64-perl
ggf
dpkg --purge libmime-base64-perl
Top

snake*sl
Posts: 37
Joined: 2004-10-21 18:04
Location: Iserlohn

Re: Nach apt-Update Problem mit Perl-Paket

Post by snake*sl »

Hmmm, komme damit leider auch nicht weiter ...

Code: Select all

server:~# apt-get remove --purge libmime-base64-perl
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  perl: Depends: perl-base (= 5.8.8-7etch1) but 5.8.8-7 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


server:~# dpkg --purge libmime-base64-perl
dpkg: dependency problems prevent removal of libmime-base64-perl:
 libwww-perl depends on libmime-base64-perl (>= 2.1) | perl (>= 5.8); however:
  Package libmime-base64-perl is to be removed.
  Package perl is not configured yet.
 libnet-dns-perl depends on libmime-base64-perl; however:
  Package libmime-base64-perl is to be removed.
  Package perl which provides libmime-base64-perl is not configured yet.
 libcrypt-ssleay-perl depends on libmime-base64-perl; however:
  Package libmime-base64-perl is to be removed.
  Package perl which provides libmime-base64-perl is not configured yet.
 liburi-perl depends on libmime-base64-perl; however:
  Package libmime-base64-perl is to be removed.
  Package perl which provides libmime-base64-perl is not configured yet.
 libunicode-string-perl depends on libmime-base64-perl; however:
  Package libmime-base64-perl is to be removed.
  Package perl which provides libmime-base64-perl is not configured yet.
dpkg: error processing libmime-base64-perl (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 libmime-base64-perl
Top

floogy
Posts: 150
Joined: 2007-10-23 22:00

Re: Nach apt-Update Problem mit Perl-Paket

Post by floogy »

Code: Select all

apt-get remove --force-all --simulate libwww-perl libnet-dns-perl  libcrypt-ssleay-perl  liburi-perl  libunicode-string-perl libmime-base64-perl libmime-base64-perl 

Falls das Problemlos geht, ohne --simulate wiederholen, und danach:

Code: Select all

apt-get -f install --simulate

Dann, falls das durchlief (ohne --simulate):

Code: Select all

apt-get install libwww-perl libnet-dns-perl  libcrypt-ssleay-perl  liburi-perl  libunicode-string-perl libmime-base64-perl libmime-base64-perl


Ansonsten:

Code: Select all

dpkg -i --force-all /var/cache/apt/archives/perl-base_5.8.8-7etch1_i386.deb

Es gibt da zwar noch eine empfohlene Methode mit dpkg-divert, aber an die Einzelheiten kann ich mich gerade nicht erinnern. --force-all ist natürlich nicht zu empfehlen..., löst aber manchmal solche Konflikte.

Alternativ könntest Du mal nach dpkg-divert und Lösung solcher Konflikte googlen.

http://qref.sourceforge.net/Debian/quic ... pkg-divert
http://www.debian.org/doc/manuals/refer ... pkg-divert
http://debiananwenderhandbuch.de/dpkg-divert.html
Top

snake*sl
Posts: 37
Joined: 2004-10-21 18:04
Location: Iserlohn

Re: Nach apt-Update Problem mit Perl-Paket

Post by snake*sl »

Vielen Dank für Deine Hilfe floogy, ich hab es allerdings jetzt so gelöst. Mit Hilfe von aptitude konnte ich die Perl-Pakete runterschmeissen, wodurch mir dann auch gleich einige wichtige Serverdienste mitgelöscht wurden - MySQL, Courier, Spamassassin, Berkley ... halt alles, was Perl benötigt.

Ich habe dann alles wieder per apt installiert und es funktionierte wieder fast alles. Im syslog fand ich dann noch ein paar Fehlermeldungen, die auf fehlende CPAN-Module hinwiesen ... installiert, fertig.

Das ganze hat nicht mehr als drei Minuten gedauert ...
Top

Who is online

Users browsing this forum: Google [Bot] and 960 guests