Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Apache, Lighttpd, nginx, Cherokee
fun4teen
Posts: 92
Joined: 2004-06-18 16:11

Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by fun4teen » 2007-09-14 18:30

Hi all,

habe via Yast auf meinem Rootie unter Software installieren php5 (5.2.4) ausgewählt. Diese habe ich dann installiert.. und nun startet der Apache nicht mehr.

Hat mir jemand einen Tipp was ich machen kann?

Gruß und Dank

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by Joe User » 2007-09-14 19:01

Was steht im error.log?

fun4teen
Posts: 92
Joined: 2004-06-18 16:11

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by fun4teen » 2007-09-14 19:07

apache2 error.log

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/sitebuilder3.so' - /usr/lib64/php5/extensions/sitebuilder3.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: SQLite: Unable to initialize modulenModule compiled with module API=20050922, debug=0, thread-safety=0nPHP compiled with module API=20060613, debug=0, thread-safety=0nThese options need to matchn in Unknown on line 0

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by Joe User » 2007-09-14 19:34

Übersetzen müssen wir die Fehlermeldungen aber nicht, oder?

fun4teen
Posts: 92
Joined: 2004-06-18 16:11

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by fun4teen » 2007-09-14 19:36

Das mit dem Sitebuilder ist ok... hab ich einfach aus der php.ini genommen.

Aber das SQlite, mit dem weiß ich nichts anzufangen...

Edit.. so nun bekomm ich das.. nachdem ich sqlite nochmal installiert habe:

Code: Select all

[Fri Sep 14 18:58:28 2007] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Sep 14 18:58:28 2007] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri Sep 14 18:58:28 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Sep 14 18:58:28 2007] [warn] RSA server certificate CommonName (CN) `XXXX' does NOT match server name!?

[Fri Sep 14 18:58:28 2007] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
No worker file and no worker options in httpd.conf nuse JkWorkerFile to set workersn
[Fri Sep 14 18:58:28 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Fri Sep 14 18:58:28 2007] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri Sep 14 18:58:28 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Sep 14 18:58:28 2007] [warn] RSA server certificate CommonName (CN) `XXXXXX' does NOT match server name!?
[Fri Sep 14 18:58:28 2007] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
Last edited by fun4teen on 2007-09-14 19:40, edited 1 time in total.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by Joe User » 2007-09-14 19:39

Die PHP-Module, insbesondere das SQLite-Modul, müssen aktualisiert/rekompiliert werden.

fun4teen
Posts: 92
Joined: 2004-06-18 16:11

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by fun4teen » 2007-09-14 19:41

Hab oben nochmal ein edit gemacht..

fun4teen
Posts: 92
Joined: 2004-06-18 16:11

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by fun4teen » 2007-09-14 20:04

Habe den apache nun nochmal gelöscht und dann wieder instaööiert.. nun startet er wieder :) Danke schon einmal.

synex
Posts: 45
Joined: 2005-06-17 23:00
Location: Möckern

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by synex » 2007-09-15 10:10

1. Er hatte vorher Version 5.12 - wenn er schon updated, kann er doch die neuste nehmen. ;)

2. Es wurden zumindest in der letzten Version einige (security) bugs behoben. (bei den Versionen dazwischen weiß ich nicht - aber bestimmt) So ist es doch eigentlich anzuraten PHP aktuell zu halten.

stefan_d
Posts: 21
Joined: 2007-09-25 20:43

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by stefan_d » 2007-09-25 20:54

Ich häng mich mal hier dran. Ich habe auch einen Suse 10.1 mit Plesk 8.2 und PHP 5.1.2 Mir würde schon ein Update auf 5.2 reiche, aber es wird bei YaSt nicht angezeigt.


Warum ein Update. Weil ich die in PHP sei 4.? integrierte Erweiterung Tokenizer benötige. Aber in dieser PHP Kompilierung auf meinem Suse Plesk Server ist es aus. Jetzt würde ich auch eine tokenizer.so über den dl() Befehl nachladen, aber ich kann keine tokenizer.so Datei finden.

wie kann ich am Besten vorgehen um den Tokenizer nachzuladen. Oder muss ich unbedingt PHP neu kompilieren?

Wäre klasse wenn jemand eine Idee hätte.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by Joe User » 2007-09-26 11:09

Code: Select all

yast install php5-tokenizer

stefan_d
Posts: 21
Joined: 2007-09-25 20:43

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by stefan_d » 2007-09-26 11:33

Joe User wrote:

Code: Select all

yast install php5-tokenizer



Danke für deine schnelle Antwort.
Bei mir kam dann die Meldung:
"No such client module install"

Also Yast eingegeben und dort Search Tokenizer

Oh wunder. So geht das also.

Tausend Dank für die Hilfe. Aller Anfang ist schwer. :wink:

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Apache/ PHP update 1&1 / SUSE 10.1 x 64 / Plesk 8.2 / von PHP 5.12 ->5.2.X

Post by oxygen » 2007-09-26 14:12

er meinte vermutlich

Code: Select all

yum install php5-tokenizer