Apache 2.2.3 und mod_fastcgi 2.4.2-8 mit php 4.4.7

Apache, Lighttpd, nginx, Cherokee
kumpel2
Posts: 46
Joined: 2006-08-09 16:13
Location: Essen Nord

Apache 2.2.3 und mod_fastcgi 2.4.2-8 mit php 4.4.7

Post by kumpel2 » 2007-09-11 21:53

Hallo Forum,

habe ein kleines, naja, problemchen...

Bekomme in meinen logs öfter den folgenden Eintrag:

Code: Select all

[warn] FastCGI: (dynamic) server "/fcgi/webXXX/starter-file" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds


Warum macht das fastcgi script nich wirklich mit?

Das File startet ohne probleme beim ersten und den darauffolgenden malen, aber dann nicht mehr...

Wäre schön, wenn jemand ne idee hat, weil die Logfiles werden total voll davon =)

LG der KuMpEl2

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: Apache 2.2.3 und mod_fastcgi 2.4.2-8 mit php 4.4.7

Post by cirox » 2007-09-11 23:24

mod-fastcgi wird nicht mehr aktiv weiterentwickelt. Es gibt also keinen Grund dieses weiterzuverwenden. Steig doch erstmal auf mod_fcgid um. Der Umstieg ist schnell erledigt.

kumpel2
Posts: 46
Joined: 2006-08-09 16:13
Location: Essen Nord

Re: Apache 2.2.3 und mod_fastcgi 2.4.2-8 mit php 4.4.7

Post by kumpel2 » 2007-09-14 13:58

hmm, gibts da auch ne schicke anleitung für nen debian server, muss ja auch einiges an den vhost dateien umgestellt werden *denkz*

Gibts auch nen debian paket?

danke!

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: Apache 2.2.3 und mod_fastcgi 2.4.2-8 mit php 4.4.7

Post by cirox » 2007-09-14 14:04

Da gibts auch nen debian Paket:

http://packages.debian.org/etch/libapache2-mod-fcgid

In der Backportsmailingliste findest Du einen Link zu einer neueren Version :)

Ansonsten wäre die Anleitung zu kurz:

Installieren -> Fertig. Vielleicht noch enablen unter apache/modules und die conf anpassen.