Ausfall unsereres Rootservers

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
pocopelli
Posts: 52
Joined: 2006-05-12 14:13

Ausfall unsereres Rootservers

Post by pocopelli » 2007-06-18 16:17

Tach,

wir haben einen Rootserver bei Hetzner. An letztem und am vorletzten Samstag ist uns das Ding zwischen 1 und 2 Uhr morgens abgestürtzt. Den Log Files war so gut wie gar nichts weiterführendes zu entnehmen. In der auth.log stand:

Code: Select all

 00:35:00 localhost sshd[17971]: Did not receive identification string from 200.207.76.38
was wahrscheinlich auf einen fehlgeschlagenen Login - Versuch schließen läßt? Sonst eine Idee wo man gucken könnte ?
Hat jemand vielleicht eine Idee / InsiderKentnisse, um hier Schutzvorkehrungen zu treffen.

2 Ursachen könnten es IMHO sein:
1.) Angriff (Manipulation der Logfiles ?)
2.) Hardware defekt Könnt ihr hier Monitoring Lösungen
empfehlen ?

Dank euch für eure Hilfe!

Gruß

Poc

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Ausfall unsereres Rootservers

Post by Roger Wilco » 2007-06-18 16:20

Moved from Webserver - Installation und Konfiguration to Allgemeine *NIX-Serverfragen mit Tiefgang.

dotme
Posts: 150
Joined: 2004-12-15 16:48

Re: Ausfall unsereres Rootservers

Post by dotme » 2007-06-18 16:28

oder

3.) Software defekt

Sprich: seid Ihr bei den Kernel-Updates auf dem Laufenden?

Ich hatte hier mal so einen ungepflegten Server, der sporadisch ohne weitere Hinweise ausfiel. Ein Kernelupdate hat Ihm das bis heute (toi, toi, toi) abgewöhnt.

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Ausfall unsereres Rootservers

Post by daemotron » 2007-06-18 18:35

Die Logzeile, die Du gepostet hast, sehe ich weniger in Zusammenhang mit einem kompletten Serverabsturz... Ich hatte bei besagtem Provider auch eine Weile lang Probleme mit unmotivierten Abstürzen und vor allem fehlenden Spuren einer möglichen Ursache (siehe http://www.rootforum.org/forum/viewtopic.php?t=45289 und http://www.rootforum.org/forum/viewtopic.php?t=45388). Ich habe nach wie vor entweder den RAID-Controller oder das NIC als Ursache im Verdacht, vielleicht ist es aber auch der Via-Chipsatz, Mondphase, Erdstrahlung, Sonneneruptionen oder was BOfH sich sonst noch so einfallen lässt...

Geholfen hat jedenfalls der Vorschlag von Theomega, dem Kernel beim booten noapic als Option mitzugeben. Seitdem herrscht jedenfalls Ruhe an der Absturz-Front.