[Debian 3.1] PHP Update

Bash, Shell, PHP, Python, Perl, CGI
markus1312
Posts: 9
Joined: 2007-05-02 18:20

[Debian 3.1] PHP Update

Post by markus1312 »

Hallo ich habe mir einen Root mit Debian 3.1 LAMP angemietet und möchte nun PHP4 auf PHP5 updaten.

Jedoch weiß ich leider nicht wie das funktioniert. Hoffe ihr könnt mir vielleicht eine Anleitung dafür schreiben, wäre auf jedenfall nett.

Gruß
Markus
elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: [Debian 3.1] PHP Update

Post by elch_mg »

Schonmal Google befragt?
markus1312
Posts: 9
Joined: 2007-05-02 18:20

Re: [Debian 3.1] PHP Update

Post by markus1312 »

elch_mg wrote:Schonmal Google befragt?
Ja hab ich schon jedoch nix gefunden für Debian 3.1
elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: [Debian 3.1] PHP Update

Post by elch_mg »

Suche

6., 7. Ergebnis hab ich so auf Anhieb gesehn..

Übrigens: Sarge (3.1) ist inzwischen oldstable, du solltest also beizeiten auf Etch updaten.
markus1312
Posts: 9
Joined: 2007-05-02 18:20

Re: [Debian 3.1] PHP Update

Post by markus1312 »

Hm soweit hab ich PHP5 schonmal jedoch erhalte ich nun den Fehler

The following packages have unmet dependencies:
libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge4 is to be installed
Depends: libdb4.4 but it is not installable
Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge3 is to be installed
Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
Depends: libxml2 (>= 2.6.27) but it is not going to be installed

So libxml2 habe ich dann noch installiert, ebenfalls auch libkrb53.
Ja nun brauch ich noch libdb4.4 und libssl0.9.8 jedoch sind diese nicht verfügbar oder so. Wo bekomm ich dafür die Sources?
elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: [Debian 3.1] PHP Update

Post by elch_mg »

Welche Befehle hast du benutzt? Wie führst du das Update durch?
markus1312
Posts: 9
Joined: 2007-05-02 18:20

Re: [Debian 3.1] PHP Update

Post by markus1312 »

Also das update mit apt-get update
Und installation von PHP5 mit apt-get install libapache2-mod-php5
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: [Debian 3.1] PHP Update

Post by Roger Wilco »

Bring deine sources.list in Ordnung...
markus1312
Posts: 9
Joined: 2007-05-02 18:20

Re: [Debian 3.1] PHP Update

Post by markus1312 »

Roger Wilco wrote:Bring deine sources.list in Ordnung...
Hm hab ich ja was habt ihr so drinn?
markus1312
Posts: 9
Joined: 2007-05-02 18:20

Re: [Debian 3.1] PHP Update

Post by markus1312 »

Markus1312 wrote:
Roger Wilco wrote:Bring deine sources.list in Ordnung...
Hm hab ich ja was habt ihr so drinn?
Hab jetzt mal apt-get dist-upgrade gemacht. Soweit ist auch der PHP5 ordner jetzt schon angelegt wurden durch das System jedoch wenn ich jetz wieder

apt-get install libapache2-mod-php5

kommt wieder

The following packages have unmet dependencies:
libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge6 is to be installed
Depends: libdb4.4 but it is not installable
Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge4 is to be installed
Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
Depends: libxml2 (>= 2.6.27) but 2.6.16-7 is to be installed
E: Broken packages


ich versteh das nicht.

In meiner Sources.list hab ich folgendes:

deb http://packages.dotdeb.org stable all
deb ftp://debian.uni-essen.de/debian sarge main contrib non-free
deb ftp://ftp.de.debian.org/debian sarge main
deb-src http://ftp.de.debian.org/debian sarge main
deb http://ftp.uni-erlangen.de/debian sarge main contrib non-free
deb http://ftp.uni-stuttgart.de/debian sarge main contrib non-free
deb http://security.debian.org/ sarge/updates main contrib non-free
deb http://dotdeb.pimpmylinux.org/ stable all
deb-src http://dotdeb.pimpmylinux.org/ stable all
Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: [Debian 3.1] PHP Update

Post by Roger Wilco »

stable = etch
sarge = sarge

Du hast eine Mischung in deiner sources.list, das ist schlecht[tm].
markus1312
Posts: 9
Joined: 2007-05-02 18:20

Re: [Debian 3.1] PHP Update

Post by markus1312 »

Hab noch ein größeres Problem jetzt funktioniert weder PHP noch MySQL -.- da waren die ganzen RECHNUNGEN NOCH oO!