Postfix Test mit telnet "lost connection after DATA from"

meddten
Posts: 4
Joined: 2007-04-25 10:41

Postfix Test mit telnet "lost connection after DATA from"

Post by meddten »

Hallo,

hab zuhhause auf einer alten Kiste einen kleinen Mailserver installiert zum rumtesten.

Gefolgt bin ich der Anleitung

http://www.debianhowto.de/doku.php/de:h ... irenschutz

Hab zwar Debian Etch (was aber nicht das Problem sein sollte)

Hab alles durchgearbeitet und alles ausgefüllt wie es in der Anleitung steht.

Beim testen mit telnet

geb ich dann data ein und "dies ist eine testmail"

Danach bleibt Telnet stehen und ich bekomme obigen Fehler in /var/log/mail.log

lost connection after DATA from

Was könnte der Grund sein?



PS: hab noch ein Problem hab rm /var/log/mail.log gemacht nun kommt aber das Log nicht wieder daher, hab dann ein leeres /var/log/mail.log gemacht. Aber auch dieses wird nicht mehr mit neuen Logeinträgen gefüllt. Warum?


Vielen Dank!
Top

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Postfix Test mit telnet "lost connection after DATA from"

Post by squize »

Das mit dem Logfile liegt wahrscheinlich daran, dass die von dir erzeugte logdatei falsche Rechte/Besitzer hat.

Warum deine Konfig beim Data-Command abbricht ist ohne Config schwer zu sagen. Je nachdem, wann du Checks machst ( smtp_data_restricions ), könnte es zu Problemen kommen.
Eine andere problemstelle ist oft die Vebindung zur Datenbank.


Gruss

Marc
Top

meddten
Posts: 4
Joined: 2007-04-25 10:41

Re: Postfix Test mit telnet "lost connection after DATA from"

Post by meddten »

squize wrote:Das mit dem Logfile liegt wahrscheinlich daran, dass die von dir erzeugte logdatei falsche Rechte/Besitzer hat.

Warum deine Konfig beim Data-Command abbricht ist ohne Config schwer zu sagen. Je nachdem, wann du Checks machst ( smtp_data_restricions ), könnte es zu Problemen kommen.
Eine andere problemstelle ist oft die Vebindung zur Datenbank.


Gruss

Marc
Hier die main.cf

Code: Select all

inet_interface = all
myhostname = th00
mydestination = th00.rnetwork, localhost.rnetwork, , localhost
mynetworks = 127.0.0.0/8
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key

Und hier mal die Rechte vo den Mail Logs

Code: Select all

-rw-r--r-- 1 root        root     43428 2007-04-24 04:01 mail.err
-rw-r--r-- 1 root        root    248464 2007-04-24 12:42 mail.info
-rw-r--r-- 1 root        root         0 2007-04-24 12:42 mail.log
-rw-r--r-- 1 root        root    232237 2007-04-24 12:27 mail.warn
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Postfix Test mit telnet "lost connection after DATA from"

Post by Roger Wilco »

Meddten wrote:Beim testen mit telnet

geb ich dann data ein und "dies ist eine testmail"
Und du schließt die Eingabe auch korrekt mit einem einzelnen Punkt in einer neuen Zeile ab? Ansonsten wartet Postfix nämlich auf weitere Eingaben und bricht die Verbindung irgendwann mit einem Timeout ab.
Meddten wrote:PS: hab noch ein Problem hab rm /var/log/mail.log gemacht nun kommt aber das Log nicht wieder daher, hab dann ein leeres /var/log/mail.log gemacht. Aber auch dieses wird nicht mehr mit neuen Logeinträgen gefüllt. Warum?
Du hast deinem syslogd die Logdatei unter dem *rsch weggelöscht, das macht man nicht. ;)
Einfach syslogd (oder syslog-ng) neustarten bzw. SIGHUPpen.
Top