Debian 3.1 (Kernel 2.6.8) inkl. VMware + IPTABLES FORWARD, geht nicht..

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
iceget
Posts: 50
Joined: 2005-03-23 13:50

Debian 3.1 (Kernel 2.6.8) inkl. VMware + IPTABLES FORWARD, geht nicht..

Post by iceget » 2007-02-27 08:57

Hallo Leute,

und zwar habe ich dieses mail folgendes Problemchen:

Habe ein eth0 mit einer statischen IP-Adresse und ein
vmnet8 mit der IP-Adresse 192.168.77.1.

Auf VMware läuft ein Windows XP Professional (192.168.77.128), bei dem ich die Firewall deaktiviert habe (unter Windows) und die Remote Desktop Verbindung aktiviert habe!

Auf der Linux Maschine kann ich ohne Problem ein nmap au 192.168.77.128 machen, dann bekomme ich 4 oder 5 offene Ports zurück, darunter auch der 3389.

Die IPTABLES Firewall läuft schon ohne Probleme, so wie ich sie konfiguriert habe! Das Problem, ich hab schon diverses bzgl. Portweiterleitung gesucht, jedoch nicht viel gefunden!

Hier mein Script:
http://temp.raving.at/firewall.txt

habe ich mir von einem automatischen Script erstellen lassen, und dieses dann etwas angepasst!

Ich habe schon diverses versucht für den Portforward:# port forwarding #
iptables -t nat -A PREROUTING -i eth0 -p tcp -s 0/0 --dport 3389 -j DNAT --to-destination 192.168.77.128
iptables -A FORWARD -i eth0 -m state --state RELATED,ESTABLISHED -p tcp -s 0/0 -d 192.168.77.128 --dport 3389 -j ACCEPT
iptables -t nat -I PREROUTING -i eth0 -p tcp --dport 3389 -j DNAT --to 192.168.77.128
iptables -I FORWARD -i eth0 -p tcp --dport 3389 -j ACCEPT
iptables -t nat -A PREROUTING -i eth0 -p tcp -s 0/0 --dport 3389 -j DNAT --to-destination 192.168.77.128
iptables -A FORWARD -i eth0 -o vmnet8 -m state --state RELATED,ESTABLISHED -p tcp -s 0/0 -d 192.168.77.128 --dport 3389 -j ACCEPT
iptables -A FORWARD -i vmnet8 -o eth0 -p tcp -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -t nat -A PREROUTING -p tcp -s 0.0.0.0/0 -d 192.168.77.1 --dport 3389 -j DNAT --to-destination 192.168.77.128:3389
iptables -A PREROUTING -t nat -i eth0 -p tcp --dport 3389 -j DNAT --to-destination 192.168.77.128
iptables -A INPUT -p tcp -m state --state NEW --dport 3389 -i vmnet8 -j ACCEPT

auch im Kernel habe ich das Portforwading aktiviert....

was mache ich falsch?

könnt ihr mir helfen?

Vielen Dank!

glg mAx

iceget
Posts: 50
Joined: 2005-03-23 13:50

Gelöst!

Post by iceget » 2007-03-02 08:48

Danke trotzdem glg mAx