Problem bei griechischen eMails...

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
inter-medien
Posts: 9
Joined: 2007-01-30 21:50

Problem bei griechischen eMails...

Post by inter-medien » 2007-02-01 17:38

Hallo,

ich habe einen kleinen Webserver auf dem eine griechische Seite läuft.
Im Webbrowser wird die griechische Schrift in html bzw. php richtig angezeigt. Jedoch wenn ich über ein Kontaktformular eine eMail versende kommen bei mir bloß wirre Zeichen an:

So sollte es sein:
Η παραγγελία σας καταχωρήθηκε και η παράδοσή της θα γίνει άμεσα για την δική σας καλύτερη εξυπηρέτηση.

Das kommt an:
Η Ï€ÃŽÂ±ÃÂÃŽÂ±ÃŽÂ³ÃŽÂ³ÃŽÂµÃŽÂ»ÃŽÂ¯ÃŽÂ± σας ολοκληρώθηκε


Hier noch das Scipt:

Code: Select all

$header = "From: #####.com <######>";
$header .= "Reply-To: <######a@#####.com>";     
$header .= 'Content-type: text/plain; charset: UTF-8;'; 
mail($emailer, "Ihre Bestellung","
Σας ευχαριστούμε θερμά για την επιλογή σας να εμπιστευτείτε την ποιότητα των προϊόντων μας. 

Η παραγγελία σας καταχωρήθηκε και η παράδοσή της θα γίνει άμεσα για την δική σας καλύτερη εξυπηρέτηση.


","$header"); 

Was kann ich noch machen?


Viele Grüsse
Rob

elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: Problem bei griechischen eMails...

Post by elch_mg » 2007-02-01 19:58

es sollte heissen

Code: Select all

Content-Type: text/plain; charset="utf-8"
meine ich...

Generierst du den Text der Mail dynamisch oder ist der fest? Ist im letzteren Falle das Encoding im Browser richtig?

inter-medien
Posts: 9
Joined: 2007-01-30 21:50

Re: Problem bei griechischen eMails...

Post by inter-medien » 2007-02-01 20:13

klar, so heißt es natürlich auch - hatte es flash kopiert ;-)
es geht so aber leider auch nicht.....