MySQL Update 4 auf 4.1 - SLES9

Anonymous

MySQL Update 4 auf 4.1 - SLES9

Post by Anonymous »

Hallo,

Mir wurde die Aufgabe erteilt auf einem Intranetserver die MySQL Datenbank zu updaten auf Version 4.1.x. Ich habe also ein Backup der Datenbank erstellt. Mir die passenden 4.1.21 SLES9 Pakete auf Mysql.org besorgt und wollte das ganze angehn.

Jedoch macht mir mein Server einen Strich durch die Rechnung:

error: Failed dependencies:
pwdutils is needed by MySQL-server-standard-4.1.21-0.sles9
procps is needed by MySQL-server-standard-4.1.21-0.sles9


Mein Problem:
Ich kann weder eine Version von pwdutils noch von procps finden die mit meinem Betriebssystem läuft bzw. nicht selbst nochmal zig Abhängigkeiten hat die ebenfalls nicht laufen. Ich stecke mitlerweile in einer Sackgasse.


Meine Hoffnung:
Hat eventuell jemand hier Erfahrung mit SLES9 und könnte mir etwas Hilfestellung leisten?


Mfg, Floha
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11519
Joined: 2003-02-27 01:00
Location: Hamburg

Re: MySQL Update 4 auf 4.1 - SLES9

Post by Joe User »

Beide Pakete befinden sich auf den original SLES9-Installationsmedien:
http://www.novell.com/products/linuxpac ... x_all.html
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

Anonymous

Re: MySQL Update 4 auf 4.1 - SLES9

Post by Anonymous »

Ja jedoch komme ich damit wieder in meinen Abhängigkeitssumpf :?

error: Failed dependencies:
libc.so.6(GLIBC_2.3.4) is needed by procps-3.2.5-1.2
libc.so.6(GLIBC_2.3.4) is needed by pwdutils-2.6.4-2.25
liblber.so.199 is needed by pwdutils-2.6.4-2.25
libldap.so.199 is needed by pwdutils-2.6.4-2.25
libselinux.so.1 is needed by pwdutils-2.6.4-2.25
libslp.so.1 is needed by pwdutils-2.6.4-2.25

Was ich vergessen habe zu erwähnen: Es ist eine SLES9 SP3 Version.

GLIB 2.3.3 von den CDs funktioniert leider nicht.

Also Version 2.3.4 gesucht die ich nur fuer Suse 9.3 fand.

error: Failed dependencies:
libdb.so.2 is needed by (installed) webalizer-2.01-531
glibc = 2.3.2 is needed by (installed) glibc-locale-2.3.2-87
glibc = 2.3.2 is needed by (installed) glibc-devel-2.3.2-87

Weiteren Packete gesucht.

file /etc/ld.so.conf from install of glibc-2.3.4-23.4 conflicts with file from package aaa_base-9.0-6
file /etc/nsswitch.conf from install of glibc-2.3.4-23.4 conflicts with file from package aaa_base-9.0-6


Das ganze geht einfach immer so weiter und findet kein Ende :roll:

Ich würde das Ding am liebsten neu aufsetzen was jedoch leider nicht möglich ist.
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11519
Joined: 2003-02-27 01:00
Location: Hamburg

Re: MySQL Update 4 auf 4.1 - SLES9

Post by Joe User »

Dann versuche es mal mit den "Linux x86 generic RPM", erst die dynamisch gelinkten und wenn die ebenfalls nicht wollen mit den statisch gelinkten.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top