POP 3 und smtp funktionieren nach update nicht mehr

schluffi
Posts: 75
Joined: 2005-10-17 19:26

POP 3 und smtp funktionieren nach update nicht mehr

Post by schluffi »

Hallo Gemeinde,

habe heute wie schon so oft Systemupdates gefahren, und muss feststellen das der Mailserver nicht mehr funktioniert.

System ist ein Suse 9.3 auf dem aktuellen stand. Plesk habe ich in dem zuge auf die 8.01 upgedatet.

Das Update verlief gut, keine Fehler.

PHP hab ich in der version 4.4.0 neu kompiliert, läuft im CGI mode.

Ich kann mich mit einem Mail Client wenn ich abrufen möchte, nicht authentifizieren.

Mail info spuckt

pop3d System error 11: Resource temporarily unavailable
IMAP connect from @ clientip Error: HTTPD_LOG_D not defined

und

pop3d System error 11: Resource temporarily unavailable
IMAP connect from @ clientip Error: HTTPD_INCLUDE_D not defined

aus.

Ich kann weder versenden, noch empfangen über den Client. QMail läuft und und arbeitet die mails auch ab die vom System selber kommen, oder von Anwendungen die auf dem System laufen.

Greife ich per telnet auf port 110 zu, kann ich user und pass eingeben und bekomme folgende Fehlermeldung angezeigt:
Error: HTTPD_LOG_D not defined
System error 11: Resource temporarily unavailable


Verbindung zu Host verloren.
Greife ich per 25 auf den server zu, bekomme ich
relaylock: Error: HTTPD_LOG_D not defined
relaylock: Error: HTTPD_LOG_D not defined
sofort angezeigt.

Das passiert aus der ferne, sowie lokal auf der maschine.

Was kann das sein? Bin echt ratlos, sorry!
Top

schluffi
Posts: 75
Joined: 2005-10-17 19:26

Re: POP 3 und smtp funktionieren nach update nicht mehr

Post by schluffi »

So, mittlerweile habe ich das in den Griff bekommen.

Ich musste folgende Zeilen in die /etc/psa/psa.conf eintragen, damit das ganze wieder läuft
HTTPD_LOG_D /var/log

AWSTATS_ETC_D /etc

AWSTATS_BIN_D /var/lib

AWSTATS_TOOLS_D /var/lib

NAMED_ZONES_CONF /etc

NAMED_OPTIONS_CONF /etc
Aber jetzt mal im ernst, warum sagt mir QMAIL meinem Client, das diese Werte nicht definiert sind? Das ist doch wirklich nicht normal, oder?

Im vergleich zur psa.conf aus meinem Backup von letzter nacht stelle ich fest das diese einträge dort definitv nicht vorhanden sind.

Auf meinem Server gibt es noch eine neuerung:
relaylock: /var/qmail/bin/relaylock: mail from 217.129.168.176:63154 (cb-217-129-168-176.netvisao.pt)
Wenn ich mich richtig belesen habe, sind das Einträge, von mailservern die versuchen meinen server als offenes Relay zu missbrauchen, richtig? Ich hatte vor dem Update das relay zwar auch nicht offen, solche einträge in der mail.warn waren nicht vorhanden.

So, ein stressiger Arbeitstag neigt sich dem ende entgegen, wenn jemand Lust hat kann er noch versuchen mich aufzuklären, wie das mit der psa.conf passieren kann...

Allen einen schönen FA!

Gruss Manfred
Top