System zu 30% ausgelastet, aber kein Prozess dazu??

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
root-maxel
Posts: 43
Joined: 2003-05-08 13:18

System zu 30% ausgelastet, aber kein Prozess dazu??

Post by root-maxel »

Hallo!

Ich betreibe hier einen vmware GSX Server unter Debian 3.1. Nun ist mir gerade aufgefallen, das die Systemauslastung CPU so um die 30% liegt, es aber keinen Prozess gibt, der das verursacht??!!

Hier mal top output:

Code: Select all

Tasks:  83 total,   2 running,  81 sleeping,   0 stopped,   0 zombie
Cpu(s):  5.0% us, 27.9% sy,  0.0% ni, 66.6% id,  0.5% wa,  0.0% hi,  0.1% si
Mem:  10137052k total, 10127828k used,     9224k free,    11948k buffers
Swap: 13181292k total,  2518528k used, 10662764k free,  9474504k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
22176 root      16   0 18080  15m 7052 S  1.7  0.2 759:36.79 vmware-serverd
 4009 www-data  15   0 31752 7724  29m S  0.3  0.1 167:28.66 httpd
13400 vmware     5 -10 1167m 997m 1.0g S  0.3 10.1   6:30.25 vmware-vmx
 8177 root      16   0  2072 1060 1852 R  0.3  0.0   0:00.31 top
    1 root      16   0  1504  512 1352 S  0.0  0.0   0:02.15 init
    2 root      RT   0     0    0    0 S  0.0  0.0   0:02.53 migration/0
    3 root      34  19     0    0    0 S  0.0  0.0   0:00.33 ksoftirqd/0
    4 root      RT   0     0    0    0 S  0.0  0.0   0:01.44 migration/1
    5 root      34  19     0    0    0 S  0.0  0.0   0:00.04 ksoftirqd/1
    6 root      RT   0     0    0    0 S  0.0  0.0   0:00.97 migration/2
    7 root      34  19     0    0    0 S  0.0  0.0   0:00.03 ksoftirqd/2
    8 root      RT   0     0    0    0 S  0.0  0.0   0:01.04 migration/3
    9 root      34  19     0    0    0 S  0.0  0.0   0:00.03 ksoftirqd/3
   10 root       5 -10     0    0    0 S  0.0  0.0   0:00.79 events/0
   11 root       5 -10     0    0    0 S  0.0  0.0   0:00.01 events/1
   12 root       5 -10     0    0    0 S  0.0  0.0   0:00.00 events/2
   13 root       5 -10     0    0    0 S  0.0  0.0   0:00.00 events/3
auch ein ps -aux liefert mir in der Addition der CPU Werte nicht annähernd 30 %:

Code: Select all

myserver:~# ps axu
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  0.0  0.0  1504  512 ?        S    Sep25   0:02 init [2]
root         2  0.0  0.0     0    0 ?        S    Sep25   0:02 [migration/0]
root         3  0.0  0.0     0    0 ?        SN   Sep25   0:00 [ksoftirqd/0]
root         4  0.0  0.0     0    0 ?        S    Sep25   0:01 [migration/1]
root         5  0.0  0.0     0    0 ?        SN   Sep25   0:00 [ksoftirqd/1]
root         6  0.0  0.0     0    0 ?        S    Sep25   0:00 [migration/2]
root         7  0.0  0.0     0    0 ?        SN   Sep25   0:00 [ksoftirqd/2]
root         8  0.0  0.0     0    0 ?        S    Sep25   0:01 [migration/3]
root         9  0.0  0.0     0    0 ?        SN   Sep25   0:00 [ksoftirqd/3]
root        10  0.0  0.0     0    0 ?        S<   Sep25   0:00 [events/0]
root        11  0.0  0.0     0    0 ?        S<   Sep25   0:00 [events/1]
root        12  0.0  0.0     0    0 ?        S<   Sep25   0:00 [events/2]
root        13  0.0  0.0     0    0 ?        S<   Sep25   0:00 [events/3]
root        14  0.0  0.0     0    0 ?        S<   Sep25   0:00 [khelper]
root        15  0.0  0.0     0    0 ?        S<   Sep25   0:00 [kacpid]
root        40  0.0  0.0     0    0 ?        S<   Sep25   1:05 [kblockd/0]
root        41  0.0  0.0     0    0 ?        S<   Sep25   0:16 [kblockd/1]
root        42  0.0  0.0     0    0 ?        S<   Sep25   0:03 [kblockd/2]
root        43  0.0  0.0     0    0 ?        S<   Sep25   0:03 [kblockd/3]
root        55  0.0  0.0     0    0 ?        S    Sep25  20:20 [kswapd0]
root        56  0.0  0.0     0    0 ?        S<   Sep25   0:00 [aio/0]
root        57  0.0  0.0     0    0 ?        S<   Sep25   0:00 [aio/1]
root        58  0.0  0.0     0    0 ?        S<   Sep25   0:00 [aio/2]
root        59  0.0  0.0     0    0 ?        S<   Sep25   0:00 [aio/3]
root       195  0.0  0.0     0    0 ?        S    Sep25   0:00 [kseriod]
root       250  0.0  0.0     0    0 ?        S    Sep25   0:03 [kjournald]
root       778  0.0  0.0     0    0 ?        S    Sep25   0:00 [kjournald]
root       779  0.0  0.0     0    0 ?        S    Sep25   0:00 [kjournald]
root       780  0.0  0.0     0    0 ?        S    Sep25   0:02 [kjournald]
root       781  0.0  0.0     0    0 ?        S    Sep25   0:02 [kjournald]
root       782  0.0  0.0     0    0 ?        S    Sep25  13:58 [kjournald]
root      2697  0.0  0.0     0    0 ?        S    Sep25   0:00 [khubd]
root      3300  0.0  0.0     0    0 ?        S    Sep25   0:00 [phpd_event]
daemon    3427  0.0  0.0  1620  560 ?        Ss   Sep25   0:09 /sbin/portmap
root      3798  0.0  0.0  2264  844 ?        Ss   Sep25   0:02 /sbin/syslogd
root      3801  0.0  0.0  2440 1496 ?        Ss   Sep25   0:00 /sbin/klogd
Debian-   3836  0.0  0.0  5148 1724 ?        Ss   Sep25   0:00 /usr/sbin/exim4 -bd -q30m
root      3841  0.0  0.0  2240  728 ?        Ss   Sep25   0:02 /usr/sbin/inetd
root      3853  0.0  0.0  3472 1508 ?        Ss   Sep25   0:00 /usr/sbin/sshd
root      3857  0.0  0.0  2380  928 ?        Ss   Sep25   0:00 /sbin/rpc.statd
daemon    3860  0.0  0.0  1688  632 ?        Ss   Sep25   0:00 /usr/sbin/atd
root      3863  0.0  0.0  1768  820 ?        Ss   Sep25   0:00 /usr/sbin/cron
root      3904  0.0  0.0  1356  312 ?        S    Sep25   0:00 /usr/bin/vmnet-bridge -d /var/run/vmnet-bridge-0.pid /dev/vmnet0 eth0
root      3990  0.0  0.0 31928 5220 ?        Ss   Sep25   0:03 /usr/lib/vmware-mui/apache/bin/httpd -DSSL -DSSL_ONLY -DSTANDARD_PORTS -DES
root      4003  0.0  0.0  1504  488 tty1     Ss+  Sep25   0:00 /sbin/getty 38400 tty1
root      4004  0.0  0.0  1504  488 tty2     Ss+  Sep25   0:00 /sbin/getty 38400 tty2
root      4005  0.0  0.0  1504  488 tty3     Ss+  Sep25   0:00 /sbin/getty 38400 tty3
root      4006  0.0  0.0  1504  488 tty4     Ss+  Sep25   0:00 /sbin/getty 38400 tty4
root      4007  0.0  0.0  1508  492 tty5     Ss+  Sep25   0:00 /sbin/getty 38400 tty5
root      4008  0.0  0.0  1508  492 tty6     Ss+  Sep25   0:00 /sbin/getty 38400 tty6
www-data  4009  0.2  0.0 31752 7724 ?        S    Sep25 167:29 /usr/lib/vmware-mui/apache/bin/httpd -DSSL -DSSL_ONLY -DSTANDARD_PORTS -DES
root      4853  0.0  0.0  8820 3876 ?        Ss   Sep25   0:05 /usr/lib/vmware/bin/vmware-vmx -C /vmware/linuxguests/cvsserver/cvsserver.v
vmware    5025  0.0  0.0  8812 3900 ?        Ss   Sep25   0:05 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/adstest02/adstest02
vmware    5052  0.0  0.0  8816 3872 ?        Ss   Sep25   0:05 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/adstest01/adstest01
root     22176  1.1  0.1 18080 15564 ?       Ss   Sep26 759:38 /usr/sbin/vmware-serverd
lp       11906  0.0  0.0  2464  884 ?        Ss   Nov05   0:00 /usr/sbin/lpd -s
vmware   13347  0.0  0.8 1767012 90532 ?     S<s  Nov05   4:53 /usr/lib/vmware/bin/vmware-vmx -C /vmware/BPAVISREDHAT/rhel3.vmx -@ ""
vmware   13352  0.0  0.3 43076 36636 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   13375  0.0  5.1 641648 519508 ?     S<s  Nov05   3:25 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/bpavisxp/winXPPro.v
vmware   13380  0.0  0.1 18228 13188 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   13400  0.1 10.0 1195976 1021876 ?   S<s  Nov05   6:30 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/crossfire/winNetSta
vmware   13405  0.0  0.2 26260 21012 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   13462  0.0  2.5 380752 261612 ?     S<s  Nov05   3:56 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/tuoran/win2000Serv.
vmware   13467  0.0  0.0 14112 9052 ?        S<   Nov05   0:00 vmware [Floppy]
vmware   13489  0.0  0.6 269212 64948 ?      S<s  Nov05   1:51 /usr/lib/vmware/bin/vmware-vmx -C /vmware/linuxguests/debian-buld/debian-bu
vmware   13492  0.0  0.1 18236 12752 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   13516  0.1  5.4 663816 554864 ?     S<s  Nov05   7:54 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/mssql2005-portal/Sq
vmware   13519  0.0  0.1 18220 12920 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   13549  0.1 10.8 1232868 1103224 ?   S<s  Nov05   6:45 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/earth_new-msportal/
vmware   13554  0.0  0.2 26512 21132 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   13576  0.0  0.5 293748 53668 ?      S<s  Nov05   2:54 /usr/lib/vmware/bin/vmware-vmx -C /vmware/linuxguests/cvsserver-0/cvsserver
vmware   13581  0.0  0.0 14112 8996 ?        S<   Nov05   0:00 vmware [Floppy]
vmware   13607  0.0 12.5 1758552 1269376 ?   S<s  Nov05   3:49 /usr/lib/vmware/bin/vmware-vmx -C /vmware/linuxguests/bpavisredhatclone/rhe
vmware   13615  0.0  0.3 43096 37352 ?       S<   Nov05   0:00 vmware [Floppy]
vmware   11990  0.1  5.8 666852 591168 ?     S<s  Nov07   3:38 /usr/lib/vmware/bin/vmware-vmx -C /vmware/windowsguests/fitzitest-xppro/xpp
vmware   11993  0.0  0.1 18228 13148 ?       S<   Nov07   0:00 vmware [Floppy]
root     27522  0.0  0.0     0    0 ?        S    Nov08   0:08 [pdflush]
root      4394  0.0  0.0     0    0 ?        S    06:02   0:03 [pdflush]
root      7483  0.0  0.0  6044 1800 ?        Ss   11:39   0:00 sshd: root@pts/0
root      7485  0.0  0.0  2608 1448 pts/0    Ss   11:39   0:00 -bash
www-data  7510  0.0  0.1 41140 15928 ?       S    11:49   0:01 /usr/lib/vmware-mui/apache/bin/httpd -DSSL -DSSL_ONLY -DSTANDARD_PORTS -DES
www-data  7513  0.0  0.1 41108 15768 ?       S    11:49   0:00 /usr/lib/vmware-mui/apache/bin/httpd -DSSL -DSSL_ONLY -DSTANDARD_PORTS -DES
root      8183  0.0  0.0  2504  852 pts/0    R+   12:25   0:00 ps axu
myserver:~#
Wie ist das zu erklären?

Danke!

Maxel

mattiass
Userprojekt
Userprojekt
Posts: 608
Joined: 2005-12-16 17:57

Re: System zu 30% ausgelastet, aber kein Prozess dazu??

Post by mattiass »

root-maxel wrote:Hallo!

Ich betreibe hier einen vmware GSX Server unter Debian 3.1. Nun ist mir gerade aufgefallen, das die Systemauslastung CPU so um die 30% liegt, es aber keinen Prozess gibt, der das verursacht??!!

Wie ist das zu erklären?
Die Last wird vom Kernel erzeugt. Bspw. durch einen Paketfilter, der gerade zu tun hat oder sonst ein Modul (vmnet?).

root-maxel
Posts: 43
Joined: 2003-05-08 13:18

Re: System zu 30% ausgelastet, aber kein Prozess dazu??

Post by root-maxel »

Danke für die Antwort!

kann ich mir das irgendwie detailierter anzeigen lassen wer das genau verbraucht?

Maxel

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: System zu 30% ausgelastet, aber kein Prozess dazu??

Post by EdRoxter »

Die 30% sind von sy (System) ausgelastet, also grob Kernel und Module (je nachdem, was du mit deiner VMWare machst, durchaus plausibler Wert). Die laufenden Prozesse, die du in der Tabelle darunter siehst, schlagen sich auf den Prozentwert bei us (User) nieder.

Edith: Oh, zu spät. Man, seid ihr schnell.