Cron tut nicht mehr

Bash, Shell, PHP, Python, Perl, CGI
elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Cron tut nicht mehr

Post by elch_mg »

Namd,

hab das Problem das cron nichts mehr ausführt, was ich ihm aufgetragen habe. Es kommt wie es scheint bei jedem Eintrag nur - per syslog -

Code: Select all

Jul 26 22:10:01 t476 CRON[30371]: User account has expired
Jul 26 22:10:01 t476 CRON[30796]: User account has expired
Jul 26 22:10:01 t476 CRON[4640]: User account has expired
Jul 26 22:10:01 t476 CRON[10935]: User account has expired
Jul 26 22:10:01 t476 CRON[4556]: User account has expired
Jul 26 22:10:01 t476 CRON[29815]: User account has expired
Netterweise verrät mir cron nicht, welcher User account angeblich expired wäre.

Ich nehme an, dass dies mit meiner Umstellung auf pam_ldap zusammenhängt, und da irgendwo etwas hakt.
Alle Systemuser für Daemons wie www-data, munin etc. stehen nach wie vor in der /etc/passwd bzw. /etc/shadow - root natürlich auch - und der Rest befindet sich auf dem LDAP.
Da mir momentan etwas die Orientierung fehlt, und ich keinen Ansatzpunkt finde.. Was soll ich posten, welche Angaben fehlen noch?

Danke schonmal..
elch_mg
Posts: 302
Joined: 2006-01-23 19:14
Location: 41063

Re: Cron tut nicht mehr

Post by elch_mg »

Nennt mich Gott, wahlweise auch Idiot. Natürlich war pam schuld, allerdings etwas anders als ich es mir ausgemalt habe.
Die pam-config und cron spielten nicht ganz zusammen so wie sie sollten. Jetzt läuft es wieder.
Die laufende pam.d/cron.

//edit
Allerdings.. "User account has expired" ist natürlich nach wie vor eine tolle Fehlermeldung. Irgendjemand wird noch dafür sterben.