SMTP AUTH PROBLEM

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
phantom32
Posts: 29
Joined: 2005-01-03 23:06

SMTP AUTH PROBLEM

Post by phantom32 » 2006-06-15 16:41

Hallo Forum,

ich habe ein großes Problem mit SMTP AUTH. Ich kann leider keine Emails verschicken. In der /var/log/mail steht folgende Fehlermeldung:

-------------------------------------------------
Jun 15 16:35:08 h919681 postfix/smtpd[5972]: connect from pD9E826C4.dip0.t-ipconnect.de[217.232.38.196]
Jun 15 16:35:08 h919681 postfix/smtpd[5972]: warning: pD9E826C4.dip0.t-ipconnect.de[217.232.38.196]: SASL LOGIN authentication failed
Jun 15 16:35:08 h919681 postfix/smtpd[5972]: lost connection after AUTH from pD9E826C4.dip0.t-ipconnect.de[217.232.38.196]
Jun 15 16:35:08 h919681 postfix/smtpd[5972]: disconnect from pD9E826C4.dip0.t-ipconnect.de[217.232.38.196]
-------------------------------------------------


postconf -n gibt folgendes ergebnis:

-------------------------------------------------
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter =
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports =
disable_dns_lookups = no
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
message_size_limit = 10240000
mydestination = $myhostname, localhost.$mydomain
myhostname = h919681.serverkompetenz.net
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtp_use_tls = no
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, check_relay_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_use_tls = no
strict_rfc821_envelopes = no
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 450
-------------------------------------------------

Meine Konfiguration: ich möchte Postfix in Verbindung mit SASL nutzen. Qpopper kümmert sich um POP3 - das funktioniert auch ohne Probleme.

Sofern ich weitere Infos posten soll, lasst es mich bitte wissen.


Danke,
Sabine

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: SMTP AUTH PROBLEM

Post by duergner » 2006-06-15 17:10

Gegen was soll SASL authentifizieren? Achja und stell doch mal den Debug Level hoeher. Dann sieht man da auch mehr.

phantom32
Posts: 29
Joined: 2005-01-03 23:06

Re: SMTP AUTH PROBLEM

Post by phantom32 » 2006-06-15 17:14

duergner wrote:Gegen was soll SASL authentifizieren? Achja und stell doch mal den Debug Level hoeher. Dann sieht man da auch mehr.
Danke für die schnelle Antwort. Also, ich habe in der Datei /etc/postfix/sasl/smtpd.conf folgendes stehen:

------------------------------------------------
pwcheck_method: saslauthd
mech_list: PLAIN LOGIN
#saslauthd_path: /var/run/saslauthd/mux
autotransition: true
------------------------------------------------

Vielleicht noch folgendes als Info. Ich nutze auf dem Server Confixx und es sollen die Daten aus der virtualUsertable ausgelesen werden.

zu diesem zweck habe ich in der /etc/postfix/main.cf folgendes stehen:

virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains


Solltest Du weitere Infos benötigen, lass es mich bitte wissen - DANKE!

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: SMTP AUTH PROBLEM

Post by duergner » 2006-06-15 17:15

Aus welchen Quellen holt der saslauthd denn die Benutzerinformationen? Hast du das Zeug selber zusammengebastelt oder aus einem Howto abgeschrieben?

phantom32
Posts: 29
Joined: 2005-01-03 23:06

Re: SMTP AUTH PROBLEM

Post by phantom32 » 2006-06-15 17:22

duergner wrote:Aus welchen Quellen holt der saslauthd denn die Benutzerinformationen? Hast du das Zeug selber zusammengebastelt oder aus einem Howto abgeschrieben?
Hallo,

ich habe mich an diesem Howto orientiert.

Howto von: http://wiki.debianforum.de/PostfixSmtpAuth

Wenns irgendwo noch eine Alternative gibt - bin für jeden Tipp dankbar.Es fehlt ja eigentlich auch nicht viel, er scheint sich eben nur nicht autentifizieren zu können. Wenn ichs mit testsaslauthd ckecke, dann klappts einwandfrei. funktioniert nur nicht, wenn ich zb mit outlook eine mail versende. dann poppt nur das passwort dialogmenue auf. Hm...

DANKE NOCH MAL...!

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: SMTP AUTH PROBLEM

Post by flo » 2006-06-15 17:56

phantom32 wrote:

Code: Select all

pwcheck_method: saslauthd
mech_list: PLAIN LOGIN
#saslauthd_path: /var/run/saslauthd/mux
autotransition: true
Warum ist die Angabe des saslauthd_path ausdokumentiert?

flo.

phantom32
Posts: 29
Joined: 2005-01-03 23:06

Re: SMTP AUTH PROBLEM

Post by phantom32 » 2006-06-15 17:58

flo wrote:
phantom32 wrote:

Code: Select all

pwcheck_method: saslauthd
mech_list: PLAIN LOGIN
#saslauthd_path: /var/run/saslauthd/mux
autotransition: true
Warum ist die Angabe des saslauthd_path ausdokumentiert?

flo.
Hallo,

das war mein letzter Versuch. Habe das irgendwo gelesen. aber auch wenns nicht auskommentiert ist, geht es nicht :-(

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: SMTP AUTH PROBLEM

Post by flo » 2006-06-15 18:07

autotransition: If you enable that option with autotransition:true Postfix will also need to write to that file. This will not be needed in this HOWTO, but we'll prepare the sasldb for use of that option by setting correct r/w permissions.
Leier doch mal die Permissions der Files rüber ... läuft Postfix/smtp im chroot?

Und das mit dem Howto kann ja wohl nicht so sein :-) Das ist ja antik ...
cat /etc/default/saslauthd
# This needs to be uncommented before saslauthd will be run automatically
START=yes

# You must specify the authentication mechanisms you wish to use.
# This defaults to "pam" for PAM support, but may also include
# "shadow" or "sasldb", like this:
# MECHANISMS="pam shadow"

MECHANISMS="pam"
PARAMETERS="-n 2" # eventuell hier noch "-d" setzen und laufen lassen
flo.