Fehler zum frashclam unter SuSE 9.3 mit Plesk 7.5

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
robert1962
Posts: 34
Joined: 2005-10-05 14:41

Fehler zum frashclam unter SuSE 9.3 mit Plesk 7.5

Post by robert1962 » 2005-12-27 10:15

Hallo!

habe so eben auf meinem Root-Server ClamAV installiert. Auf dem Root-Server läuft qmail und Spamassis. Ich bin noch der HowTo's:
http://www.huschi.net/25_69_de.html und http://www.mittelstedt.net/clamplesk.html vorgegangen.
Installation lief ohne Fehler durch.
Wenn ich

Code: Select all

freshclam
aufrufe bekomme ich diese hier im Log:
--------------------------------------
ClamAV update process started at Tue Dec 27 09:58:52 2005
main.cvd is up to date (version: 34, sigs: 39625, f-level: 5, builder: tkojm)
daily.cvd updated (version: 1218, sigs: 2411, f-level: 6, builder: ccordes)
Database updated (42036 signatures) from database.clamav.net (IP: 62.26.160.3)
ERROR: Clamd was NOT notified: Can't connect to clamd on 127.0.0.1:3310
--------------------------------------
freshclam daemon 0.87.1 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
ClamAV update process started at Tue Dec 27 10:00:36 2005
main.cvd is up to date (version: 34, sigs: 39625, f-level: 5, builder: tkojm)
daily.cvd is up to date (version: 1218, sigs: 2411, f-level: 6, builder: ccordes)
--------------------------------------
Ich verstehe nicht, warum der
Error: Clamd was NOT notfied: Can't connect to clamd on 127.0.0.1:3310
erzeugt wird.

Kann mir da jemand mit Rat weiterhelfen?

Danke

Robert

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Fehler zum frashclam unter SuSE 9.3 mit Plesk 7.5

Post by Roger Wilco » 2005-12-27 19:31

Du solltest freshclam richtig konfigurieren. Vor allem die Direktive NotifyClamd ist für dich interessant...

robert1962
Posts: 34
Joined: 2005-10-05 14:41

Re: Fehler zum frashclam unter SuSE 9.3 mit Plesk 7.5

Post by robert1962 » 2005-12-28 04:37

Was ist denn falsch an der Howto? Dort wird doch erklärt was ich in der freshclam machen muss?

Schaue mir dir gleich noch mal an, wäre aber dankbar wenn du mir da etwas mehr sagen könntest.

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Fehler zum frashclam unter SuSE 9.3 mit Plesk 7.5

Post by Roger Wilco » 2005-12-28 13:09

Robert1962 wrote:Schaue mir dir gleich noch mal an, wäre aber dankbar wenn du mir da etwas mehr sagen könntest.
Was soll ich dazu noch mehr sagen? Freshclam versucht nach dem Update clamd mitzuteilen, dass neue Virendefinitionen vorhanden sind. Das funktioniert nicht, weil clamd nicht auf dem eingestellten Interface und Port läuft. Das sollst du in der freshclam.conf korrigieren...

robert1962
Posts: 34
Joined: 2005-10-05 14:41

Re: Fehler zum frashclam unter SuSE 9.3 mit Plesk 7.5

Post by robert1962 » 2005-12-28 13:31

Man vergessen!

Also war wohl nur beim ersten Start so, denn jetzt funktioniert es einwandfrei!

Weiß der Geier warum es so was, bekomme jetzt korrekte Meldungen das ein Update erfolgreich gemacht wurde, alles ohne ERROR!

Danke.