Autoresponder "Can't locate loadable object for module DBI in @INC"

Bash, Shell, PHP, Python, Perl, CGI
der dude
Posts: 114
Joined: 2005-03-04 18:46

Autoresponder "Can't locate loadable object for module DBI in @INC"

Post by der dude » 2005-12-17 18:48

Moin,

also ich habe mir jetzt schon die 80000 "Confixx Autoresponder Problem" Threads durchgelesen. Aber hierzu habe ich keine Lösung gefunden.

Ich habe:

Suse 9.2
Confixx 3.0.9
Postfix

Und wenn ich jetzt eine Mail an eine Adresse mit Autoresponder sende, erhalte ich folgendes:

Code: Select all

The Postfix program
 
<confixx-du-10@XXX> (expanded from
    <MAILADRESSE>): Command died with status 255:
    "/usr/bin/autoresponder.pl 10". Command output: Can't locate loadable
    object for module DBI in @INC (@INC contains:
    /usr/lib/perl5/5.8.5/i586-linux-thread-multi /usr/lib/perl5/5.8.5
    /usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi
    /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
    /usr/lib/perl5/vendor_perl/5.8.5/i586-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl .) at
    /usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi/DBI.pm line 254
    BEGIN failed--compilation aborted at
    /usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi/DBI.pm line 254.
    Compilation failed in require at /usr/bin/autoresponder.pl line 193. BEGIN
    failed--compilation aborted at /usr/bin/autoresponder.pl line 193.

Bisher war immer von Rechteprüblemen die Rede. Aber das hat auch nicht geklappt. /usr/bin/autoresponder.pl läuft als nobody:nobody mit 550. Ich habe aber auch schon mit 755 getestet. Aber das bringt auch nix.

Die Module wurden alle per YAST installiert. Ich habe die auch schon mit CPAN installiert. Aber das bringt auch nix.

Hat da noch jemand nen Rat für mich?

Gruß

hotzi
Posts: 197
Joined: 2004-04-14 09:04
Location: Bayern, Sulzemoos

Re: Autoresponder "Can't locate loadable object for module DBI in @INC"

Post by hotzi » 2005-12-28 19:10

Ohne detailiert angesehen zu haben:

1.) Confixx 3.1.2 ist aktuell
2.) Ich hatte mal mit dem Autoresponder Probleme, da fehlten doch nur noch ein paar Perl Packages.
3.) Frag das am besten mal im Confixx Webhostlist Forum, bzw suche mal dort.