Spamassasin: Mails eigener Mailserver nicht scannen

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
nightman
Posts: 37
Joined: 2003-05-30 22:29

Spamassasin: Mails eigener Mailserver nicht scannen

Post by nightman » 2005-10-24 09:59

Hallo

wir haben seid einiger Zeit auf unserem zentralen Mailserver Spamassassin am laufen. Des weiteren werden von allen Webservern die Mails zentral über den Mailserver verschickt (Smarthost). Dabei kommt es vor das zum Beispiel Mails wie Forenanmeldungen vom Spamassasin als Spam markiert werden obwohl diese von den eigenen Maschinen kommen. In der Local.cf hab ich unter Trusted network alle Server von uns angegeben. Trotzdem werden die mails der Systeme noch verarbeitet. Was kann ich noch tun damit die eigenen Mails vom Spamassasin nicht verarbeitet werden?

Vielen Dank für eure Hilfe im Vorraus.

Gruß
Marco

m.c.s.
Posts: 55
Joined: 2004-06-13 11:59
Location: Hamburg

Re: Spamassasin: Mails eigener Mailserver nicht scannen

Post by m.c.s. » 2005-10-24 10:35

Hi,

ich habe ein ähnliches Problem (allerdings Postfix) wie folgt gelöst:
Port 10025, auf dem Amavis seine Mails zurück an den MTA liefert, habe ich nicht an localhost gebunden, sondern an eth0. Außerdem habe ich mit iptables den Port 10025 nur für sich selbst sowie die IPs bestimmter Server freigegeben, so dass diese Mails direkt ohne den Umweg durch den Spamassassin versenden können.

Ob es elegant ist, keine Ahnung. Aber gerade bei Großversand tausender E-Mails ist das ganze so zumindest sehr schnell :)

Gruß
M.C.S.

dk79
Posts: 13
Joined: 2005-10-22 01:08

Re: Spamassasin: Mails eigener Mailserver nicht scannen

Post by dk79 » 2005-10-25 01:13

Hallo,

(Ich gehe von Postfix aus)
um eine Lösung dafür zu finden, welche für deine Situation akzeptabel
ist, solltest Du dir diese Dokumente durchlesen. (Mit den Infos
sollte es wirklich kein Thema mehr sein)

http://www.postfix.org/FILTER_README.html
http://www.ijs.si/software/amavisd/README.postfix

(Das hier sollte man in dem Zusammenhang zumindest einmal gelesen haben)
http://www.postfix.org/SMTPD_PROXY_README.html


Ein einfaches Bsp.(ohne Raffinessen), wie so ein Eintrag ausehen könnte (master.cf).
(Das geht natürlich alles noch viel ausgefeilter ;) und soll hier auch nur die Richtung aufzeigen. )

Code: Select all

pickup   fifo   n   -   -   60   1   pickup
        -o content_filter=
        -o receive_override_options=no_header_body_checks

nightman
Posts: 37
Joined: 2003-05-30 22:29

Re: Spamassasin: Mails eigener Mailserver nicht scannen

Post by nightman » 2005-10-25 07:59

Moin

wir haben leider kein Postfix. Wir nutzen laut Debianhowto das Exim4-Spamassassin gerüßt. Scheinbar hab ich heute Nacht unsere Probleme in den Griff bekommen. Spamassasssin fehlten trotz APT Installation noch ein Perl Modul. Hab den Fehler im Mail.err Logfile gefunden. Da gehts um ein Modul das Hostnamen auflöst. Tippe mal das daher das Modul nicht unseren Servernamen nach der IP auflösen könnte um dann die Trusted_Networks Option zu nutzen.

Gruß
Marco

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Spamassasin: Mails eigener Mailserver nicht scannen

Post by dodolin » 2005-11-02 00:43

Wann immer möglich sollte man in solchen Fällen nicht den SA entsprechend konfigurieren, sondern bereits im MTA einstellen, dass die entsprechenden Mails erst gar nicht durch SA geblasen werden. Gerade bei Exim sollte das wirklich ein leichtes Unterfangen sein.

nightman
Posts: 37
Joined: 2003-05-30 22:29

Re: Spamassasin: Mails eigener Mailserver nicht scannen

Post by nightman » 2005-11-05 12:38

Hi

wie könnte man das denn einstellen das der Exim bei den Servern den SpamAssasin ausläßt?

Wir haben den Mailserver nach der DebianHowTo Doku eingerichtet.

Vielen Dank für die Hilfe.

Gruß
Marco

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Spamassasin: Mails eigener Mailserver nicht scannen

Post by dodolin » 2005-11-05 21:47

Die entsprechende ACL Condition heisst hosts und ist in der Doku unter Abschnitt 39.20 gelistet.