HTML-Emails werden falsch gesendet (Quellcode???)

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
medienopfer98
Posts: 12
Joined: 2005-07-19 09:56
Location: Kronach

HTML-Emails werden falsch gesendet (Quellcode???)

Post by medienopfer98 » 2005-07-19 10:08

Erstmal vorne weg! Ja ich weis ein Rootserver ist nichts für mich! Bitte lasst mich jetzt nicht wieder erklären wieso ein Typ wie ich den Rootserver für die Firma administriert! Ich bin halt das Opfer... :? Wollte ich nur schonmal sagen, damit die Diskussion nicht darauf ausartet. Ich würde mich echt über Hilfe bei meinem Problem freuen...

Es geht um Postfix. Dieses scheint entweder einen Fehler zu haben, oder falsch konfiguriert zu sein. Wenn unser Kunde seinen HTML-Newsletter verschickt so kommt er als HTML Quellcode an?

Code: Select all

rom: info@domain.de
Message-ID: <2005070933.b0a5c@www.domain.de> X-Mailer: PHP-EMAIL on www.domain.de (webmaster@anderedomain.de) MIME-Version: 1.0 Content-Type: multipart/alternative; boundary="--e3cd2cbf63702dcb614110edd" 
 

----e3cd2cbf63702dc71411ce0e Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: 8bit  Sie haben von ichselbst@domain.de eine Grusskarte erhalten.

Hallo test  ----e3cd2cbf3702dc75b61411ce0e Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding: 8bit 
 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"> <html> <head> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> <title>:: Meine Website :: Newsletter Juni 2005 ::</title> <style type="text/css"> <!-- body { 	margin: 0px; 	padding: 0px; 	font-
Vielleicht kennt jemand das Problem oder könnte mir evtl. sagen wie und wo ich das ändern kann? :(

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: HTML-Emails werden falsch gesendet (Quellcode???)

Post by Roger Wilco » 2005-07-19 10:13

MEDIENOPFER98 wrote:Vielleicht kennt jemand das Problem oder könnte mir evtl. sagen wie und wo ich das ändern kann? :(
Das muss ein Clientproblem sein. Der MTA verändert die Mails (mal abgesehen von ein paar Recieved-Headern) nicht.

medienopfer98
Posts: 12
Joined: 2005-07-19 09:56
Location: Kronach

Aber,...

Post by medienopfer98 » 2005-07-19 10:15

ich hab das mailscript mal auf ein normales Paket von 1und1 gelegt und den newsletter abgeschickt und da gehts komischerweise...?

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Aber,...

Post by Roger Wilco » 2005-07-19 10:22

MEDIENOPFER98 wrote:ich hab das mailscript mal auf ein normales Paket von 1und1 gelegt und den newsletter abgeschickt und da gehts komischerweise...?
Na dann lass halt mal Details zu deiner Konfiguration sehen...

medienopfer98
Posts: 12
Joined: 2005-07-19 09:56
Location: Kronach

Mhh...

Post by medienopfer98 » 2005-07-19 10:44

Habe jetzt mit 1und1 telefoniert und die meinen ich muss in der main.cf von postfix irgenwelche parameter ändern um die mails in html umzuwandeln... bei google hab ich jetzt nichts gefunden... werde jetzt aber nochmal weiter suchen und geb dann beischeid. Ansonsten wenn jemand eine Idee hat???