Sendmail absturz...?

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
sziebeck
Posts: 9
Joined: 2003-06-26 12:01

Sendmail absturz...?

Post by sziebeck » 2005-07-14 10:19

Ich habe seit einiger Zeit ,das sendmail nach aussen hin nur Fehler anzeigt ,wenn ich senden möchte.

Restarte ich Sendmail ,dann gehts wieder einige Zeit .

Hilft euch vielleicht das err File? :

Code: Select all

Jun 21 20:44:03 london223 sendmail-client[3260]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 20:52:02 london223 sendmail-client[12885]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 20:54:02 london223 sendmail-client[14457]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 20:58:02 london223 sendmail-client[14759]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 21:00:51 london223 sendmail-client[15172]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 21:14:03 london223 sendmail-client[3258]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 21:52:09 london223 sendmail-client[4558]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 21:56:03 london223 sendmail-client[5226]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 21 22:04:02 london223 sendmail-client[5612]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 07:10:03 london223 sendmail-client[8009]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 07:13:19 london223 sendmail-client[14727]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 07:26:27 london223 sendmail-client[15188]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 07:32:34 london223 sendmail-client[15923]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 07:54:05 PowerServer sendmail-client[3259]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 08:35:31 PowerServer sendmail[5700]: j5M6ZQkr005694: SYSERR(root): mail.partyunited.de. config error: mail loops back to me (MX problem?)
Jun 22 08:36:05 PowerServer sendmail-client[4038]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 08:48:02 PowerServer sendmail-client[5817]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 09:04:04 PowerServer sendmail-client[6171]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 11:14:03 PowerServer sendmail-client[6601]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 12:54:40 PowerServer sendmail-client[9545]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 13:00:09 PowerServer imapd[4028]: Unable to load certificate from /etc/ssl/certs/imapd.pem, host=UNKNOWN
Jun 22 13:00:09 PowerServer imapd[4028]: SSL error status: error:02001002:system library:fopen:No such file or directory
Jun 22 13:00:09 PowerServer imapd[4028]: SSL error status: error:20074002:BIO routines:FILE_CTRL:system lib
Jun 22 13:00:09 PowerServer imapd[4028]: SSL error status: error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib
Jun 22 13:02:23 PowerServer sendmail-client[3619]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 22 13:08:47 PowerServer imapd[3755]: Unable to load certificate from /etc/ssl/certs/imapd.pem, host=UNKNOWN
Jun 22 13:08:47 PowerServer imapd[3755]: SSL error status: error:02001002:system library:fopen:No such file or directory
Jun 22 13:08:47 PowerServer imapd[3755]: SSL error status: error:20074002:BIO routines:FILE_CTRL:system lib
Jun 22 13:08:47 PowerServer imapd[3755]: SSL error status: error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib
Jun 23 08:43:22 PowerServer sendmail-client[3661]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 23 09:48:02 PowerServer sendmail-client[3665]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 24 16:14:03 PowerServer sendmail-client[4583]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 24 23:05:57 PowerServer sendmail-client[22134]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 24 23:08:57 PowerServer sendmail[3886]: j5OL8jII003830: SYSERR(root): mail.pc-freeze.de. config error: mail loops back to me (MX problem?)
Jun 25 00:13:34 PowerServer sendmail[4897]: j5OMDUpo004895: SYSERR(root): mail.pc-freeze.de. config error: mail loops back to me (MX problem?)
Jun 28 00:20:05 PowerServer sendmail-client[3661]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 30 12:34:04 PowerServer sendmail-client[31425]: persistent queue runner control process: lost all children: wait returned ECHILD
Jun 30 20:10:27 PowerServer sendmail-client[5324]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  3 09:18:51 PowerServer sendmail-client[3662]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  4 21:00:15 PowerServer sendmail-client[3619]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  4 21:46:42 PowerServer sendmail-client[3660]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  5 15:32:03 PowerServer sendmail-client[3640]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  5 15:44:03 PowerServer sendmail-client[15104]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  6 09:19:20 PowerServer procmail[27435]: Renamed bogus "/var/spool/mail/root" into "/var/spool/mail/BOGUS.root.oWsU"
Jul  7 19:18:04 PowerServer sendmail-client[15217]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  8 19:58:05 PowerServer sendmail-client[31991]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  8 21:14:02 PowerServer sendmail-client[20569]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 10:28:07 PowerServer sendmail-client[22004]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 11:04:04 PowerServer sendmail-client[3671]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 11:34:03 PowerServer sendmail-client[7171]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 22:58:58 PowerServer sendmail-client[8558]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 22:59:14 PowerServer sendmail-client[29193]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 23:04:54 PowerServer sendmail[29750]: j69L4qFJ029750: SYSERR(root): hash map "Alias0": missing map file /etc/aliases.db: No such file or directory
Jul  9 23:05:31 PowerServer sendmail-client[30274]: unable to write pid to /var/spool/clientmqueue/sm-client.pid: file in use by another process
Jul  9 23:05:34 PowerServer sendmail-client[29235]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 23:06:13 PowerServer sendmail-client[30317]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 23:11:18 PowerServer sendmail-client[3686]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul  9 23:34:26 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:26 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:34:31 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:31 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:34:36 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:36 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:34:41 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:41 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:34:46 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:46 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:34:51 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:51 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:34:56 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:34:56 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:35:01 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:35:01 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:35:06 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:35:06 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:35:11 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:35:11 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:35:16 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:35:16 PowerServer sendmail[5356]: daemon MTA: problem creating SMTP socket
Jul  9 23:35:16 PowerServer sendmail[5356]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
Jul  9 23:36:55 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:36:55 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:00 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:00 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:05 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:05 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:10 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:10 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:15 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:15 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:20 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:20 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:25 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:25 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:30 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:30 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:35 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:35 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:40 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:40 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:45 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Jul  9 23:37:45 PowerServer sendmail[5544]: daemon MTA: problem creating SMTP socket
Jul  9 23:37:45 PowerServer sendmail[5544]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
Jul  9 23:39:20 PowerServer sendmail-client[4151]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul 14 03:14:02 PowerServer sendmail[23953]: NOQUEUE: SYSERR(root): hash map "Alias0": unsafe map file /etc/aliases.db: Permission denied
Jul 14 03:14:02 PowerServer sendmail[23953]: NOQUEUE: SYSERR(root): Cannot create database for alias file /etc/aliases
Jul 14 03:14:02 PowerServer sendmail-client[5802]: persistent queue runner control process: lost all children: wait returned ECHILD
Jul 14 09:49:12 PowerServer sendmail-client[23969]: persistent queue runner control process: lost all children: wait returned ECHILD
Grüsse Sven

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Sendmail absturz...?

Post by squize » 2005-07-15 23:54

Wenn du das Log durchschaust, fallen doch gleich einige Fehler auf.
Wahrscheinlich hast du z.B. ein paar sendmailprozesse, die bereits an Port 25 hängen und deswegen ein Neustart nichts bringt, da der Port 25 ja immernoch besetzt ist.

Ich würde als erstes also mal schauen, was da am Port 25 hängt, wenn du sendmail über die Init-Skripte beendest.

Ein

Code: Select all

netstat -apn --protocol=inet | grep :25
Sollte dir zeigen, ob der Port immernoch belegt ist. Wenn ja, musst du die Prozesse erst entsorgen.
Ob die ganzen anderen Probleme darauf zurückzuführen sind, ist eine andere Frage.
mail.partyunited.de. config error: mail loops back to me (MX problem?)
DNS Config ist in Ordnung?
Unable to load certificate from /etc/ssl/certs/imapd.pem
Datei existiert?
/etc/aliases.db: No such file or directory
Existiert Datei?

Die grosse Frage ist im Prinzip, was den Unterschied zwischen "Es lief" und "Es macht jetzt Probleme" macht. Du musst ja wissen ab wann die Probleme auftraten und was du u diesem Zeitpunkt geändert hast ( Festplatte voll?).

Gruss

Marc