phpmyadmin: http auth problem

MySQL, PostgreSQL, SQLite
aliced
Posts: 14
Joined: 2005-06-30 10:13

phpmyadmin: http auth problem

Post by aliced » 2005-07-04 13:53

hi rooties,

leider bekomme ich den in den phpmyadmin docs beschriebenden http auth login nicht gebacken :(

Wie beschrieben habe ich einen controlluser angelegt

Code: Select all

GRANT USAGE ON mysql.* TO 'pma'@'localhost' IDENTIFIED BY 'pmapass';
GRANT SELECT (
    Host, User, Select_priv, Insert_priv, Update_priv, Delete_priv,
    Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv,
    File_priv, Grant_priv, References_priv, Index_priv, Alter_priv,
    Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv,
    Execute_priv, Repl_slave_priv, Repl_client_priv
    ) ON mysql.user TO 'pma'@'localhost';
GRANT SELECT ON mysql.db TO 'pma'@'localhost';
GRANT SELECT ON mysql.host TO 'pma'@'localhost';
GRANT SELECT (Host, Db, User, Table_name, Table_priv, Column_priv)
    ON mysql.tables_priv TO 'pma'@'localhost';
und diesen in die config.inc.php eingetragen...

Code: Select all

$cfg['Servers'][$i]['host']          = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port']          = '';          // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket']        = '';          // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension']     = 'mysql';     // The php MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['compress']      = FALSE;       // Use compressed protocol for the MySQL connection
                                                    // (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser']   = 'pma';          // MySQL control user settings
                                                    // (this user must have read-only
$cfg['Servers'][$i]['controlpass']   = 'pmapass';          // access to the "mysql/user"
                                                    // and "mysql/db" tables).
                                                    // The controluser is also
                                                    // used for all relational
                                                    // features (pmadb)
$cfg['Servers'][$i]['auth_type']     = 'http';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = '';      // MySQL user
$cfg['Servers'][$i]['password']      = '';          // MySQL password (only needed
                                                    // with 'config' auth_type)

zu testzwecken hab ich noch einen Benutzer "test" angelegt und eine datenbank "testuser".

über auth_type="config" kann ich mich mit diesem benutzer anmelden aber auth_type="http" lässt mich nicht reicht es kommt einfach immer wieder nur das login popup.

was mache ich falsch? was hab ich vergessen?

mysql-vers: 4.1.11
phpmyadmin: 2.6.2-pl1
php: 5.0.4

debian 3.1

User avatar
Joe User
Project Manager
Project Manager
Posts: 11597
Joined: 2003-02-27 01:00
Location: Hamburg

Re: phpmyadmin: http auth problem

Post by Joe User » 2005-07-04 14:59

Wenn Du entsprechend Deiner Konfiguration per Socket statt TCP auf den MySQLd zugreifen würdest, würde es auch funktionieren...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

mydani
RSAC
Posts: 228
Joined: 2003-08-18 19:34

Re: phpmyadmin: http auth problem

Post by mydani » 2005-07-04 15:05

<-- hat Sarge, mysqld und tcp! Und tut...

aliced
Posts: 14
Joined: 2005-06-30 10:13

Re: phpmyadmin: http auth problem

Post by aliced » 2005-07-04 15:05

*grr* wer lesen kann ist klar im vorteil :oops:

http://www.rootforum.org/forum/viewtop ... der+status

ich hab zwar in den docs von phpmyadmin nix dazu gefunden...aber wenns hier so steht wirds schon stimmen, jedenfalls mit cookie funktioniert jetzt alle wie gewünscht

mydani
RSAC
Posts: 228
Joined: 2003-08-18 19:34

Re: phpmyadmin: http auth problem

Post by mydani » 2005-07-04 15:06

AliceD wrote:jedenfalls mit cookie
Das hab ich zum Glück irgendwo gelesen ;)