[Fehlersuche] Server fährt nicht mehr hoch

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
matzel78
Posts: 17
Joined: 2004-12-21 02:15
Location: Moers

[Fehlersuche] Server fährt nicht mehr hoch

Post by matzel78 »

Hallo!

Ich habe ein Problem: mein Rootserver hat durch den exploit von der alten AWStats Version einen Angriff erlitten (ging auf meine Kappe). Es wurde unter anderem ein IRC-ShareBot installiert und Rathole. Nachdem wir das Loch gestopft haben und alle unerwünschten Programme mit Hilfe des Rescue Systems gelöscht haben, wollten wir (mein Co-Admin und ich) den Server wieder mit dem Standardsystem (Fedora 3 - 2.6.9-1.667) booten. Allerdings kommt der nicht mehr. Beim Hochfahren wird noch nicht einmal in die log-Dateien geschrieben, also kommt es garnicht zum starten des logdeamons, richtig ? Deswegen wollte ich mal ein paar Tipps einholen, wie man jetzt am besten vorgeht.

Das /boot Verzeichnis mit einem frischen Kernel versehen ? So scheinen die Dateien und die Grubconfig in Ordnung zu sein.

Ich hoffe ihr könnt mich mit ein paar Tipps versorgen, weil so ein Problem musste ich noch nicht lösen und steh ein wenig auf dem Schlauch,[/quote]

chris76
Posts: 1878
Joined: 2003-06-27 14:37
Location: Germering

Re: [Fehlersuche] Server fährt nicht mehr hoch

Post by chris76 »

In Deinem Fall ist Neu initialisieren lassen das einzig richtige aufgrund der Vorkommnisse.
Gruß Christian

BofH excuses: YOU HAVE AN I/O ERROR -> Incompetent Operator error

matzel78
Posts: 17
Joined: 2004-12-21 02:15
Location: Moers

Re: [Fehlersuche] Server fährt nicht mehr hoch

Post by matzel78 »

Ã?ber kurz oder lang werde ich sicherlich nicht darauf verzichten können, aber mich interessiert im Moment eher die Herausforderung das alte System wieder hochzubringen, um wieder einmal meine Linuxerfahrung auszubauen. Danach wird sicherlich das System plattgemacht und neu aufgesetzt (diesmal mit md5 checksums).

thorsten
Posts: 561
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: [Fehlersuche] Server fährt nicht mehr hoch

Post by thorsten »

solche Versuche solltest du an einem LAN Server machen - nicht bei einem rooty im Web.
Boote in die Rescueconsole, mach eine abschließende Datensicherung und beantrage die Neuinstallation.

Im chroot kann ein dpkg --get-selections und die Sicherung von /etc eine Hilfe bei der Neuinstallation sein.

Aber laß die Kiste aus - das bringt keinem etwas da weiter rumzufummeln.