Spamassassian will nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
alexnbg
Posts: 60
Joined: 2004-03-16 11:21

Spamassassian will nicht

Post by alexnbg » 2005-05-16 02:09

Hi zusammen,

ich tu nun schon ewig mit dem Spamassassian rum. Seit der Neuinstallation des Systems bekomm ich es einfach nicht mehr zum laufen.

Suse 8.2, Postfix, amavisd, clamav und spamassassian sind installiert.

Amavis und ClamAV funktionieren einwandfrei.

Hab auch schon sämtlich Seiten im Internet durch und es will trotzdem nicht. In den logs sind auch keine Fehlermeldungen drin.

Hab auch schon mit echo getestet und folgendes erhalten :

Code: Select all


95171:/etc/postfix # echo "Das ist ein Test" | spamassassin
Created user preferences file: /root/.spamassassin/user_prefs
X-Mail-Format-Warning: Bad RFC2822 header formatting in Das ist ein Test
X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on
        95171.xxx.de
X-Spam-Level: **
X-Spam-Status: No, hits=2.9 required=5.0 tests=DATE_MISSING,FROM_NO_LOWER
        autolearn=no version=2.63
Auch wenn ich diverse Testmail mit mehr als genug Spaminhalt schicke, makiert er es nicht als Spam. Spamdeamon läuft.

Hier mal meine Konfig Files. Evtl hab ich ja da was übersehen :
Auszug auf postfix/main.cf

Code: Select all

content_filter = smtp-amavis:[127.0.0.1]:10024
mailbox_command = /usr/bin/procmail
master.cf

Code: Select all

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = 95171.xxx.de
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
mydestination = $myhostname, localhost.$mydomain
defer_transports =
#
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o smtpd_error_sleep_time=0
    -o smtpd_soft_error_limit=1001
    -o smtpd_hard_error_limit=1000
Auszug etc/amavisd.conf

Code: Select all

# SpamAssassin settings

# $sa_local_tests_only is passed to Mail::SpamAssassin::new as a value
# of the option local_tests_only. See Mail::SpamAssassin man page.
# If set to 1, no tests that require internet access will be performed.
#
$sa_local_tests_only = 1;   # (default: false)

$sa_timeout = 30;           # timeout in seconds for a call to SpamAssassin
                            # (default is 30 seconds, undef disables it)
$sa_mail_body_size_limit = 150*1024; # don't waste time on SA if mail is larger
                            # (less than 1% of spam is > 64k)
                            # default: undef, no limitations

# default values, can be overridden by more specific lookups, e.g. SQL
$sa_tag_level_deflt  = 3.0; # add spam info headers if at, or above that level
$sa_tag2_level_deflt = 5.0; # add 'spam detected' headers at that level
$sa_kill_level_deflt = 20.0; # triggers spam evasive actions
                            # at or above that level: bounce/reject/drop,
                            # quarantine, and adding mail address extension

$sa_dsn_cutoff_level = 10;  # spam level beyond which a DSN is not sent,
                            # effectively turning D_BOUNCE into D_DISCARD;
                            # undef disables this feature and is a default;

# string to prepend to Subject header field when message exceeds tag2 level
$sa_spam_subject_tag = '***SPAM*** ';   # (defaults to undef, disables)
                             # (only seen when spam is not to be rejected
                             # and recipient is in local_domains*)

$sa_spam_modifies_subj = 1; # may be a ref to a lookup table, default is true
etc/mail/spamassassian

Code: Select all

# Encapsulate spam in an attachment
report_safe             1

# Use terse version of the spam report
use_terse_report        0

# How many hits before a message is considered spam.

required_hits           5.0

# Whether to change the subject of suspected spam

rewrite_subject         0

# Text to prepend to subject if rewrite_subject is used

subject_tag             *****SPAM*****

# Mail using languages used in these country codes will not be marked
# as being possibly spam in a foreign language.

ok_languages            all

# Mail using locales used in these country codes will not be marked
# as being possibly spam in a foreign language.

ok_locales              all
Fehlt noch irgendwas?

Ich hoffe mir kann jemand helfen.
Danke

Gruß

Alex

alexnbg
Posts: 60
Joined: 2004-03-16 11:21

Re: Spamassassian will nicht

Post by alexnbg » 2005-05-16 02:21

Hab im log file mail.info gerade folgenden eintrag gefunden :

Code: Select all

May 16 01:20:19 95171 amavis[6486]: (06486-03) spam_scan: hits=10.196 tests=CASHCASHCASH,FOR_FREE,GUARANTEE,HTML_FONTCOLOR_BLUE,HTML_FONTCOLOR_GREEN,HTML_FONTCOLOR_RED,HTML_MESSAGE,LOCAL_DRUGS_MALEDYSFUNCTION,LOCAL_DRUGS_MALEDYSFUNCTION_OBFU,SUBJ_HAS_SPACES,SUBJ_HAS_UNIQ_ID,UPPERCASE_25_50,VIAGRA
Aber die Testmail ging trotzdem durch und im Header war auch nix von einem Spam Scan zu lesen.

Gruß

Alex

alexnbg
Posts: 60
Joined: 2004-03-16 11:21

Re: Spamassassian will nicht

Post by alexnbg » 2005-05-16 15:43

Hi,

hab den Fehler gefunden.

hatte bei mailbox_command den -a "$EXTENSION" vergessen.

Jetzt hab ich aber noch ne andere Frage :

Im Spam Header steht jetzt immer :

Code: Select all

X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on
        95171.xxx.de
Wie bekomm ich das 95171.xxx.de raus? oder kann ich es irgendwie ändern?

Danke

Gruß

Alex