sendmail+mailscanner

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
tho
Posts: 15
Joined: 2003-03-23 13:15
Location: Baden Württemberg

sendmail+mailscanner

Post by tho » 2004-12-02 21:14

Hallo,

ich habe ein Problem mit Sendmail + mailscanner. :cry:

Installation lief normal.
Wenn ich mir einen Virus schicke, dann kommt die trotzdem normal an.

Mail Log:
Dec 4 01:28:42 vs147017 sendmail-in[17154]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
Dec 4 01:28:58 vs147017 smtp[29121]: iB40SvOZ029121: from=<thomas@pg-tw-computer.com>, size=1171, class=0, nrcpts=1, msgid=<200412040029.iB40TSMr012840@serve
r1.pg-computerservice.de>, proto=ESMTP, relay=server1.pg-computerservice.de [217.172.181.138]
Dec 4 01:28:58 vs147017 smtp[29253]: iB40SvOZ029121: to=<webmaster@pg-tw-webhosting.de>, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=31425, dsn=2.0.0,
stat=Sent
Dec 4 01:36:39 vs147017 MailScanner[23194]: MailScanner child caught a SIGHUP
Dec 4 01:36:39 vs147017 MailScanner[18115]: MailScanner child caught a SIGHUP
Dec 4 01:36:39 vs147017 MailScanner[26467]: MailScanner child caught a SIGHUP
Dec 4 01:36:39 vs147017 MailScanner[27395]: MailScanner child caught a SIGHUP
Dec 4 01:36:39 vs147017 MailScanner[26115]: MailScanner child caught a SIGHUP
Dec 4 01:36:49 vs147017 sendmail-in[6081]: starting daemon (8.12.10): SMTP
Dec 4 01:36:49 vs147017 sendmail-in[6081]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Dec 4 01:36:49 vs147017 sendmail-in[6081]: daemon MTA: problem creating SMTP socket
Dec 4 01:36:49 vs147017 sendmail-client[6146]: starting daemon (8.12.10): persistent-queueing@00:30:00
Dec 4 01:36:49 vs147017 sendmail-out[6275]: starting daemon (8.12.10): queueing@00:30:00
Dec 4 01:36:53 vs147017 MailScanner[7011]: MailScanner E-Mail Virus Scanner version 4.36.4 starting...
Dec 4 01:36:53 vs147017 MailScanner[7011]: Using locktype = flock
Dec 4 01:36:54 vs147017 sendmail-in[6081]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use
Dec 4 01:36:54 vs147017 sendmail-in[6081]: daemon MTA: problem creating SMTP socket
Dec 4 01:36:59 vs147017 sendmail-in[6081]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Address already in use

Kann mir jemand helfen? :-D

Vielen Dank schon mal, ich komme echt nicht weiter! :(

Viele Grüße
Thomas

tho
Posts: 15
Joined: 2003-03-23 13:15
Location: Baden Württemberg

Re: sendmail+mailscanner

Post by tho » 2004-12-04 13:24

Hat denn keiner einen Tipp für mich? :(

pg-computer
Posts: 144
Joined: 2002-09-27 19:28
Location: Drebach / Erzgebirge

Re: sendmail+mailscanner

Post by pg-computer » 2004-12-04 16:57

Hoi Hoi,

prüf mal ob evtl. Sendmail per xinetd gestartet wird und hau das dort mal raus, der Mailscanner versucht evtl. Sendmail als Daemon zu starten...
Die Fehlermeldung besagt ja, dass auf Port 25 bereits ein Dienst einen "Listener" hat.

Gruß,

Peter

tho
Posts: 15
Joined: 2003-03-23 13:15
Location: Baden Württemberg

Re: sendmail+mailscanner

Post by tho » 2004-12-05 00:40

Hoi Peter,

dein Tipp hat das Problem gelöst.

Vielen Dank!
Thomas