mail wird im falschen Format versandt (BASE64 anstatt 8bit)

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

mail wird im falschen Format versandt (BASE64 anstatt 8bit)

Post by cipi » 2004-11-17 01:51

hallo und guten morgen,

seit einiger Zeit habe ich ein mittelschweres Problem mit meinem Server. Wenn ich via php eine Mail verschicken will, kommt untenstehende Mail an.
Irgendwie ist das aber nicht richtig codiert ...
Auch nach Suche hier im Forum hab ich keine Lösung gefunden. Selbst wenn ich in der mail() -funktion
Content-type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit
hinzufüge, funktioniert es nicht. Hat vielleicht jemand ne Idee, was ich wo zu ändern habe?

Code: Select all

Return-Path: <wwwrun@pxxxxxxx.pureserver.info>
Delivered-To: postmaster@domain.de
Received: (qmail 16965 invoked by uid 1003); 17 Nov 2004 00:01:05 -0000
Received: from 217.160.xxx.xxx by domain.de (envelope-from <wwwrun@pxxxxxxxx.pureserver.info>, uid 89) with qmail-scanner-1.23 
 (f-prot: 4.4.7/3.14.13. spamassassin: 3.0.0.  
 Clear:RC:0(217.160.xxx.xxx):SA:0(-102.5/3.5):. 
 Processed in 4.002998 secs); 17 Nov 2004 00:01:05 -0000
X-Envelope-From: wwwrun@pxxxxxxxx.pureserver.info
Received: from unknown (HELO pxxxxxx.pureserver.info) (217.160.xxx.xxx)
  by domain.de with SMTP; 17 Nov 2004 00:01:00 -0000
Received: by pxxxxxxxx.pureserver.info (Postfix, from userid 30)
	id 7EE881004CE4; Wed, 17 Nov 2004 01:01:00 +0100 (CET)
To: postmaster@domain.de
Subject: seitenaufruf
From: webmaster@anderedomain.de
X-Mailer: PHP/4.3.9
Mime-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: BASE64
Message-Id: <20041117000100.7EE881004CE4@pxxxxxxxx.pureserver.info>
Date: Wed, 17 Nov 2004 01:01:00 +0100 (CET)
X-Spam-Checker-Version: SpamAssassin 3.0.0 (2004-09-13) on domain.de
X-Spam-Status: No, hits=-102.5 required=3.5 tests=ALL_TRUSTED,NO_REAL_NAME,
	USER_IN_WHITELIST autolearn=failed version=3.0.0
X-Spam-Level: 


SVAtQWRyZXNzZToJNjIuMjE0LjIyNC4xODIKSG9zdG5hbWU6CQp2aWEgUHJveHk6CQoKUmVxdWVz

dGVkIFVSTDoJL21haWwucGhwClJlZmVyaW5nIFVSTDoJCkJyb3dzZXI6CU1vemlsbGEvNS4wIChX

aW5kb3dzOyBVOyBXaW5kb3dzIE5UIDUuMTsgZGUtREU7IHJ2OjEuNy41KSBHZWNrby8yMDA0MTEw

OCBGaXJlZm94LzEuMAo=

und hier, wie ich die Mail verschicke:

Code: Select all

<?
$msg = "IP-Adresse:t$REMOTE_ADDRn"; // IP-Adresse
$msg .= "Hostname:t$REMOTE_HOSTn"; // Host Name
$msg .= "via Proxy:t$HTTP_VIAnn"; // Proxy-Adresse
$msg .= "Requested URL:t$REQUEST_URIn"; // URL der Datei die angefordert wurde
$msg .= "Refering URL:t$HTTP_REFERERn"; // URL die auf diese Datei verweist
$msg .= "Browser:t$HTTP_USER_AGENTn"; // Verwendeter Browser


mail ("postmaster@domain.de", "seitenaufruf", $msg,"From: webmaster@$SERVER_NAMEnReply-To: webmaster@$SERVER_NAMEnX-Mailer: PHP/" . phpversion() );

echo "mail verschickt!";
?>
Vielen Dank im voraus!

cipi

erland
Posts: 21
Joined: 2004-11-22 00:08

Re: mail wird im falschen Format versandt (BASE64 anstatt 8bit)

Post by erland » 2004-11-22 00:11

Das gleiche Problem habe ich auch. Bisher aber noch keine Lösung gefunden.
Nutze übrigens Confixx.

Vielleicht ist ja die Sprache des Servers verstellt, bloß wie ändert man diese wieder zurück?

cipi
Posts: 39
Joined: 2002-10-25 01:15
Location: Karlsruhe

erledigt

Post by cipi » 2004-11-22 18:38

hatte in der php.ini folgenden Eintrag korrigiert auf:
mbstring.internal_encoding = ISO-8859-1

Jetzt gehts wieder.