PHP 4.3.8 RPM instabil ??

Bash, Shell, PHP, Python, Perl, CGI
Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

PHP 4.3.8 RPM instabil ??

Post by Outlaw »

Hallo Leute,

ich hatte ja mit dem alten Image extreme Probleme den Apachen am Leben zu erhalten. Nach nem Plattencrash habe ich ein neues Image bekommen, was auch bis vor kurzem prima lief, trotz einiger Updates.

Nun geht die Geschichte wieder los und zwar seit dem Update auf PHP 4.3.8. Unter dem Standar installiertem 4.3.1 der Distri gab es nie Probleme.

Ok, viele sagen jetzt wieder, daß es am LogRotate liegt aber daran glaube ich fast nicht mehr, denn bisher gings ja auch ohne Ã?nderungen des Logrotate.

Hier der einzigste Eintrag in einem LOG:
(Damals beim alten Image gab es nicht mal Einträge (Logrotate))

Code: Select all

[Sun Jul 18 00:15:10 2004] [notice] SIGUSR1 received.  Doing graceful restart
[Sun Jul 18 00:18:43 2004] [warn] NameVirtualHost 217.160.208.145:80 has no Virt
ualHosts
[Sun Jul 18 00:18:43 2004] [warn] pid file /var/run/httpd.pid overwritten -- Unc
lean shutdown of previous Apache run?
[Sun Jul 18 00:18:44 2004] [notice] Apache/1.3.31 (Linux/SuSE) mod_ssl/2.8.18 Op
enSSL/0.9.6i mod_python/2.7.10 Python/2.2.2 PHP/4.3.8 mod_perl/1.27 configured -
- resuming normal operations
[Sun Jul 18 00:18:44 2004] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin
/suexec)
[Sun Jul 18 00:18:44 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
Und das sieht noch nicht mal aus, als ob das den STOP des Apachen verursacht hätte ....

Hat jemand ähnliche Erfahrungen gemacht ??

Gruß Outi
Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: PHP 4.3.8 RPM instabil ??

Post by Outlaw »

Ach so:

SuSE 8.2 / Apache 1.3.31 / PHP 4.3.8 RPM laut meinem HowTo (neu)

Gruß Outi

(Bis zum PHP Update keinerlei Probleme)
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: PHP 4.3.8 RPM instabil ??

Post by arty »

Hi,

also ich hab keine Probleme mit PHP 4.3.8....

bye
arty
l4a-shadow
Posts: 23
Joined: 2002-12-17 23:16

Re: PHP 4.3.8 RPM instabil ??

Post by l4a-shadow »

Also das Problem hab ich auch mit PHP 4.3.8 und dem Apachen.
Hab jetzt erstmal wieder auf 4.3.1 zurück gepatcht und muss demnächst mal schauen, ob ich die Lösung finde.

Allerdings nutz ich noch einen etwas älteren Apache.
kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: PHP 4.3.8 RPM instabil ??

Post by kostya »

SuSE 9.0, Apache 2.0.50 (RPM) , PHP 4.3.8 (RPM), Zend Optimizer 2.5.3 machen bei mir gar keine Probleme auf einem sehr von Usern beanspruchten Rootserver.
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: PHP 4.3.8 RPM instabil ??

Post by arty »

PHP unter 4.3.8 hat aber einige üble Sicherheitslücken, eine Version darunter würde ich nicht einsetzen.

bye
arty
l4a-shadow
Posts: 23
Joined: 2002-12-17 23:16

Re: PHP 4.3.8 RPM instabil ??

Post by l4a-shadow »

Würde ich auch nicht, wenn mein apache nicht immer abschmieren würde. Solange ich das Problem nicht lösen kann, muss ich es leider einsetzen.
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: PHP 4.3.8 RPM instabil ??

Post by arty »

Hi,

du lässt also lieber deinen Server angreifbar? Mutig.

bye
arty
Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: PHP 4.3.8 RPM instabil ??

Post by Swiper »

Hi !

Habe mir mal Outi's 4.3.8 RPM Howto etwas genauer angesehen und danach meinen 1&1 mit 9.0 und 4.3.3 geuppt.

Sieht so aus als würde noch alles laufen. Nur die phpinfo zeigt mir immer noch Version 4.3.3 an.

Code: Select all

rpm -Uvh *rpm
warning: mod_php4-4.3.8-1.i586.rpm: V3 DSA signature: NOKEY, key ID efb694ea
Preparing...                ########################################### [100%]
   1:mod_php4-core          ########################################### [ 33%]
warning: /etc/php.ini saved as /etc/php.ini.rpmsave
   2:mod_php4               ########################################### [ 67%]
Updating etc/sysconfig/apache...
   3:mod_php4-devel         ########################################### [100%]
Das WARNING sah mir jetzt nicht wirklich wichtig aus ;)
Habe ich irgendwas vergessen ?

Cu Sven
Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: PHP 4.3.8 RPM instabil ??

Post by Swiper »

OOOOOOOOOOOOha !

Habe einen reBoot gemacht und nu iss er hin !

Bekomme jetzt bei jeder Domain auf die ich zugreife nur noch den Index angezeigt wo NUR das Verzeichnis webalizer/ drin steht.
Also das sollte die srv/www/htdocs/ sein

PHPinfo sagt nun 4.3.8 allerdings mit APACHE 1.3.28.
Vorher hatten wir Apache 2.0.48 und deshalb wird er wohl auch keine configs mehr finden :twisted:
Ich hoffe das ist jetzt nur einstellungssache ! Kann mir bitte jemand helfen ?
User avatar
Joe User
Project Manager
Project Manager
Posts: 11176
Joined: 2003-02-27 01:00
Location: Hamburg

Re: PHP 4.3.8 RPM instabil ??

Post by Joe User »

man docroot

rpm -e --nodeps mod_php4-core mod_php4 mod_php4-devel
rpm -ivh mod_php4-%OLDVERSION%.rpm
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: PHP 4.3.8 RPM instabil ??

Post by Swiper »

Code: Select all

Shutting down httpd                                                                                             done
Starting httpd []                                                                                               failed
File "//etc/httpd/mod_php4.conf", included from /etc/httpd/suse_include.conf, can't be found...
You likely need to run "SuSEconfig --module apache".
Ohoh.... Kann ich nicht einfach wieder den Apachen2 aktivieren und den 1.3.28 raus schmeissen.. Dann müsste es doch wieder gehn ?!

Weil irgendwie wird auf die /etc/http/ verwiesen und nicht auf die /etc/apache2/
Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: PHP 4.3.8 RPM instabil ??

Post by Swiper »

Ich habe jetzt einfach mal die APACHE 2.0.50 RPM's installiert und danach einen 'SuSEconfig --module apache2' gemacht. System rebootet und schon lief es wieder.
Warum ich nun aber wieder PHP 4.3.3 drauf habe weis ich einfach nicht.
Wird wohl daran liegen das das 4.3.8 RPM mit Apache 1 Verknüpfelt ist und das der Apache 2 mit dem 4.3.3.

Nun bin ich nicht viel weiter wie vorher..

Gibts noch ne sichere möglichkeit jetzt nun doch 4.3.8 drauf zu ziehen ?
kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: PHP 4.3.8 RPM instabil ??

Post by kostya »

Du hast von Anfang an falsche rpm installiert. Für Apache2 hättest du folgende installieren müssen:

apache2-mod_php4-4.3.8-1.i586.rpm
mod_php4-core-4.3.8-1.i586.rpm
eventuell noch devel...
Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: PHP 4.3.8 RPM instabil ??

Post by Outlaw »

Ok, hab nochmal nen Hinweis reingemacht, daß sich die RPMs auf die 1er Apache Version beziehen ....

Habe jetzt testhalber auch mal kurz die alte PHP Version wieder draufgemacht und getestet und is prima durchgelaufen ....

Kann man eigentlich den Inhalt von cron.daily auch manuell irgendwie starten, ohne gleich ein Skript dafür zu schreiben ?? Würde das gerne manuell simulieren, damit ich nächste Woche mal ausgiebig testen kann.

Was mir aufgefallen ist (auch früher vor dem letzten Image), daß alle nachträglich installierten PHP RPM Versionen Probleme verursacht haben (beim, während oder nach dem Logrotate). Hat man wieder die Distri Version installiert, war alles wieder ok.

Am Apachen liegt es anscheinend nicht, denn den 1.3.31er habe ich auch per RPM upgedated und der lief auch ohne Probleme bis eben zu diesem PHP Update. Auch die Distri Version 1.3.27 lief bis zum Update und danach nicht mehr zuverlässig.

Kann das mal einer erklären ??

Beim SuSEconfig wird doch die Apachesektion mit berücksichtigt, daher müsste ich doch eigentlich ohne Apache Reinst. per RPM auskommen, oder nicht ??

Gruß Outi
Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: PHP 4.3.8 RPM instabil ??

Post by Swiper »

Code: Select all

Starting SuSEconfig, the SuSE Configuration Tool...
Running module apache2 only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.apache2...
Looking for multi-processing modules (MPM)...
  1 MPM installed (prefork)
  APACHE_MPM is unset (/etc/sysconfig/apache2), picked "prefork"
  create symbolic link `/usr/sbin/httpd2' to `/usr/sbin/httpd2-prefork'
Finished.
Habe jetzt das Apache2 RPM geleecht und vermutlich auch richtig installt.

Nun habe ich ein SuseConfig gemacht und zusätzlich noch den Server rebooted.

Aber leider immer noch PHP 4.3.3
Irgendwie mache ich da wieder was falsch