Ich springe gleich aus dem Fenster :(( Postfix "make&qu

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
dumpfbacke
Posts: 43
Joined: 2004-03-13 22:31

Ich springe gleich aus dem Fenster :(( Postfix "make&qu

Post by dumpfbacke » 2004-07-02 22:21

Nabend ich hoffe es kann mir jemand um diese Uhrzeit noch ein wenig weiterhelfen. Ich bin dabei Postfix neu zu Installieren da doe version die vorhanden war etwas älter war.

Als erstes habe ich versucht nach diesem tut zu gehen

http://www.rootforum.org/faq/index.php ... 41&lang=de

Doch bei make bekomme ich sämtliche Fehlermeldungen. Ich habe das ganze Forum abgegrasst und alle Varianten die hier drin stehen ausprobiert. Es sind bei mir alle Devel, sasl .... packete Installiert.

Ich habe ihn nun soweit das er nur noch eine Fehlermeldung bei allen Varianten die es hier im Forum gibt ausgibt und diese kann ich leider Absolut nicht nachvollziehen.


ich gehe so vor:

make makefiles CCARGS="-DHAS_LDAP -DHAS_PCRE -DUSE_SASL_AUTH -DHAS_SSL" AUXLIBS="-lldap -llber -lpcre -lsasl2 -lssl -lcrypto"

dann make mit dieser Fehlermeldung am schluss:

/usr/local/src/postfix-2.1.4/src/global/mail_dict.c:66: undefined reference to `dict_ldap_open'
collect2: ld returned 1 exit status
make: *** [error] Error 1
make: *** [update] Error 1

Was hat das mit dict_ldap_open aufsich BITTE HELFT MIR :cry: :cry: :cry: :cry: :cry:

Ich habe wie schon gesagt alle Devel Packete Installiert. Die Version von Postfix ist postfix-2.1.4

Ich bin für jeden Hinweis der mich näher ans Ziel bring sehr sehr dankbar.

MFG.[/url]

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: Ich springe gleich aus dem Fenster :(( Postfix "make&qu

Post by sascha » 2004-07-02 22:51

Brauchst du wirklich LDAP Support? Ansonsten würde ich mal versuchen, -DHAS_LDAP und -lldap wegzulassen. Natürlich nach jedem Versuch immer brav "make clean" machen.

dumpfbacke
Posts: 43
Joined: 2004-03-13 22:31

Re: Ich springe gleich aus dem Fenster :(( Postfix "make&qu

Post by dumpfbacke » 2004-07-02 23:01

Ich Danke dir es hat jetzt auf einmal geklappt denn ich hatte vorher schon mal Probiert (was heißt vorher vor stunden) LDAP rauszunehmen aber es klappte nicht. Warscheinlich weil ich vergessen hatte make clean vorher zu machen :oops:

Er ist jetzt wie ein Blitz durchgeschnuddelt vielen Dank :-D



MFG.