Interne EMails innerhalb des gleichen Servers werden nicht..

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Interne EMails innerhalb des gleichen Servers werden nicht..

Post by titus.hanke » 2004-06-23 16:03

Hallo, ich habe ein Problem und bei der Suche nach Loesungen habe ich bislang nichts im Forum gefunden...

Ausstattung: 1&1 Root Server mit Suse 8.1 und Confixx 2.0 (jaja, ich weiss, updaten etc., tut aber jetzt mal nix zur Sache...).

wenn ich von einem pop3-Konto des Server an ein anderes eine EMail schicke, kommt diese nicht an und auch nicht zurueck. Es gibt auch keine "undeliverable" Message o.ae.
Also beispielsweise von web3p4 => web4p1 oder von web3p4 => web3p3.

- Ich verwende SMTP Auth. und nach aussen gehen alle Mails wunderbar raus.

FRAGE: Kann mir jemand nen Tipp geben, wo ich anfangen sollte zu suchen?

Herzlichen Dank im Voraus!!!

Titus.

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by duergner » 2004-06-23 16:14

/var/log/mail*

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Interne EMails innerhalb des gleichen Servers werden nic

Post by wgot » 2004-06-23 17:49

Hallo,
titus.hanke wrote:Confixx 2.0 (jaja, ich weiss, updaten etc.,
muß nicht sein - bringt vor allem erstmal neue Probleme, und hat mit Deinem Problem nix zu tun.

Werden Mails von außen an den Server zugestellt?

Vermutlich Fehler in der /etc/postfix/main.cf, zeig die mal.

Gruß, Wolfgang

jasa
Posts: 14
Joined: 2003-03-20 17:40

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by jasa » 2004-06-23 22:29

Huhu...

hatte das selbe Problem, allerdings ohne Confixx. Wollte Qmail benutzen, aber nach der Installation kamen keine Mails an die lokalen Benutzer an :(

In den Logfiles war nichts zu finden. Die Mails wurden auch ganz normal zugestellt. Ich denke Qmail suchte einfach in den falschen Verzeichnissen nach Mails für lokale Benutzer, denn nach einer Installation von Postfix hatte ich "quasi" alle Mailboxes der lokalen Benutzer mit Mails überflutet, die zuvor von Qmail zugestellt worden waren.

Sehr strange das Ganze, und eine Lösung habe ich bisher auch nicht!

Hatte im Forum zwar einige Beiträge gefunden, allerdings brachten diese auch keine Besserung

titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Re: Interne EMails innerhalb des gleichen Servers werden nic

Post by titus.hanke » 2004-06-26 21:06

wgot wrote: Vermutlich Fehler in der /etc/postfix/main.cf, zeig die mal.
Gruß, Wolfgang
Hi Wolfgang und alle anderen, danke für die schnelle Antwort.
Meine main.cf könnt Ihr Euch hier anschauen (wollte sie hier nicht posten, weil 23kb lang...):

http://www.titus-privat.de/main.cf

Hat es vielleicht mit dieser Sektion zu tun?
#smtpd_recipient_restrictions = permit_mynetworks,check_relay_domains
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
Danke für Infos. in der var/log/mail finde ich ne Menge Kram, verstehe allerdings nur Bahnhof. Ausser, dass eigentlich ueberall status=sent steht...
Hier mal ein Auszug von einer der betroffenen Email-Adressen, in diesem Fall allerdings bei einer Email nach "aussen", die ja ohnehin funktionieren:
Jun 24 14:36:04 p15093699 postfix/smtpd[11050]: setting up TLS connection from pD9F7FF04.dip.t-dialin.net[217.247.255.4]
Jun 24 14:36:04 p15093699 postfix/smtpd[11050]: TLS connection established from pD9F7FF04.dip.t-dialin.net[217.247.255.4]: TLSv1 with cipher EDH-RSA-DES-CBC3-SHA (168/168 bits)
Jun 24 14:36:04 p15093699 postfix/smtpd[11050]: connect from pD9F7FF04.dip.t-dialin.net[217.247.255.4]
Jun 24 14:36:05 p15093699 smtpd[11050]: 2A67E1400EF: client=pD9F7FF04.dip.t-dialin.net[217.247.255.4], sasl_method=LOGIN, sasl_username=web2p5
Jun 24 14:36:06 p15093699 postfix/cleanup[11038]: 2A67E1400EF: message-id=<000901c459e7$e53db340$2e73a8c0@kundendienst>
Jun 24 14:36:06 p15093699 postfix/qmgr[21153]: 2A67E1400EF: from=<hausgeraete@HABICHVERAENDERT.de>, size=3743, nrcpt=1 (queue active)
Jun 24 14:36:06 p15093699 postfix/smtp[11041]: 2A67E1400EF: to=<aso-edi-be@DUMMDIDUMM.com>, relay=mail3.retarus.de[82.135.18.59], delay=1, status=sent (250 5155794 message accepted for delivery)
Bezüglich der Frage wegen ankommender Mails: Absolut kein Problem, von aussen kommt alles rein, ist echt nur ein Problem innerhalb des Servers Mails hin und her zu senden!!!

Danke für Eure Bemühungen, stöbere auch selbst fleißig weiter.
Titus.

jasa
Posts: 14
Joined: 2003-03-20 17:40

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by jasa » 2004-06-26 21:47

wenn du ne Antwort gefunden hast bitte unbedingt posten! :)

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Interne EMails innerhalb des gleichen Servers werden nic

Post by wgot » 2004-06-27 00:13

Hallo,
titus.hanke wrote:www.titus-privat.de/main.cf
gut gemacht!

Wie schickst Du die Mails denn ab? Client auf dem PC, PHP-mail() oder Webmailer?
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
Mehr hab ich auch nicht drin.
Hier mal ein Auszug von einer der betroffenen Email-Adressen,
sind nur einige Emailadressen betroffen?

Zeig bitte mal einen Logauszug von einer Mail die nicht zugestellt wird.

Gruß, Wolfgang

compositiv
Posts: 193
Joined: 2003-01-22 14:58
Location: Hamburg

Re: Interne EMails innerhalb des gleichen Servers werden nic

Post by compositiv » 2004-06-27 11:56

smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
So müssen sich auch Mails von intern mit SASL authentifiziert werden. permit_mynetworks vor dem reject einfügen und mynetworks entsprechend setzen.

titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Re: Interne EMails innerhalb des gleichen Servers werden nic

Post by titus.hanke » 2004-06-27 17:17

wgot wrote: Wie schickst Du die Mails denn ab? Client auf dem PC, PHP-mail() oder Webmailer?
Ich schicke die Mails mit Outlook auf dem PC, aber auch über einen Webmailer (PHP Skript, was über smtp und pop3 arbeitet), funktioniert es nicht...

titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by titus.hanke » 2004-06-27 17:22

So, jetzt habe ich gerade mal eine Mail an eine Adresse auf dem Server geschickt. Hier der Auszug aus der var/log/mail:
Jun 27 17:18:19 p15093699 popper[21357]: Stats: web7p1 0 0 0 0 qwd-server.de 217.160.109.157 [pop_updt.c:296]
Jun 27 17:18:47 p15093699 postfix/smtpd[21366]: connect from localhost.localdomain[127.0.0.1]
Jun 27 17:18:47 p15093699 smtpd[21366]: 35A2D1400EF: client=localhost.localdomain[127.0.0.1], sasl_method=LOGIN, sasl_username=web7p1
Jun 27 17:18:47 p15093699 postfix/cleanup[21368]: 35A2D1400EF: message-id=<20040627151847.35A2D1400EF@p15093699.pureserver.info>
Jun 27 17:18:47 p15093699 smtpd[21366]: disconnect from localhost.localdomain[127.0.0.1]
Jun 27 17:18:47 p15093699 postfix/qmgr[21153]: 35A2D1400EF: from=<titus.hanke@qwd.de>, size=881, nrcpt=1 (queue active)
Jun 27 17:18:47 p15093699 popper[21370]: Stats: web7p1 0 0 0 0 qwd-server.de 217.160.109.157 [pop_updt.c:296]
Jun 27 17:18:47 p15093699 postfix/local[21371]: 35A2D1400EF: to=<web20p1@p15093699.pureserver.info>, relay=local, delay=0, status=sent (mailbox)
Irgendwas fehlerhaft?
Titus.

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by adjustman » 2004-06-27 17:34

nö, is gesendet
Jun 27 17:18:47 p15093699 postfix/local[21371]: 35A2D1400EF: to=<web20p1@p15093699.pureserver.info>, relay=local, delay=0, status=sent (mailbox)

titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by titus.hanke » 2004-06-29 08:37

...das Problem ist nur, die Email kommt nicht an....

Hat sonst noch irgend jemand eine schlaue Idee?
Grazie,

Titus.

titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Re: Interne EMails innerhalb des gleichen Servers werden nic

Post by titus.hanke » 2004-06-29 08:39

Compositiv wrote:
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
So müssen sich auch Mails von intern mit SASL authentifiziert werden. permit_mynetworks vor dem reject einfügen und mynetworks entsprechend setzen.
Kannst Du den Satzteil "mynetworks entsprechend setzen" bitte mal dechiffrieren? :-) Verstehe die Anweisung nicht genau (setzen tu ich mich schon mal..) 8)

Daaaaaaaaaaaanke! Titus.

wgot
RSAC
Posts: 1707
Joined: 2003-07-06 02:03

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by wgot » 2004-06-29 12:23

Hallo,

Code: Select all

mynetworks=127.0.0.0/8

smtpd_recipient_restrictions=permit_sasl_authenticated, permit_mynetworks, check_relay_domains
Es wird Dir nur vermutlich nichts nützen weil permit_mynetworks nichts mit dem Versand über Mailclient zu tun hat. Die Einstellung ist nur interessant für Versand direkt vom Server (z.B. mit PHP).
to=<web20p1@p15093699.pureserver.info>, relay=local, delay=0, status=sent (mailbox)
Gibt es einen User web20p1 und gibt es eine Mailbox(-datei) web20p1? Funktioniert diese Mailbox wenn sie von außen angeschrieben wird?

Vorsichthalber: Confixx-Lizenz gültig?

Gruß, Wolfgang

titus.hanke
Posts: 9
Joined: 2004-05-31 16:42

Re: Interne EMails innerhalb des gleichen Servers werden nicht..

Post by titus.hanke » 2004-06-29 13:34

Es wird Dir nur vermutlich nichts nützen weil permit_mynetworks nichts mit dem Versand über Mailclient zu tun hat. Die Einstellung ist nur interessant für Versand direkt vom Server (z.B. mit PHP).
Aha, verstehe. Danke.
Gibt es einen User web20p1 und gibt es eine Mailbox(-datei) web20p1? Funktioniert diese Mailbox wenn sie von außen angeschrieben wird?
Ja, der User existiert und das Postfach funzt einwandfrei, wenn es von aussen angeschrieben wird...
Vorsichthalber: Confixx-Lizenz gültig?
Ja, grins... War die erste Sache die ich gecheckt habe. Confixx funktioniert ja auch sonst...

Titus.[/quote]