Das Versenden von Mails klappt nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
siniver
Posts: 11
Joined: 2003-08-15 09:45

Das Versenden von Mails klappt nicht

Post by siniver » 2004-05-09 13:38

Hallo.

Ich habe unter Confixx eine E-Mail Adresse mit einem POP3-Postfach eingerichtet.

An diese Adresse kann ich E-Mails problemlos schicken, die kommen ohne Weiteres an und können abgerufen werden.
Nur, wenn ich eine Mail über diese Adresse senden will, klappt es nicht.
Ich benutze Outlook und bei den Serverinformationen habe ich
pop.hauptdomain.de
mail.hauptdomain.de
stehen.
Der Posteingang klappt, nur der Postausgang nicht.
Einfache Weiterleitungen an eine andere E-Mail Adresse funktionieren auch.

Woran kann das liegen, dass der Postausgang nicht klappt?

ravensmetaller
Posts: 68
Joined: 2003-08-05 20:27

Re: Das Versenden von Mails klappt nicht

Post by ravensmetaller » 2004-05-09 13:49

Ich schies nu einfach mal ins Blaue...

Outlook-Like heisst es "Postausgangsserver erfordert Athentifizierung"
Schonma da dran gedacht ?

Deine Info's (Logfiles,etc) sind etwas spärlich, von daher ist mehr als eine Mutmaßung nicht möglich...

--> Mehr Info's, dann kann ihnen auch gehilft werden ;-)

Gruß

RM

sep1871
Posts: 14
Joined: 2004-05-03 22:08

Re: Das Versenden von Mails klappt nicht

Post by sep1871 » 2004-05-10 19:53

Das gleiche Problem habe ich auch und keine Lösung in Sicht. Alle Outlooksettings durchgespielt. Es ist ein "Relay access denied" Fehler. Das bedeutet in diesem Fall, dass er nur e-mail für Deine Domain annimmt. E-Mails, die mit Deiner Absenderdomain an eine fremde Domain geschickt werden, werden nicht weitergeleitet. Es müssen Settings im Mail-Server sein. Ich könnte das alles fein für Windows-Kisten machen, aber bin Neuling was Suse 9.0 und Confixx 3 angeht.

Falls jemand Ideen hat, wäre das ganz nett...

siniver
Posts: 11
Joined: 2003-08-15 09:45

Re: Das Versenden von Mails klappt nicht

Post by siniver » 2004-05-10 20:01

Bei mir hat sich das inzwischen erledigt.
Der Tipp mit der Authentifizierung war tatsächlich hilfreich, vielen Dank dafür.

Auf der Linux-Ebene bin ich auch ein totaler Noob, aber ich schäme mich nicht im Geringsten dafür. ;)
Deshalb stelle ich gleich die Frage: Momentan habe ich SuSe 8.1 am Laufen, macht es Sinn, auf 9.0 aufzustocken?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Das Versenden von Mails klappt nicht

Post by Joe User » 2004-05-10 20:23

Siniver wrote:Momentan habe ich SuSe 8.1 am Laufen, macht es Sinn, auf 9.0 aufzustocken?
Nö, aber auf 9.1...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Das Versenden von Mails klappt nicht

Post by Joe User » 2004-05-10 20:24

sep1871 wrote:Falls jemand Ideen hat, wäre das ganz nett...

Code: Select all

postconf -n
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

sep1871
Posts: 14
Joined: 2004-05-03 22:08

Re: Das Versenden von Mails klappt nicht

Post by sep1871 » 2004-05-10 21:23

Ich bin wirklich ein linux-greenhorn (ca. 2 Tage). Hab gerade ein paar settings gefunden in mail.cf und versuche die mal zu posten... (war schwer die mail.cf zu finden :-)


Code: Select all

readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = (...meine.domain.tld...)
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains = 
mydestination = $myhostname, localhost.$mydomain
defer_transports = 
disable_dns_lookups = no
relayhost = 
content_filter = 
mailbox_command = 
mailbox_transport = 
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions = 
smtpd_helo_required = no
smtpd_helo_restrictions = 
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
Ist nochwas von Nöten? Danke schonma

sep1871
Posts: 14
Joined: 2004-05-03 22:08

Re: Das Versenden von Mails klappt nicht

Post by sep1871 » 2004-05-10 21:38

Gleich noch ein Newby-Frage:

Wenn ich die mail.cf geändert habe ,wie zb permit_sasl_authenticated, muss ich dann postfix neustarten? und wie?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Das Versenden von Mails klappt nicht

Post by Joe User » 2004-05-10 21:40

Code: Select all

postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination'
postfix reload
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

heinz-werner
Posts: 9
Joined: 2004-05-09 08:47
Location: Frankfurt

Re: Das Versenden von Mails klappt nicht

Post by heinz-werner » 2004-05-11 08:45

Joe User wrote:

Code: Select all

postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination'
postfix reload
oder halt so:

Original:
#smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination

Modiviziert
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,check_relay_domains

Danke für das verschieben meiner Postings nach "Unerwünscht".

sep1871
Posts: 14
Joined: 2004-05-03 22:08

Re: Das Versenden von Mails klappt nicht

Post by sep1871 » 2004-05-11 09:59

Das hat funktioniert! Dank an Euch!