spamassassin + qmail

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
hahni
Posts: 165
Joined: 2003-06-20 13:07
Location: Regensburg

spamassassin + qmail

Post by hahni » 2004-04-11 11:09

hallo zusammen,

hab spamassassin auf suse 8.1 installiert. funktioniert scheinbar auch wunderbar. sogar das startskript. beim boot/reboot.

leider scheint aber trotzdem der dämon nicht vernüftig zu arbeiten. ich bekomme nämlich folgende fehlermeldung:

Apr 11 02:27:30 server spamc[3134]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#1 of 3): Connection refused Apr 11 02:27:31 server spamc[3134]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#2 of 3): Connection refused Apr 11 02:27:32 server spamc[3134]: connect(AF_INET) to spamd at 127.0.0.1 failed, retrying (#3 of 3): Connection refused Apr 11 02:27:33 server spamc[3134]: connection attempt to spamd aborted after 3 retries

was genau hab ich denn noch verkehrt gemacht oder muss ich noch einsteleen?

danke für eure hilfe. gruß

björn

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: spamassassin + qmail

Post by chris76 » 2004-04-11 11:55

Wie genau startest du den spamd?

Gruß Christian

hahni
Posts: 165
Joined: 2003-06-20 13:07
Location: Regensburg

spamassassin + qmail

Post by hahni » 2004-04-11 12:09

ich starte ihn mit einem skript von qmail hoch:

/etc/init.d/qmailstart:

als eintrag glaub ich steht

/usr/bin/spamd &

drinnen

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: spamassassin + qmail

Post by chris76 » 2004-04-11 12:33

Also interssant wäre was dort genau steht !

bei meiner SuSE Maschine sieht das startscript von SA so aus

Code: Select all

#! /bin/sh
# Copyright (c) 1996 S.u.S.E. Gmbh Fuerth, Germany. All rights reserved.
#
# Author: Burchard Steinbild , 1996
# Modified: Michael@Schaarwaechter.de 8/2002
#
### BEGIN INIT INFO
# Provides: SpamAssassin / Spamd
# Required-Start:
# Required-Stop:
# Default-Start: 2 3 5
# Default-Stop:
# Description: SpamAssassin daemon
### END INIT INFO

. /etc/rc.status

# Determine the base and follow a runlevel link name.
base=${0##*/}
link=${base#*[SK][0-9][0-9]}

# The echo return value for success (defined in /etc/rc.config).
return=$rc_done
case "$1" in
 start)
   echo -n "Starting service spamd daemon:"
   startproc /usr/bin/spamd -a -d || return=$rc_failed
   echo -e "$return"
   ;;
 stop)
   echo -n "Shutting down service spamd daemon:"
   killproc -TERM /usr/bin/spamd || return=$rc_failed
   echo -e "$return"
   ;;
 status)
   echo -n "Checking for service spamd deamon: "
   checkproc /usr/bin/spamd && echo OK || echo No process
   ;;
 reload)
   $0 stop && $0 start || return=$rc_failed
   ;;
 restart)
  $0 stop && $0 start || return=$rc_failed
   ;;
 *)
   echo "Usage: $0 {start|stop|status|restart|reload}"
   exit 1
   ;;
esac

# Inform the caller not only verbosely and set an exit status.
test "$return" = "$rc_done" || exit 1
exit 0
Gruß Christian

hahni
Posts: 165
Joined: 2003-06-20 13:07
Location: Regensburg

spamassassin + qmail

Post by hahni » 2004-04-11 12:47

nee, so ein startskript habe ich garnicht. bei mir ist das ein einzeler. wo befindet sich bei dir das skript? also in welchem verzeichnis? kannst du es mir vielleicht auch noch einmal an "bjoern@hahnefeld.de" schicken, damit ich es nicht kopieren und in die zwischenablage tun muss? vielleicht ist das auch der grund, weil irgendwelche parameter nicht passen...

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: spamassassin + qmail

Post by chris76 » 2004-04-11 13:54

hahni wrote:kannst du es mir vielleicht auch noch einmal an "bjoern@hahnefeld.de" schicken, damit ich es nicht kopieren und in die zwischenablage tun muss?
Ist es zuviel verlangt es zu kopieren und über die Zwischenablage einzufügen?
Bei mir liegt es unter /usr/sbin/rcspamd

Gruß Christian

hahni
Posts: 165
Joined: 2003-06-20 13:07
Location: Regensburg

spamassassin + qmail

Post by hahni » 2004-04-11 14:20

nee, aber das textformat unix-tauglich zu machen ;-) nee, spaß beiseite. bin gerade am experimentieren und werde dich am laufenden halten ;-)

hahni
Posts: 165
Joined: 2003-06-20 13:07
Location: Regensburg

spamassassin + qmail

Post by hahni » 2004-04-11 18:41

leider gibt es einen traurigen befund: trotz startskript der exakt gleiche fehler wie auch vorher. hast du noch eine idee? der eintrag in den mails im header lautet auch unverändert:

"X-Spam-Status: No, hits=? required=?"