PHP schickt keine Mails...

Bash, Shell, PHP, Python, Perl, CGI
ybbus
Posts: 8
Joined: 2003-12-24 13:52

PHP schickt keine Mails...

Post by ybbus »

Hi!

Die kleine Datei:

Code: Select all

<?php
mail("xxx@xxx.org", "Betreff", "Nachrichtentext", "From: info@xxx.de");
?>
Funktioniert nicht.
Im Apache error.log steht die Meldung:

exim: neither action flags nor mail addresses given

Ich hab keine ahnung warum das nich geht :(
makue
Posts: 17
Joined: 2003-11-27 07:39

Re: PHP schickt keine Mails...

Post by makue »

Mach mal das:

Code: Select all

<?php 
mail("xxx@xxx.org", "Betreff", "Nachrichtentext", "From: info@xxx.de","-f info@xxx.de"); 
?> 
Ich hatte das Problem auch, lag an der Konfiguration von Sendmail, die ich aber nicht ändern wollte. Im /var/log/mail findest Du auch eine entsprechende Fehlermeldung. Man muss sich halt mit einer gültigen Mailadresse identifizieren. Ich weiss zwar nicht ob das Dein Problem ist, ein Versuch ist es aber sicher Wert.
ybbus
Posts: 8
Joined: 2003-12-24 13:52

Re: PHP schickt keine Mails...

Post by ybbus »

Ne hat nix gebracht :(

"exim: neither action flags nor mail addresses given"

irgendwie komisch
niklas_
Posts: 122
Joined: 2003-08-13 20:46

Re: PHP schickt keine Mails...

Post by niklas_ »

mailserver in der php.ini falsch angegeben ?
ybbus
Posts: 8
Joined: 2003-12-24 13:52

Re: PHP schickt keine Mails...

Post by ybbus »

Dann würde exim ja garkein meldung bringen, weil es dann davon garnix mitbekommen würde, oder?
dodolin
Posts: 3840
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: PHP schickt keine Mails...

Post by dodolin »

Du sagtest, das stand im Apachen error.log. Bisher hat dein Exim also noch nichts nachweisbares geloggt. Was steht denn bitteschön in den Eximlogs? Wie sieht dein sendmail_path in PHP aus?