1und1 & Serverabstürze

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
danzas
Posts: 6
Joined: 2003-04-03 08:23

1und1 & Serverabstürze

Post by danzas »

Hi,

seit ca. einem Monat hab ich einen Rootserver XXL bei 1und1 gemietet. Auf dem Server läuft lediglich ein phpBB in der 2.0.2er Version. Dazu das Fotoalbum-Addon, was noch GD für die Thumbnails verwendet. Also rein HTML, PHP, mySQL und GD. Das war's.

Nun das Phänomen: Das Forum flutscht, alles geht wunderbar schnell, zeitweise sind 40 User online, dann 20, dann so an die 15, und plötzlich bleibt alles stehen. Wenn man was anklickt, gibt's nur ein "Opening page ..." und nichts kommt. FTP ist ebenso tot, genau wie SSH. Nix mehr.

Einzige Abhilfe: Reboot über die Konfigurationsseite. Danach läuft's wieder. So zw. 30 Min. und 12 Stunden, bis zum nächsten Crash.

var/log/*.* zeigt nix erkennbares, auch finde ich keine auffälligen Prozesse im Betrieb. my.cnf, php.ini und httpd.conf sind unmodifiziert. Mailserver ebenso. Fremdseiten laufen keine auf dem Rechner.

Es kann doch nicht sein, daß das Forum den Server abschiesst. Vor allem nicht wenn's kaum unter Last steht. Nach meinem Verständnis könnte es höchstens einen Prozess treffen; sei es der Apache, die Datenbank oder sonstwas.

Hardware-Probleme? Betriebssystem ist Suse 8. Ansonsten > ratlos. Bin jetzt dabei, das Forum in der aktuellen Version neu aufzusetzen, auch wenn ich nicht gerade sicher bin, daß das Abhilfe schafft.

[Edit von Olfi: Absatz gelöscht]

Gruss,
Chris

floschi
Userprojekt
Userprojekt
Posts: 3247
Joined: 2002-07-18 08:13
Location: München

Re: 1und1 & Serverabstürze

Post by floschi »

Ich habe mir zwei Sachen erlaubt: Den einen Absatz gelöscht, sowas wollen wir hier nicht öffentlich und zweitens verschiebe ich mal ins Linuxforum.

Kannst du vor den Abstürzen etwas beobachten, z.B. schnell ansteigende Last oder soetwas?

Kannst du nachvollziehen, welche Funktion den Absturz verursacht?

Ist es wirklich ein Absturz, oder nur eine Ã?berlastung?

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: 1und1 & Serverabstürze

Post by captaincrunch »

Welche Netzwerkkarte ist verbaut?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

danzas
Posts: 6
Joined: 2003-04-03 08:23

Re: 1und1 & Serverabstürze

Post by danzas »

Kannst du vor den Abstürzen etwas beobachten, z.B. schnell ansteigende Last oder soetwas?
Nichts dergleichen. Die Zeitpunkte der Abstürze sind komplett lastunabhängig. Zeitweise raucht die Kiste nacht um 4 ab, wo höchstens 2 User im Forum unterwegs sind.
Kannst du nachvollziehen, welche Funktion den Absturz verursacht?
Ich habe mal ein Terminalfenster mit top offen stehengelassen. Zum Zeitpunkt des Absturzes konnte ich weder einen last-ziehenden Prozess noch etwas ungewöhnliches entdecken.
Ist es wirklich ein Absturz, oder nur eine Ã?berlastung?
Kann ich leider nicht genau sagen. Zumindest werden nach einem "Crash" keine Logfiles mehr geschrieben, auch ein SSH-Fenster bringt mir selbst nach einer halbe Stunde des Wartens keinen Prompt.
Welche Netzwerkkarte ist verbaut?
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
Subsystem: FIRST INTERNATIONAL Computer Inc: Unknown device 9212
Flags: bus master, medium devsel, latency 32, IRQ 23
I/O ports at e000
Memory at ea401000 (32-bit, non-prefetchable)
Capabilities: [40] Power Management version 2

Treiberversion: via-rhine.c:v1.10-LK1.1.19 July-12-2003 Written by Donald Becker

Kernel-Version: 2.4.23-xfs-031204

Ich dachte auch zuerst an den Rhine-Bug, aber ein 23er-Kernel sollte ja (eigentlich) den Bug nicht mehr aufzeigen.

Gruss,
Chris

dopefish
Posts: 142
Joined: 2003-02-06 12:57
Location: Karlsruhe

Re: 1und1 & Serverabstürze

Post by dopefish »

Ich würde es trotzdem mit die Treiber direkt von via versuchen. hat zumindest bei einige von uns geholfen. ich hatte auch mit die 1.1.19 Kernel Treiber von Donald Becker noch Probleme mit die Karte. Anderseites bin ich derzeit wieder bei die "original" kernel rteiber wieder gelandet (1.1.19-2.5) da die treiber von via sich nicht für 2.6 kompilieren lassen, und bisher gab es damit auch keine Probleme (läuft aber auch erst seit einen Tag).

danzas
Posts: 6
Joined: 2003-04-03 08:23

Re: 1und1 & Serverabstürze

Post by danzas »

Status:

Abstürze alle Stunde > 1und1 angerufen
> 1und1 will einen Hardwarescan machen = 'Alles ok'

2h später:
Abstürze alle Stunde > 1und1 angerufen
> 1und1 macht BIOS-Update

weitere 2h später:
Abstürze alle Stunde > 1und1 angerufen
> 1und1 tauscht den Rechner, altes System bleibt drauf

Dann lief es 24h durch, und jetzt hab ich wieder Abstürze am Stück. Habe an dem Treiber nichts verändert. Sehe auch nicht ein, wieso das jetzt meine Sache sein soll wenn's Inkompatibilitäten mit Treibern & Hardware gibt.

Jetzt hab ich allerdings Widersprüche was das Problem sein kann. Auf der einen Seite schreit es nach wie vor nach der Netzwerkkarte, vor allem weil ein copyjob per scp auf ein Remotesystem den Rechner nach 3 Sekunden zum stehen bringt. Allerdings gibt mir auf der anderen Seite das /var/log/warn auch noch ganz andere Meldungen, die eher auf die Platte schliessen lassen:

Code: Select all

Jan 11 12:00:51 pXXX kernel: hda: dma_timer_expiry: dma status == 0x24
Jan 11 12:00:51 pXXX kernel: hda: DMA interrupt recovery
Jan 11 12:00:51 pXXX kernel: hda: lost interrupt
Allerdings kam dieser Fehler bisher nur 2x am Stück .. vor einer Woche und heute. Kann es dennoch ein Faktor sein?

Geduldsfaden wird immer dünner ...

Gruss,
Chris

dopefish
Posts: 142
Joined: 2003-02-06 12:57
Location: Karlsruhe

Re: 1und1 & Serverabstürze

Post by dopefish »

könnte auch mit einfliessen in das problem. wenn die abstürze aber auch ohne probleme mit der festplatte auftreten ist es vielleicht auch nur ein folgefehler durch den absturz. Es ist schon ärgerlich, dass hardware verbaut wird für die es keine treiber gibt die auch unter last stabil laufen.

Ich muss allerdings auch sagen, dass ich bisher mit den 2.6.1 Kernel gute erfahrungen gemacht habe (die via-rhine treiber die beim kernel dabei sind). Habe ein paar testst gemacht die früher probleme gemacht haben, hat diesesmal keine probleme gemacht.

kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: 1und1 & Serverabstürze

Post by kostya »

Ein meiner rooties verhält sich seit paar Wochen genau so. Zwar nicht alle paar Stunden aber immerhin 1-2 mal pro Tag. Der Server wurde vor zwei wochen reinitialisiert. Davor hatte ich keine Probleme mit ihm in der Richtung. Die Hardware ist also die gleiche, auch soft und configs. der einzige Unterschid ist der Kernel. Vor Initialisierung hatte ich 2.4.21-lufs-030704 und danach 2.4.23-xfs-031204. Der NIC ist VIA Technologies, Inc. VT6102 [Rhine-II].

Auch die gleichen hda-Fehler sind aufgetretten aber nur ein mal und kamen nicht wieder. Ich denke, dass es Folgefehler sind.

In zwei weiteren Servern steckt der gleiche NIC und Kernel 2.4.21-lufs-030704. Die beiden laufen viel stabiler.

deaggi
Posts: 28
Joined: 2003-11-09 12:37

Re: 1und1 & Serverabstürze

Post by deaggi »

Bei mir läuft inzwischen auch der Kernel vmlinuz-2.4.23-xfs-031204. Allerdings völlig Problemlos mit der 1&1-Hardware.

deaggi

chris76
Moderator
Moderator
Posts: 1878
Joined: 2003-06-27 14:37
Location: Germering

Re: 1und1 & Serverabstürze

Post by chris76 »

^^ ACK bei mir auch

danzas
Posts: 6
Joined: 2003-04-03 08:23

Re: 1und1 & Serverabstürze

Post by danzas »

Schade, wieder gegensätzliche Meinungen/Erfahrungen. Der 23er Kernel läuft bei den einen, und bei den anderen gibt's die Abstürze.

Da motiviert es kaum überhaupt jetzt am Kernel rumzufummeln wenn's eh fraglich ist. Allein heute wieder 5 Abstürze.

Welche Provider empfehlen sich neben 1und1 im Rootserverbereich? Ich glaube ich werde mich da mal umgucken.

Gruss,
Chris

kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: 1und1 & Serverabstürze

Post by kostya »

DanZas wrote:Schade, wieder gegensätzliche Meinungen/Erfahrungen. Der 23er Kernel läuft bei den einen, und bei den anderen gibt's die Abstürze.

Da motiviert es kaum überhaupt jetzt am Kernel rumzufummeln wenn's eh fraglich ist. Allein heute wieder 5 Abstürze.

Welche Provider empfehlen sich neben 1und1 im Rootserverbereich? Ich glaube ich werde mich da mal umgucken.

Gruss,
Chris
Mein Server, der Probleme hat, ist auch ein XXL von 1&1 Puretec. Vielleicht ist gerade das ein Problem (dual-cpu)? Ich werde auf einen meiner L-Servern den Kernel draufspielen und schauen, ob der sich anders verhält.

Es ist auch interesant, welche Server die anderen haben, bei denen es keine Probs mit dem Kernel gibt.

Ich vermute stark, dass es am Kernel (oder dem NIC-Driver darin) liegt.

kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: 1und1 & Serverabstürze

Post by kostya »

Ich habe es anders gemacht. Ich habe Kernel 2.4.24-xfs-040109 vom Updateserver auf den XXL-Rootie draufgespielt. Läuft seit 10 Minuten ohne Anzeichen von Probs. Jetzt bleibt nur abwarten.

kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: 1und1 & Serverabstürze

Post by kostya »

Kostya wrote:Ich habe es anders gemacht. Ich habe Kernel 2.4.24-xfs-040109 vom Updateserver auf den XXL-Rootie draufgespielt. Läuft seit 10 Minuten ohne Anzeichen von Probs. Jetzt bleibt nur abwarten.
Ã?ber 24 Stunden Uptime ohne Probs.

flolein
Posts: 113
Joined: 2003-12-11 14:47

Re: 1und1 & Serverabstürze

Post by flolein »

und der 10.000ste beitrag in diesem forum ;)

danzas
Posts: 6
Joined: 2003-04-03 08:23

Re: 1und1 & Serverabstürze

Post by danzas »

Nachdem die Restart-Orgie nicht abreißt, wollte 1und1 Mitte der Woche nun selbst nach dem Server schauen. Seitdem habe ich nichts mehr gehört - weder telefonisch, noch per Mail.

Der Server ist nun letzte Nacht wieder abgeraucht und war für Stunden offline. Nach einem Restart hielt es für 1 Stunde, dann war er wieder weg. Wieder Restart - nach 30 Minuten wieder weg.

Soll man da noch irgendwas zu sagen? Wenn morgen kein Feedback kommt bin ich raus.

Mein Mitgefühl an alle Leidensgenossen, die sich wie ich die Nächte vor einer 1und1-Recovery-Konsole um die Ohren schlagen müssen.

Gruss,
Chris

kostya
Posts: 89
Joined: 2003-01-22 17:23

Re: 1und1 & Serverabstürze

Post by kostya »

Meine Kiste läuft seit mehr als 4 Tagen ohne Probleme. An deiner Stelle würde ich den Kernel 2.4.24-xfs-040109 vom 1&1-Updateserver draufspielen. Bei meinem XXL-Roote hat's geholfen.

danzas
Posts: 6
Joined: 2003-04-03 08:23

Re: 1und1 & Serverabstürze

Post by danzas »

Hab den 2.4.24-xfs-040109 gestern installiert .. und seit 20 Stunden läuft's jetzt.

*leichtesaufatmen

Aber erstmal schauen ob's hält.

Danke vorab!

Gruss,
Chris

Anonymous

Hatten auch Probleme mit dem 2.4.23- Kernel auf XXL-Server

Post by Anonymous »

Hi,

unser XXL-Server stürzte auch nach einigen Stunden ab, nachdem wir den ungetesteten 2.4.23-Kernel aufgespielt hatten. Auf einem L-Server lief er jedoch problemlos.

Ist der 2.4.24 von 1&1 denn offiziell freigegeben für Linux 8.1 und den XXL-Server? Oder wie erfährt man überhaupt, wann das soweit ist?

Danke für den Thread und schöne Grüße,
Peter

mattes
Posts: 4
Joined: 2003-04-04 19:26

Re: 1und1 & Serverabstürze

Post by mattes »

DanZas wrote:...und plötzlich bleibt alles stehen. Wenn man was anklickt, gibt's nur ein "Opening page ..." und nichts kommt. FTP ist ebenso tot, genau wie SSH. Nix mehr.

Gruss,
Chris
Also ich hab jetzt seit fast einem Jahr einen RootServer L (!) und ja, ich kenne deine Probleme. Ich gebe mir selbst auch nicht wirklich die Schuld, da die Kiste schon in den ersten drei Monaten, in denen ich wirklich nichts gemacht hatte, ausser webseiten druafzuspielen, und in confixx etwas rumzuspielen, schon mehrmals einfror. Inzwsichen ist genug software drauf, und auch die last ist sicher höher, obwohl er niemals wirklich ausgelastet ist, und last wirklich scheinbar kein grund ist.

meine logfiles verraten auch nur, dass der normale mail und http-verkehrt normal weiterlief, bis er irgenwann einfach stehenblieb. habe noch nie irgendetwas entdecken können.

mein workaround: ein anderer rechner checkt den server jede minute, und wenn er 5 minuten offline ist, dann loggt sich zweiter rechner bei login.1und1.com ein und resettet den rootserver... traurig aber wenigstens funktioniert es... meistens :-(

ja, noch meine Daten: wie gesagt, es ist der L Rootserver, schon was älter, mein kernel ist 2.4.20 (meine erfahrungen mit kernelupdate bei suse haben mir letztens 4h nicht nur den schlaf geraubt, sondern meinen blutdruck auf 180 verweilen lassen, daran denke ich nicht gern zurück - ausserdem ist 1&1 schuld, dass die netzwerkkarten verbauen, die nach einem normalen yast-update nicht mehr gehen... grummel... ) meine netzwerkkarte sagt folgendes:

Code: Select all

via-rhine.c:v1.10-LK1.1.14  May-3-2002  Written by Donald Becker
<6>  http://www.scyld.com/network/via-rhine.html
<6>eth0: VIA VT6102 Rhine-II at 0xe000, 00:40:63:c3:66:7f, IRQ 15.
<6>eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.

tja, wenn jemand eine idee hat, aber ihr schlagt euch ja schon alle drum... mich würde in der hinsicht mal knteressieren, ob es hier leute gibt, die der meinung sind, mit debian würde sowas besser laufen... die leute die vserver und http://www.vlinux.de vermieten schwören auf debian, in erster linue wegen stabilität. ich werde mir da wohl mal was zulegen, und zunächst als check&reset-server für den ersten und als backup benutzen...

grüsse,

Matthias