Spamassassin Detuscher Report.

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
berserker
Posts: 4
Joined: 2003-10-12 19:34

Spamassassin Detuscher Report.

Post by berserker » 2003-10-12 19:36

Hallo liebe Gemeinde.

Ich bin nun mit meinem Latein am Ende.

Wie bewege ich SpamASSASSIN dazu mir den Report wenn er eine Spam-Mail gefunden hat in deutsch zu senden? Er schickt es immer in Englisch raus.

MfG, Berserker

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Spamassassin Detuscher Report.

Post by dodolin » 2003-10-13 12:37

Wie bewege ich SpamASSASSIN dazu mir den Report wenn er eine Spam-Mail gefunden hat in deutsch zu senden? Er schickt es immer in Englisch raus.
Die Environment-Variable $LANGUAGE sollte für den spamassassin Prozess auf 'de' gesetzt sein, dann funzt das.

berserker
Posts: 4
Joined: 2003-10-12 19:34

Re: Spamassassin Detuscher Report.

Post by berserker » 2003-10-16 06:27

Hallo.

Also ich habe auf meinem Debian in die Datei /etc/profile

export LANGUAGE=de


eingetragen.

Leider sendet er die Reports immer noch in englisch.

MfG, Ronny

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Spamassassin Detuscher Report.

Post by dodolin » 2003-10-16 08:48

Wie genau wird dein SA aufgerufen? procmail, maildrop, mta, ...?

berserker
Posts: 4
Joined: 2003-10-12 19:34

Re: Spamassassin Detuscher Report.

Post by berserker » 2003-10-16 17:34

Hi.

Also der SA wird per procmail aufgerufen:

:0fw
| /usr/local/bin/spamassassin

:0e
{
EXITCODE=$?
}

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Spamassassin Detuscher Report.

Post by dodolin » 2003-10-16 20:21

MIt procmail kenne ich mich nicht so aus, aber lies mal die manpage dazu, dort sollte stehen, wie man IN PROCMAIL Environment Variablen setzen kann. Tue dies vor dem Aufruf von SA.

sebbus
Posts: 125
Joined: 2003-07-07 09:37
Location: Chemnitz

Re: Spamassassin Detuscher Report.

Post by sebbus » 2003-10-30 20:08

@Berseker:
Hast du mittlerweile eine Lösung für das Problem?

Würde mich interessieren.

MfG, Sebbus

berserker
Posts: 4
Joined: 2003-10-12 19:34

Re: Spamassassin Detuscher Report.

Post by berserker » 2003-10-30 22:50

Hi.

Ja ich habe das Problem gelöst.

ich habe folgendes in meiner /etc/procmailrc stehen

Code: Select all

LANGUAGE=de
LANG=de_DE

:0fw
| /usr/local/bin/spamassassin

:0e
{
   EXITCODE=$?
}


LANGUAGE=de
LANG=de_DE


Das ist alles gewesen.
Nun bekommt der User den Spam-Report in deutsch.

footh
Posts: 84
Joined: 2002-12-02 02:33

Re: Spamassassin Detuscher Report.

Post by footh » 2003-10-31 11:21

@Berserker

...könntest du uns mal deine procmailrc als code offenlegen?
Wäre sehr nett!!!

Vielen Dank im Voraus!!!

sebbus
Posts: 125
Joined: 2003-07-07 09:37
Location: Chemnitz

Re: Spamassassin Detuscher Report.

Post by sebbus » 2003-11-01 11:30

Berserker wrote:Hi.

Ja ich habe das Problem gelöst.

ich habe folgendes in meiner /etc/procmailrc stehen

Code: Select all

LANGUAGE=de
LANG=de_DE

:0fw
| /usr/local/bin/spamassassin

:0e
{
   EXITCODE=$?
}


LANGUAGE=de
LANG=de_DE


Das ist alles gewesen.
Nun bekommt der User den Spam-Report in deutsch.
Hallo,

muss ich danach noch irgendwas neustarten? Eigentlich nicht, oder?
Er schickt das bei mir nämlich immernoch in Englisch raus. Ich hab damit eigentlich kein Problem, aber meine "Kunden" verwirrt das sicher etwas, dann halten die nachher den Spamraport noch für Spam ;).

Hat (um es nochmal auf den Punkt zu bringen) leider nicht funktioniert...

bravesurfer
Posts: 170
Joined: 2003-05-08 12:17
Location: Stuttgart

Re: Spamassassin Detuscher Report.

Post by bravesurfer » 2004-05-31 02:21

Hallo,

hat den noch jemand einen Tip? Bei mir funktioniert das so leider auch nicht!

crocodoc
RSAC
Posts: 30
Joined: 2002-10-07 14:29
Location: Rehau

Re: Spamassassin Detuscher Report.

Post by crocodoc » 2004-05-31 09:36

Hallo,

ich glaub der Tip steht hier schon irgendwo im rootforum. So hat es jedenfalls bei mir funktioniert.

In der Datei, die den SpamAssassin-Damon spamd startet habe ich folgendes eingetragen

Code: Select all

LANG=de_DE.ISO-8859-15
LC_ALL=de_DE@euro
LANGUAGE=de_DE@euro
LC_CTYPE=de_DE@euro
export LANG LC_ALL LANGUAGE LC_CTYPE
Danach hatte ich einen deutschen Report.

...man liest sich,
Carsten

bravesurfer
Posts: 170
Joined: 2003-05-08 12:17
Location: Stuttgart

Re: Spamassassin Detuscher Report.

Post by bravesurfer » 2004-05-31 10:00

Perfekt. Das hat funktioniert. Ich danke dir :-D
Noch jemand eine Idee wo ich dran drehen kann damit er mit als Hostname den Name des Mailservers anzeigt anstatt den tatsächlchen Host? Könnte das ja händisch ändern und die Vairable _Hostname_ einfach
in den Texten entsprechend ändern, aber geht das nicht anderst?

Anonymous

Re: Spamassassin Detuscher Report.

Post by Anonymous » 2004-10-22 17:06

Wenn ich diesen Tip befolge (und vorher per apt-get install locales und die entsprechenden de locales installiert habe) bekomem ich beim neustarten von spamassasin dennoc folgenden fehler:
/etc/init.d/spamassassin restart
Restarting SpamAssassin Mail Filter Daemon: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "de_DE@euro",
LC_ALL = "de_DE@euro",
LC_CTYPE = "de_DE@euro",
LANG = "de_DE.ISO-8859-15"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
spamd.
Kann es ggf. an fehlenden Zugriffsrechten liegen, da ich spamassasin unter dem User postfix starte der sich nur in den gruppen shadow und root befindet?

perlitz
Posts: 202
Joined: 2003-11-01 12:25

Re: Spamassassin Detuscher Report.

Post by perlitz » 2006-02-13 16:59

Hallo,

ich rufe SA über procmail wie folgt auf

Code: Select all

:0fw: spamassassin.lock
* < 256000
| /usr/bin/spamc -f
Leider klappt mit dem deutschem Report nicht, trotz einträgen wie

Code: Select all

LANG=de_DE.ISO-8859-15
LC_ALL=de_DE@euro
LANGUAGE=de_DE@euro
LC_CTYPE=de_DE@euro
export LANG LC_ALL LANGUAGE LC_CTYPE
Jemand ne Idee?

Thanx
Andreas

perlitz
Posts: 202
Joined: 2003-11-01 12:25

Re: Spamassassin Detuscher Report.

Post by perlitz » 2006-02-13 17:32

Ach ja, debian System...

Ich bin kurz davor ne Belohnung auszusetze... habe schon fast an die 100 Posts in Foren gelesen, doch nie ne Lösung gefunden. :roll:

Es kann doch nicht sein, das alle einfach den englischen Report nutzen, und das obwohl ja eindeutig schon deutsche Reports (Texte) integriert sind.

Boy, was übersehe ich? Wie muss SA aufgerufen werden?

HILFE
:cry:

bfal
Posts: 68
Joined: 2002-07-07 15:12
Location: Lüneburg

Re: Spamassassin Detuscher Report.

Post by bfal » 2006-02-14 11:25

Also bei mir klappt es ohne Probleme...wo hast du denn die Language einträge drin?
Ich habe sie bei mir unter /etc/init.d/spamassassin jeweils vor der
"start-stop-daemon --start xxxxxx" anweisung. So klappt es bei mir auf 2 Servern :wink:

pg-computer
Posts: 144
Joined: 2002-09-27 19:28
Location: Drebach / Erzgebirge

Re: Spamassassin Detuscher Report.

Post by pg-computer » 2006-02-14 12:57

Hoi Hoi,

steh auch vor dem selben Problem ;-)
Spamassassin mit Exim4 - wird über den Spam Check Router aufgerufen

Code: Select all

spamcheck:
  driver = pipe
  command = "/usr/sbin/exim4 -oMr spam-scanned -bS"
  use_bsmtp = true
  transport_filter = "/usr/bin/spamc -u $local_part"
  home_directory = "/tmp"
  current_directory = "/tmp"
  user = Debian-exim
  group = Debian-exim
  log_output = true
  return_fail_output = true
  return_path_add = false
  message_prefix =
  message_suffix =
Also wohin am besten mit den Umgebungsvariablen?
=> habs auch mal mit in den Startscript geschrieben, funzt perfekt...

perlitz
Posts: 202
Joined: 2003-11-01 12:25

Re: Spamassassin Detuscher Report.

Post by perlitz » 2006-02-14 16:33

:?: in den Startscript :?:
Was hast Du wo reingeschrieben? Ins init.d Startscript?

pg-computer
Posts: 144
Joined: 2002-09-27 19:28
Location: Drebach / Erzgebirge

Re: Spamassassin Detuscher Report.

Post by pg-computer » 2006-02-14 21:12

Hoi,

jo habs einfach mit in den Startscript getan

Code: Select all

#! /bin/sh

# Spamd init script
# June 2002
# Duncan Findlay

# Based on skeleton by Miquel van Smoorenburg and Ian Murdock

PATH=/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/spamd
NAME=spamd
SNAME=spamassassin
DESC="SpamAssassin Mail Filter Daemon"
PIDFILE="/var/run/$NAME.pid"
PNAME="spamd"

export TMPDIR=/tmp
export LANGUAGE="de_DE"
export LANG="de_DE@euro"

# Apparently people have trouble if this isn't explicitly set...

# Defaults - don't touch, edit /etc/default/spamassassin
ENABLED=0
OPTIONS=""
NICE=

test -f /etc/default/spamassassin && . /etc/default/spamassassin
--------------------------------------------- SCHNIPP
Evtl. vorher mit dpkg-reconfigure locales die deutsche Sprachumgebung konfigurieren.


Viele Grüße

Peter

perlitz
Posts: 202
Joined: 2003-11-01 12:25

Re: Spamassassin Detuscher Report.

Post by perlitz » 2006-02-15 20:27

Hallo Peter,

ich verstehe das nicht

Code: Select all

locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=de_DE@euro
LC_CTYPE="de_DE@euro "
LC_NUMERIC="de_DE@euro "
LC_TIME="de_DE@euro "
LC_COLLATE="de_DE@euro "
LC_MONETARY="de_DE@euro "
LC_MESSAGES="de_DE@euro "
LC_PAPER="de_DE@euro "
LC_NAME="de_DE@euro "
LC_ADDRESS="de_DE@euro "
LC_TELEPHONE="de_DE@euro "
LC_MEASUREMENT="de_DE@euro "
LC_IDENTIFICATION="de_DE@euro "
LC_ALL=de_DE@euro
bin mir auch nicht sicher, was in dpkg-reconfigure locales einzustellen ist. Denn egal was ich dort währe, ein locale gibt immer obige "Fehlermeldung" aus :( Wobei dpkg-reconfigure keine Fehlermeldung bringt:

Code: Select all

Generating locales...
  de_DE.ISO-8859-1... done
  de_DE.UTF-8... done
  de_DE.UTF-8@euro... done
  de_DE.ISO-8859-15@euro... done
  en_US.ISO-8859-1... done
  en_US.ISO-8859-15... done
Generation complete.

pg-computer
Posts: 144
Joined: 2002-09-27 19:28
Location: Drebach / Erzgebirge

Re: Spamassassin Detuscher Report.

Post by pg-computer » 2006-02-15 20:31

Hoi Hoi,

müsste schon so passen, haste mal versucht nur die beiden Variablen wie bei mir im Startscript zu setzen?

perlitz
Posts: 202
Joined: 2003-11-01 12:25

Re: Spamassassin Detuscher Report.

Post by perlitz » 2006-02-15 20:37

yep, dann bekomme ich in den E-Mails auch nen

Code: Select all

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "de_DE@euro ",
        LC_ALL = "de_DE@euro ",
        LC_CTYPE = "de_DE@euro ",
        LANG = (unset)
    are supported and installed on your system.
geschrieben (anstelle des SA Reports.
Ein debconf-get-selections | grep ^locales ergibt

Code: Select all

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "de_DE@euro ",
        LC_ALL = "de_DE@euro ",
        LC_CTYPE = "de_DE@euro ",
        LANG = (unset)
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
locales locales/default_environment_locale      select  de_DE
locales locales/locales_to_be_generated multiselect     de_DE ISO-8859-1, de_DE.
UTF-8 UTF-8, de_DE.UTF-8@euro UTF-8, de_DE@euro ISO-8859-15, en_US ISO-8859-1, e
n_US.ISO-8859-15 ISO-8859-15
Ein locale-gen hat auch nicht geholfen... :roll:

Ach ja, schon das starten per init.d gibt

Code: Select all

/etc/init.d/spamassassin start
Starting SpamAssassin Mail Filter Daemon: perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "de_DE",
        LC_ALL = "de_DE@euro ",
        LC_CTYPE = "de_DE@euro ",
        LANG = "de_DE@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
spamd.
:?