Postfix und reverse DNS abschalten?

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
bernostern
Posts: 129
Joined: 2003-02-09 12:52

Postfix und reverse DNS abschalten?

Post by bernostern » 2003-09-10 12:13

Hallo,

ich habe ein Problem mit Postfix: Von zu Hause aus kann ich mails auf meinen gmx-Account ohne Probleme versenden.
Von der Arbeit aus geht es nicht. Es kommt folgende Meldung in den Logs:

Code: Select all

Sep 10 12:05:05 pxxxxxxxx postfix/smtpd[14143]: connect from unknown[212.xx.xx.xx]
Sep 10 12:05:05 pxxxxxxxx postfix/smtpd[14143]: E6D518010: client=unknown[212.xx.xx.xx]
Sep 10 12:05:06 pxxxxxxxx postfix/smtpd[14143]: E6D518010: reject: RCPT from unknown[212.xx.xx.xx]: 554 <my_alias@gmx.net>: Relay access denied; from=<real_sender@domain.de> to=<my_alias@gmx.net> proto=ESMTP helo=<pc2>
Sep 10 12:05:07 pxxxxxxxx postfix/smtpd[14143]: disconnect from unknown[212.xx.xx.xx]
Ich denke mal, das relay denied ist, weil der reverse DNS (unkown) nicht funkt. Ich denke aber das ist ein Problem der Namesserver hier in der Arbeit (Admin is im Urlaub *gg*).
Frage: kann ich das reverse DNS im Postfix abschalten? Mach ich mir dadurch irgendwelche Lücken auf? Normalerweise is bei mir relaying verboten, es dürfen nur lokale User senden.

Danke und schönen Gruß,
Bern

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: Postfix und reverse DNS abschalten?

Post by duergner » 2003-09-10 12:19

An welchem Postfix willst du denn was verstellen? Bzw. von wo aus willst du wie Mails verschicken. Ich versteh dein Problem nicht ganz. Wenn GMX die Mail von dem Mailserver bei dir in der Arbeit wegen fehlendem Reverse Lookup nicht annimmt, dann wirst du daran nur dann was ändern können, wenn du einen korrekten Reverse DNS bekommst.

bernostern
Posts: 129
Joined: 2003-02-09 12:52

Re: Postfix und reverse DNS abschalten?

Post by bernostern » 2003-09-10 15:35

Hi,

du hast mich falsch verstanden, oder ich mich missverständlich ausgedrückt. Nicht der Mailserver aus meiner Arbeit wird abgelehnt, sondern ich an meinem Rootie (schon krass, ein Rootie lehnt seinen Herrn ab *g*).

von zu Hause: Ich versende von meinem HeimPC aus eine eMail an meinem GMX-Account. Dazu melde ich mich mit OjE am Rootie an, der erkennt einen lokalen Benutzer bzw. einen gültigen Host und versendet die Mail an GMX. Im Log steht drin:

Code: Select all

connect from pD9DWG87B.dip.t-dialin.net...usw.


aus der Arbeit: Ich möchte wieder mit OjE über meinen Rootie ne mail an GMX verschicken. Ich hab hier die gleichen Kontoeinstellungen wie zuhause (Export->Import in OjE). Leider haut aber hier die Namensauflösung der IP-Adresse nicht hin. Daher bekomme ich im Mail-Log folgenden Eintrag:

Code: Select all

connect from unknown[212.xx.xx.xx]
Und anscheinend ist Postfix so konfiguriert, dass wenn der Host nicht aufgelöst werden kann (unknown) dass dann die Mail nicht versendet wird. Und genau das möchte ich ausschalten.
Da mein Postfix sowieso nur eMails weiterleitet, die von lokalen, angemeldeten Benutzern stammen, muss ja nicht auch noch auf einen gültigen Host geprüft werden.

Wo kann ich das abschalten?

Danke und Gruß,
Bern

duergner
RSAC
Posts: 976
Joined: 2003-08-20 11:30
Location: Pittsburgh, PA, USA

Re: Postfix und reverse DNS abschalten?

Post by duergner » 2003-09-10 15:46

Das sollte normalerweise in der main.cf gehen. Welcher Schalter das genau ist, kann ich dir aber jetzt so ausm Stegreif leider auch nicht sagen, da ich schon seit einiger Zeit von SuSE + Postfix zu Debian + Qmail gewechselt bin.

Sollte irgendetwas mit reject_unknown_sender sein. Poste doch evtl. mal die Ausgabe von postconf

bernostern
Posts: 129
Joined: 2003-02-09 12:52

Re: Postfix und reverse DNS abschalten?

Post by bernostern » 2003-09-10 16:17

Ok alles klar.
Es war 'reject_unauth_destination' . Komisch müsste doch wohl eher reject_unknown_sender oder so heißen...naja.

Leider meckert er aber dann folgendes:

Code: Select all

postfix/smtpd[27294]: fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Könnte ich nicht irgendwie den Zugang hier in der Arbeit als relaying erlaubt eintragen o.ä.?

Danke,
Bern

P.S.: glaub die ganze Ausgabe von postconf is bißchen viel.... daher nur die main.cf. Du darfst gerne Verbesserungsvorschläge bringen :-):

Code: Select all

command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
program_directory = /usr/lib/postfix

sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
queue_directory = /var/spool/postfix

#readme_directory = /etc/postfix/readme
#sample_directory = /etc/postfix/samples
#manpage_directory = /usr/local/man


default_privs = mtafw
mail_owner = postfix
unknown_local_recipient_reject_code = 450

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
setgid_group = postdrop
biff = no
append_dot_mydomain = no


myhostname = mail.domain.tld
mydomain = domain.tld
myorigin = $myhostname


#myhostname =pxxxxxxxx
#mydomain = pureserver.info
#myorigin = $myhostname
mydestination = $myhostname, localhost.$mydomain, localhost, pxxxxxxxx.pureserver.info

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases


#strict_rfc821_envelopes = yes
maps_rbl_domains = sbl.spamhaus.org,relays.ordb.org,unconfirmed.dsbl.org

relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter =

smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_invalid_hostname,reject_rbl_client,permit_mx_backup,reject_unauth_destinati
#smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_non_fqdn_sender,reject_non_fqdn_recipient,reject_non_fqdn_hostname,reject_


### CONFIXX POSTFIX ENTRY ###

virtual_maps = hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains

### /CONFIXX POSTFIX ENTRY ###

#header_checks = regexp:/etc/postfix/header_checks
#body_checks = regexp:/etc/postfix/body_checks
#mime_header_checks = regexp:/etc/postfix/mime_header_checks

# Other configurable parameters.
smtpd_tls_key_file = /etc/postfix/server.pem
smtpd_tls_cert_file = /etc/postfix/server.pem
smtpd_tls_CAfile = /etc/postfix/server.pem
smtpd_use_tls = yes

tls_random_source = dev:/dev/urandom
tls_daemon_random_source = dev:/dev/urandom

mailbox_transport = cyrus