QMail Probleme ?

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

QMail Probleme ?

Post by petter » 2003-07-07 13:09

Hi,

da bin ich wieder :oops:

Also ,

habe mal ps -aux |grep qmail gemacht und folgende ausgabe erhalten:

Code: Select all

root 505 0.0 0.0 1248 88 ? S 2002 0:04 supervise qmail-send 
root 506 0.0 0.0 1248 88 ? S 2002 0:04 supervise log 
root 507 0.0 0.0 1248 88 ? S 2002 0:05 supervise qmail-smtpd 
root 508 0.0 0.0 1248 88 ? S 2002 0:04 supervise log 
root 509 0.0 0.0 1248 88 ? S 2002 0:04 supervise qmail-pop3d 
root 510 0.0 0.0 1248 88 ? S 2002 0:04 supervise log 
qmails 511 0.0 0.0 1320 152 ? S 2002 0:31 qmail-send 
qmaild 512 0.0 0.0 1324 120 ? S 2002 0:01 /usr/local/bin/tcpserver -v -R -l 0 -x /home/vpopmail/etc/tcp.s 
qmaill 513 0.0 0.0 1268 204 ? S 2002 0:07 /usr/local/bin/multilog t /var/log/qmail 
qmaill 514 0.0 0.0 1268 108 ? S 2002 0:00 /usr/local/bin/multilog t /var/log/qmail/smtpd 
root 515 0.0 0.0 1280 100 ? S 2002 0:07 /usr/local/bin/tcpserver -v -R -H -l 0 0 110 /var/qmail/bin/qma 
qmaill 516 0.0 0.0 1268 204 ? S 2002 0:06 /usr/local/bin/multilog t /var/log/qmail/pop3d 
root 522 0.0 0.0 1260 36 ? S 2002 0:01 qmail-lspawn ./Maildir/ 
qmailr 523 0.0 0.0 1264 60 ? S 2002 0:06 qmail-rspawn 
qmailq 524 0.0 0.0 1252 60 ? S 2002 0:07 qmail-clean 
Habe dann versucht qmail neu zu starten einmal mit
/etc/init.d/qmail restart
und einmal mit
/var/qmail/rc
(bekomme ich als meldung: alert: cannot start: unable to switch to queue directory)

Wenn ich versuche qmail zu stoppen:
/etc/init.d/qmail stop
sagt der zwar qmail wurde gestoppt aber die Prozesse laufen noch immer,

also hab ich per KILL die tasks einzeln gelöscht,
dann wieder ein ps aux |grep qmail welches mir folgendes zurück gibt:

Code: Select all

p15097027:/var/qmail # ps aux |grep qmail
qmails     511  0.0  0.0  1320  168 ?        S     2002   0:31 qmail-send
qmaill     513  0.0  0.0  1268  204 ?        S     2002   0:07 /usr/local/bin/multilog t /var/log/qmail
qmaill     514  0.0  0.0  1268  192 ?        S     2002   0:01 /usr/local/bin/multilog t /var/log/qmail/smtpd
qmaill     516  0.0  0.0  1268  204 ?        S     2002   0:06 /usr/local/bin/multilog t /var/log/qmail/pop3d
root       522  0.0  0.0     0    0 ?        Z     2002   0:01 [qmail-lspawn <defunct>]
qmailr     523  0.0  0.0     0    0 ?        Z     2002   0:06 [qmail-rspawn <defunct>]
qmailq     524  0.0  0.0     0    0 ?        Z     2002   0:07 [qmail-clean <defunct>]
root     24577  0.0  0.1  1248  340 ?        S    12:51   0:00 supervise qmail-send
qmails   24578  0.0  0.1  1292  336 ?        S    12:51   0:00 qmail-send
root     24580  0.0  0.1  1260  356 ?        S    12:51   0:00 qmail-lspawn ./Maildir/
qmailr   24581  0.0  0.0     0    0 ?        Z    12:51   0:00 [qmail-rspawn <defunct>]
qmailq   24582  0.0  0.0     0    0 ?        Z    12:51   0:00 [qmail-clean <defunct>]
root     24583  0.0  0.1  1248  340 ?        S    12:51   0:00 supervise qmail-smtpd
root     24584  0.0  0.1  1248  340 ?        S    12:51   0:00 supervise qmail-pop3d
qmaild   24585  0.0  0.2  1324  528 ?        S    12:51   0:00 /usr/local/bin/tcpserver -v -R -l 0 -x /home/vpopmail/etc/tcp.smtp.cdb -c 20 -u 506 -g 501 0 smtp /var/qmail/bin/qmail-smtpd
root     24587  0.0  0.1  1280  380 ?        S    12:51   0:00 /usr/local/bin/tcpserver -v -R -H -l 0 0 110 /var/qmail/bin/qmail-popup p15097027 /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir
p15097027:/var/qmail #
Irgendwie lassen die Proezesse sich nicht Killen , hmm.

Ich hab gestern mein System auf Apache 1.3.27 und Php 4.2.3 geupdatet,
könnte das irgendwie damit zusammenhaengen ?

Danke.

Hier noch was :

Code: Select all

Restarting qmail:
* Stopping qmail-smtpd.
* Sending qmail-send SIGTERM and restarting.
* Restarting qmail-smtpd.
* Restarting qmail-pop3d.
die /var/log/httpd/error_log hat folgendes getrackt, sehe da nichts in Zusammenhang :(

Code: Select all

[Mon Jul  7 03:07:32 2003] [notice] Apache/1.3.27 (Unix) PHP/4.2.3 mod_ssl/2.8.12 OpenSSL/0.9.6b mod_perl/1.25 configured -- $
[Mon Jul  7 03:07:32 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul  7 03:07:32 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Mon Jul  7 03:07:54 2003] [notice] caught SIGTERM, shutting down
[Mon Jul  7 03:08:00 2003] [notice] Apache/1.3.27 (Unix) PHP/4.2.3 mod_ssl/2.8.12 OpenSSL/0.9.6b mod_perl/1.25 configured -- $
[Mon Jul  7 03:08:00 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul  7 03:08:00 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
Hoffe jemand hat nen Tipp weil weiß nicht wo ich noch suchen soll nach den Fehler.

Danke
gruß
petter

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 15:04

Komischerweise laesst sich mein qmail irgendwie nicht beenden :(

So das ich es versuchen könnte neu zu installieren.

killall qmail-send geht nicht , die einzelnen Prozesse killen geht auch nicht,
killall inetd geht auch nicht.

Bin am verzweifeln

Danke
gruß
petter

gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: QMail Probleme ?

Post by gamecrash » 2003-07-07 15:05

Für Qmail gibt's hier andere Spezialisten, aber zumindestens beim Killen kann ich Dir wohl weiterhelfen...

kill -9 PID

das ist dann auf die ganz harte Tour...

Was die Logs angeht, wirst Du in den Apache-Logs mit Sicherheit nix finden ;) Gibt da extra Qmail-Logs, ich glaub in /var/log/qmail oder so

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:10

GameCrash wrote:Für Qmail gibt's hier andere Spezialisten, aber zumindestens beim Killen kann ich Dir wohl weiterhelfen...

kill -9 PID

das ist dann auf die ganz harte Tour...

Was die Logs angeht, wirst Du in den Apache-Logs mit Sicherheit nix finden ;) Gibt da extra Qmail-Logs, ich glaub in /var/log/qmail oder so
Naja, hab qmail nun deinstalliert und mit qmail installer wieder drüber gebügelt. Scheint auch alles geklappt zu haben , dennoch funzt es nicht, scheint irgendwie als wenn mein Webserver nicht lauschen würde , weiß jetzt nicht wie ich das anders erklaeren soll.
:(
grummel

Brauche glaube ich doch ein Spezialisten ....
Ist Sartre gerade zufaellig da ? :-D

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:13

hmm moment ... :)
Tut sich was ;)

hab jetzt mal pop.meinedomain.de statt nur meinedomain.de angegeben, nun scheint es zu gehen.

Vorher gings auch ohne das pop, nunja, mal gucken ob jetzt alles beim alten ist.

Danke noch mal

+gruß
petter

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:17

Noch eine Frage: wie kriege ich die qmail Leichen weg ?

Code: Select all

#511       511  0.0  0.0  1320  168 ?        S     2002   0:31 qmail-send
#507       513  0.0  0.0  1268  204 ?        S     2002   0:07 /usr/local/bin/multilog t /var/log/qmail
#507       514  0.0  0.0  1268  192 ?        S     2002   0:01 /usr/local/bin/multilog t /var/log/qmail/smtpd
#507       516  0.0  0.0  1268  204 ?        S     2002   0:06 /usr/local/bin/multilog t /var/log/qmail/pop3d
root       522  0.0  0.0     0    0 ?        Z     2002   0:01 [qmail-lspawn <defunct>]
#510       523  0.0  0.0     0    0 ?        Z     2002   0:06 [qmail-rspawn <defunct>]
#509       524  0.0  0.0     0    0 ?        Z     2002   0:07 [qmail-clean <defunct>]
root     31550  0.0  0.1  1248  340 ?        S    15:55   0:00 supervise qmail-send
root     31552  0.0  0.1  1248  340 ?        S    15:55   0:00 supervise qmail-smtpd
qmails   31554  0.0  0.1  1304  428 ?        S    15:55   0:00 qmail-send
qmaill   31563  0.0  0.1  1264  348 ?        S    15:55   0:00 /usr/local/bin/multilog t /var/log/qmail
qmaill   31574  0.0  0.1  1264  348 ?        S    15:55   0:00 /usr/local/bin/multilog t /var/log/qmail/smtpd
qmaild   31575  0.0  0.2  1324  528 ?        S    15:55   0:00 /usr/local/bin/tcpserver -v -R -l 0 -x /home/vpopmail/etc/tcp.smtp.cdb -c 20 -u 546 -g 501 0 smtp /var/qmail/bin/qmail-smtpd
root     31581  0.0  0.1  1260  360 ?        S    15:55   0:00 qmail-lspawn ./Maildir/
qmailr   31582  0.0  0.1  1260  356 ?        S    15:55   0:00 qmail-rspawn
qmailq   31583  0.0  0.1  1252  376 ?        S    15:55   0:00 qmail-clean
root     31584  0.0  0.1  1248  340 ?        S    15:55   0:00 supervise qmail-pop3d
root     31586  0.0  0.1  1280  380 ?        S    15:55   0:00 /usr/local/bin/tcpserver -v -R -H -l 0 0 110 /var/qmail/bin/qmail-popup p15097027 /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir
qmaill   31597  0.0  0.1  1264  348 ?        S    15:55   0:00 /usr/local/bin/multilog t /var/log/qmail/pop3d
Da wo defunct steht ist ja offensichtlich tod ?

Danke

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: QMail Probleme ?

Post by captaincrunch » 2003-07-07 16:30

Genau : defunct sind Zombie-Prozesse, was so viel heißt, dass der Elternprozess nicht mehr da ist, und den Kindprozess nicht sauber mitbeendet hat, der jetzt nur noch nutzlos im System rumgeistert.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: QMail Probleme ?

Post by olaf.dietsche » 2003-07-07 16:32

Wenn ich das Datum richtig interpretiere, dann scheinen dich diese Zombies seit über einem halben Jahr nicht zu stören. ;-)

Solange der Elternprozess existiert und nicht nach seinen verstorbenen Kindern sieht, bleiben diese Zombies bestehen (qmail scheint da nicht ganz sauber programmiert zu sein). Als Lösung hilft dann nur, den Elternprozess zu beenden und neu zu starten.

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:34

CaptainCrunch wrote:Genau : defunct sind Zombie-Prozesse, was so viel heißt, dass der Elternprozess nicht mehr da ist, und den Kindprozess nicht sauber mitbeendet hat, der jetzt nur noch nutzlos im System rumgeistert.
Das heist die bleiben jetzt da auf immer und ewig ? :twisted:

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: QMail Probleme ?

Post by captaincrunch » 2003-07-07 16:35

Theoretisch ja, sofern du dich nicht mit Silberkugeln (und bestenfalls einem beherzten "kill") bewaffnet auf sie stürzt ... ;)
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:35

olaf.dietsche wrote:Wenn ich das Datum richtig interpretiere, dann scheinen dich diese Zombies seit über einem halben Jahr nicht zu stören. ;-)
Bis gestern waren diese Zombie Prozesse noch mein funktionierendes Qmail ;)
Mit der neuinstall eben sind die irgendwie kleben geblieben :(

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: QMail Probleme ?

Post by olaf.dietsche » 2003-07-07 16:36

CaptainCrunch wrote:defunct sind Zombie-Prozesse, was so viel heißt, dass der Elternprozess nicht mehr da ist,
Wenn der Elternprozess schon verstorben ist, werden noch vorhandene Kinder (egal ob lebende oder Zombies) an init "vererbt". Init kümmert sich dann im Falle ihres Ableben um Aufräumarbeiten im System.

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:37

CaptainCrunch wrote:Theoretisch ja, sofern du dich nicht mit Silberkugeln (und bestenfalls einem beherzten "kill") bewaffnet auf sie stürzt ... ;)
Was verstehst du unter einen beherzten "Kill" ? hmm.
weil kill <PID> tuts nicht .

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: QMail Probleme ?

Post by olaf.dietsche » 2003-07-07 16:38

petter wrote:Bis gestern waren diese Zombie Prozesse noch mein funktionierendes Qmail ;)
Mit der neuinstall eben sind die irgendwie kleben geblieben :(
Dann hast du - bzw. die Installationsroutine von qmail - den alten qmail nicht beendet. Das solltest du nachholen.

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: QMail Probleme ?

Post by captaincrunch » 2003-07-07 16:40

Ein "kill -9 PID" als root tut immer ... :twisted:
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:42

olaf.dietsche wrote:
petter wrote:Bis gestern waren diese Zombie Prozesse noch mein funktionierendes Qmail ;)
Mit der neuinstall eben sind die irgendwie kleben geblieben :(
Dann hast du - bzw. die Installationsroutine von qmail - den alten qmail nicht beendet. Das solltest du nachholen.
Hmm. Ok also noch mal installieren, kein problem,
nur wie den alten qmail beenden wenn er nicht mehr da ist ;)

BIn vorgegangen wie in der FAQ hier:
http://www.rootforum.org/faq/index.php ... d=52&lang=

rm - alles alte qmail :)

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: QMail Probleme ?

Post by olaf.dietsche » 2003-07-07 16:42

Hier geht's ja zu wie im Taubenschlag. Eine Antwort jagt die andere :-D

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:45

CaptainCrunch wrote:Ein "kill -9 PID" als root tut immer ... :twisted:
Tjo, bei mir leider nicht .
Der meckert auch nicht , aber beu der neuen auflistung sind die prozesse noch da, evtl sollte ich mal den Kompletten server neu booten.

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 16:46

olaf.dietsche wrote:Hier geht's ja zu wie im Taubenschlag. Eine Antwort jagt die andere
.... Frage ;)

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: QMail Probleme ?

Post by olaf.dietsche » 2003-07-07 16:47

petter wrote:Hmm. Ok also noch mal installieren, kein problem,
nur wie den alten qmail beenden wenn er nicht mehr da ist ;)

BIn vorgegangen wie in der FAQ hier:
http://www.rootforum.org/faq/index.php ... d=52&#9001;=
Du mußt qmail nicht noch einmal installieren. Es genügt, wenn du den alten qmail beendest. Erst einmal ein /etc/init.d/qmail stop und danach mit ps nachsehen, ob noch qmail Prozesse (damit meine ich nicht die Zombies) laufen. Diese Prozesse mußt du dann - wie CaptainCrunch so schön sagte :-) - mit einem beherzten kill beenden.

Wenn dann keine qmail Prozesse mehr existieren, kannst du qmail wieder starten mit

Code: Select all

/etc/init.d/qmail start

petter
Posts: 67
Joined: 2002-06-18 16:41
Location: Aachen

Re: QMail Probleme ?

Post by petter » 2003-07-07 17:00

olaf.dietsche wrote:Du mußt qmail nicht noch einmal installieren. Es genügt, wenn du den alten qmail beendest. Erst einmal ein /etc/init.d/qmail stop und danach mit ps nachsehen, ob noch qmail Prozesse (damit meine ich nicht die Zombies) laufen. Diese Prozesse mußt du dann - wie CaptainCrunch so schön sagte :-) - mit einem beherzten kill beenden.

Wenn dann keine qmail Prozesse mehr existieren, kannst du qmail wieder starten mit

Code: Select all

/etc/init.d/qmail start
Ok. das scheint es gewesen zu sein nun sind die Zombies weg :))

Danke euch nochmal .