Warum Empfänger: web1p1@p2787382.pureserver.info???

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
maik
Posts: 82
Joined: 2003-04-14 19:31

Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by maik » 2003-05-28 09:40

Hallo,

ich habe auf dem Account web1p1 nur einen * Account. Wenn ich jetzt von GMX eine Mail an test@meinedomain.de schicke, bekomme ich in Outlook als Empfänger der eMail angezeigt web1p1@p2787382.pureserver.info da müßte doch eigentlich test@meinedomain.de drinstehen oder?

Was ist falsch

mark
Posts: 295
Joined: 2003-04-15 16:48
Location: Oldenburg

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by mark » 2003-05-28 11:14

Hi,

1. zeig mal den Mail Header dieser E-Mail
2. Zeig mal "postconf -n"

Dann können wir dir die Frage hoffentlich beantworten.

Aber du hast recht: Normalerweise sollte das nicht.

Gruß
Mark

maik
Posts: 82
Joined: 2003-04-14 19:31

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by maik » 2003-05-28 12:11

Hi,

anbei die Postconf, wie kann ich mir den Mail Head anzeigen lassen?

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
default_privs = autoresp
fast_flush_domains = $relay_domains
in_flow_delay = 0
inet_interfaces = all
local_recipient_maps = $alias_maps unix:passwd.byname
mail_owner = postfix
mail_spool_directory = /var/mail
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains = tauch-partner.de
masquerade_exceptions = root
mydestination = $myhostname, localhost.$mydomain, $mydomain, smtp.$mydomain
mydomain = tauch-partner.de
myhostname = p15125586.pureserver.info
mynetworks_style = host
newaliases_path = /usr/sbin/sendmail
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_client_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/cacert.pem
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains

mark
Posts: 295
Joined: 2003-04-15 16:48
Location: Oldenburg

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by mark » 2003-05-28 12:13

Hi,
anbei die Postconf, wie kann ich mir den Mail Head anzeigen lassen?
in Outlook Express ?
Mail auswählen und STRG + F3 drücken...

Edit:
Ist das eigentlich die Default konfig von 1&1 ??? Oder hast du das schon etwas geändert..

Hab da noch ein paar Ã?nderungsvorschläge, aber zeig mal erst den Header.

Gruß
Mark

maik
Posts: 82
Joined: 2003-04-14 19:31

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by maik » 2003-05-28 12:26

Ja, das ist die standard 1&1 config.
Leider nutzen wir kein Outlook, ich habs aber mal gerade eingerichtet und abgerufen. In Outlook stimmt alles auch mit den Empfänger Adressen. Anscheinend ist es ein Problem von David XL. Oder?
Leider geht STRG F3 nicht in Outlook

mark
Posts: 295
Joined: 2003-04-15 16:48
Location: Oldenburg

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by mark » 2003-05-28 12:35

Maik wrote:Ja, das ist die standard 1&1 config.
Leider nutzen wir kein Outlook, ich habs aber mal gerade eingerichtet und abgerufen. In Outlook stimmt alles auch mit den Empfänger Adressen. Anscheinend ist es ein Problem von David XL. Oder?
Leider geht STRG F3 nicht in Outlook
Meist gibt es in jeden Programm die Option den Header anzuschauen. In Outlook solltest du die mail auch mit der rechten Maustause auswählen und dort die Eigenschaften selektieren können...

Aber dann scheint es wirklich nur ein Anzeige Problem von David XL zu sein.

Normalerweise sollte der MUA (dein E-Mail Client) die "An:" Adresse aus dem header anzeigen. Aber anscheinen hält sich David XL nicht daran und zeigt dir lieber die letzte Delivered-To oder zieht sich seine Informationen aus dem letzten "Received:" Eintrag aus dem Header...

Da kannst du nichts gegen machen. Einfach nur einen anderen Client nutzen.

BTW. Trotzdem die Empfehlung:

Ã?nder mal folgendes noch ab:

Code: Select all

myorigin=$myhostname
smtpd_recipient_restrictions = 
   permit_mynetworks, 
   permit_sasl_authenticated, 
   reject_unauth_destination 
Siehe auch diesen Thread: http://www.rootforum.org/forum/viewtopic.php?t=11443

Zum testen: soft_bounce=yes, danach wieder rausnehmen... :)

Ach ja:
Ich hoffe dein mynetworks ist zumindest:

Code: Select all

mynetworks = 127.0.0.1/24
Ah. ist ja egal. du hast ja "mynetworks_style = host" :)

Gruß
Mark

bobby
Posts: 146
Joined: 2003-08-03 13:42

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by bobby » 2003-08-06 20:50

Hi!

Ich hab hier auch nen David Server und hatte das gleiche Problem. Hast du dein schon gelöst? Wenn ja, wie.
Normalerweise sollte der MUA (dein E-Mail Client) die "An:" Adresse aus dem header anzeigen. Aber anscheinen hält sich David XL nicht daran und zeigt dir lieber die letzte Delivered-To oder zieht sich seine Informationen aus dem letzten "Received:" Eintrag aus dem Header...

Da kannst du nichts gegen machen. Einfach nur einen anderen Client nutzen.
Irrtum... Ich hab da ein kleines Workarround:
Gib einfach mal im Grabbing-Sever, in den Eigenschaften des Postfachs im Feld "Auszuwertendes Adressfeld" ein To ein, dann funktionierts. U.U. kann das allerding dazu führen, dass in "Unverteilt", dann für jeden im To angegebenen Empfänger eine Mail erzeugt wird.

Ich suche noch nach ner Lösung, ohne die Angabe in der David-Konf. zu machen. Kann man dem Postfix oder Procmail sagen, dass er das Delivered-To auf die Empfängeradresse setzen soll?

Gruß

Bobby

bobby
Posts: 146
Joined: 2003-08-03 13:42

Re: Warum Empfänger: web1p1@p2787382.pureserver.info???

Post by bobby » 2003-08-23 19:36

Hallo zusammen!

Nach einigen Stunden suchen und Probieren bin ich da auf etwas gestoßen: Man kann Postfix sagen, dass er in lokal ausgelieferte Mails keinen Delivered-To Header setzen soll.
Das geht ganz einfach mit einer Zeile in der main.cf:

Code: Select all

prepend_delivered_header = command, forward
Wenn die, bzw. eine ähnliche Zeile noch nicht vorhanden ist einfach am Ende hinzufügen.
Die Zeile sagt Postfix, dass er Delivered-To nur setzen soll, wenn er en einen Command ausliefert oder eben forwardet.
Der Parameter sollte mindestens forward enthalten, sonst kann es Probleme geben. (siehe Postfix FAQ)

Anschließend einen Postfix neustart, fertig, Problem weg.

Gruß

B.