Sendmail will nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
bleed
Posts: 4
Joined: 2005-09-12 10:56

Sendmail will nicht

Post by bleed » 2005-09-12 11:13

Guten Morgen alle miteinander.

Ich habe eine Frage bezüglich sendmail von Linux. Und zwar versuche ich mit PHP per mail() eine E-Mail zu versenden und dies wird auch mit bool(true) quittiert, jedoch wird keine mail versandt. Nachdem ich das bemerkt habe, habe ich mich zuerst auf meinen Root eingeloggt und es manual mit sendmail versucht, jedoch erfolglos. Wenn ich sendmail anwende kann ich ins unendliche auf eine response des Servers warten da hilft nur ein Abort (CTRL+C - (Putty)). Könnte mir jemand vlt. helfen sendmail zum laufen zu bringen ohne irgend ein 'subprogramm' à la QMail o.a.?

Ich bedanke mich hiermit schon im voraus,

bLeEd

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Sendmail will nicht

Post by Roger Wilco » 2005-09-12 12:02

bLeEd wrote:Könnte mir jemand vlt. helfen sendmail zum laufen zu bringen ohne irgend ein 'subprogramm' à la QMail o.a.?
qmail ist kein "subprogramm", sondern ein ausgewachsener MTA. Du meinst wahrscheinlich nur das sendmail-Binary (/usr/sbin/sendmail o. ä.), welches von den meisten MTAs aus Kompatibilitätsgründen mitgeliefert wird.
Schau in deine Maillogs, ob der MTA die Mails überhaupt angenommen hat. Wenn ja, wird darin auch stehen, weshalb er sie nicht ausliefert.

bleed
Posts: 4
Joined: 2005-09-12 10:56

Re: Sendmail will nicht

Post by bleed » 2005-09-12 12:16

ja genau und scheinbar benutzt mein server standardmässig exim als mta.

und das ist was ich aus den logauszügen als sinnvoll betrachte:

2005-03-24 03:42:22 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned

kannst du mir mit diesem error evtl. weiterhelfen? mir sagt die error message schon etwas jedoch nicht wie ich ihn beheben kann (den error)

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Sendmail will nicht

Post by Roger Wilco » 2005-09-12 12:30

Dann schau erstmal nach, was bereits auf 127.0.0.1:25 läuft und beende den Prozess. `netstat -tulpen|grep 25` oder `lsof -i :25` verraten es dir.

bleed
Posts: 4
Joined: 2005-09-12 10:56

Re: Sendmail will nicht

Post by bleed » 2005-09-12 12:36

paradoxer oder gerade logischerweise tut exim das scheinbar selbst

auszug aus lsof -i :25

exim4 466 Debian-exim 3u IPv4 1208 TCP R240207:smtp (LISTEN)

**EDIT

habe es immernoch nicht geschafft. wäre also über weitere postings erfreut : |

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Sendmail will nicht

Post by Roger Wilco » 2005-09-12 19:37

bLeEd wrote:habe es immernoch nicht geschafft. wäre also über weitere postings erfreut : |
Dann schreib, was sich geändert hat.

bleed
Posts: 4
Joined: 2005-09-12 10:56

Re: Sendmail will nicht

Post by bleed » 2005-09-13 11:59

Nunja hab mitlerweile geschafft es zum laufen zu bringen.

(dpkg-reconfigure exim4-config)

das problem nun ist das dieses verschissen programm sich einfach das recht einholt port 80 zu benutzen und das einfach so.. port 25 ist nun frei... sowas ver* habe ich schon lange nicht mehr gesehen denn nun kann ich die php funktion mail() nicht mehr benutzen da der apache nicht mehr startet... (already in use... :-))

ich bedanke mich im vorraus für jegliche hilfe