courier: pop3/imap funktionieren nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
pico78
Posts: 30
Joined: 2004-10-18 15:19

courier: pop3/imap funktionieren nicht

Post by pico78 » 2005-07-01 15:18

kann es sein das courier seine dienste wie pop3 und imap selber startet?? bei mir sieht die start-meldung wie folgt aus :

Code: Select all

File: mail.info         Col 0              271407 bytes                                                        97%
Jun 30 19:53:00 argon117 courierd: Loading STATIC transport module libraries.
Jun 30 19:53:00 argon117 courierd: Courier 0.50.0 Copyright 1999-2005 Double Precision, Inc.
Jun 30 19:53:00 argon117 courierd: Installing [0/0]
Jun 30 19:53:00 argon117 courierd: Installing uucp
Jun 30 19:53:00 argon117 courierd: Installed: module.uucp - Courier 0.50.0 Copyright 1999-2005 Double Precision, Inc.
Jun 30 19:53:00 argon117 courierd: Installing local
Jun 30 19:53:00 argon117 courierd: Installed: module.local - Courier 0.50.0 Copyright 1999-2005 Double Precision,Inc.
Jun 30 19:53:00 argon117 courierd: Installing fax
Jun 30 19:53:00 argon117 courierd: Installed: module.fax - Courier 0.50.0 Copyright 1999-2005 Double Precision, Inc.
Jun 30 19:53:00 argon117 courierd: Installing esmtp
Jun 30 19:53:00 argon117 courierd: Installed: module.esmtp - Courier 0.50.0 Copyright 1999-2005 Double Precision,Inc.
Jun 30 19:53:00 argon117 courierd: Installing dsn
Jun 30 19:53:00 argon117 courierd: Installed: module.dsn - Courier 0.50.0 Copyright 1999-2005 Double Precision, Inc.
Jun 30 19:53:00 argon117 courierd: Initializing uucp
Jun 30 19:53:00 argon117 courierd: Initializing local
Jun 30 19:53:00 argon117 courierd: Initializing fax
Jun 30 19:53:00 argon117 courierd: Initializing esmtp
Jun 30 19:53:00 argon117 courierd: Initializing dsn
Jun 30 19:53:00 argon117 courierd: Started ./courieruucp, pid=1110, maxdels=4, maxhost=4, maxrcpt=16
Jun 30 19:53:00 argon117 courierd: Started ./courierlocal, pid=1111, maxdels=10, maxhost=4, maxrcpt=1
Jun 30 19:53:00 argon117 courierd: Started ./courierfax, pid=1112, maxdels=1, maxhost=1, maxrcpt=1
Jun 30 19:53:00 argon117 courierd: Started ./courieresmtp, pid=1113, maxdels=40, maxhost=4, maxrcpt=100
Jun 30 19:53:00 argon117 courierd: Started ./courierdsn, pid=1114, maxdels=4, maxhost=1, maxrcpt=1
Jun 30 19:53:00 argon117 courierd: queuelo=200, queuehi=400
Jun 30 19:53:00 argon117 courierd: Purging /usr/lib/courier/var/msgq
Jun 30 19:53:00 argon117 courierd: Purging /usr/lib/courier/var/msgs
Jun 30 19:53:00 argon117 courierd: Waiting.  shutdown time=Thu Jun 30 20:53:00 2005, wakeup time=Thu Jun 30 20:53:00 2005, queuedelivering=0, inprogress=0
ich habe nämlich das problem das ich per smtp emails versenden kann, aber weder per pop3 noch per imap empfangen kann...

und ich bekomme leider nur recht wenig aussagende fehlermeldungen:

Code: Select all

Jun 29 18:47:12 argon117 pop3d: Connection, ip=[::ffff:80.138.76.68]Jun 29 18:47:12 argon117 pop3d: LOGIN FAILED, user=web2p8, ip=[::ffff:80.138.76.68]Jun 29 18:47:17 argon117 pop3d: Disconnected, ip=[::ffff:80.138.76.68]
diese allerdings auch nur wenn ich den pop3d vom courier per hand starte... :-/

was kann ich tuen? welche dateien soll ich mal posten?
weiss mir ehrlich nicht mehr zu helfen... hatte noch mehr probleme mit postfix, aber die habe ich mittlerweile gelöst...

achja, mein rechner:
suse 9.0
postfix aktuelle version ,selbst kompiliert
courier aktuelle verision ,selbst kompiliert
maildrop/courier auth aktuelle version, selbst kompiliert

wenn ihr genau versionsnummern braucht, einfach schreiben, ich poste alles was ihr braucht um mir zu helfen...

gruss markus

static
Posts: 437
Joined: 2002-10-27 19:56
Location: Schweiz

Re: courier: pop3/imap funktionieren nicht

Post by static » 2005-07-01 15:41

Hi
also in deiner mail.info seh ich zwar einige Module (uucp, fax etc.) die geladen werden, aber weder von pop3 noch von imap steht da was.

Ich denke daher, dass sie gar nicht (automatisch) gestartet werden (Kannst du mit netstat -ltp überprüfen).

Wenn du ihn von Hand startest, funktioniert die Connection ja im Prinzip, dein Login ist lediglich falsch (Passwort und Benutzername wirklich korrekt?).

Ansonsten müsstest du wahrscheinlich mal die Configs vom Courier posten.

.static

pico78
Posts: 30
Joined: 2004-10-18 15:19

Re: courier: pop3/imap funktionieren nicht

Post by pico78 » 2005-07-01 15:53

Jab, also wiegesagt, ich muss pop3 und imap immer per hand starten, aber dnann funktionieren diese nit. Kann es sein das ich da ne chroot-beschränkung habe?
Naja, und wenn ich halt pop3 und imap per hand starte, dann sagen die immer das login falsch wäre, obwohl es GENAU die gleichen daten sind wie ich sie für smtp benutze. Und bei smtp funktionieren die ja...

Wo muss ich denn angeben welche module gestartet werden?
Da gibts doch bestimmt ne conf datei oder?
Werde gleich aber auch noch auf jedefall mal die configurationsdateien posten die ich finde. (Aber bin noch auf der Arbeit *grins*)

pico78
Posts: 30
Joined: 2004-10-18 15:19

Re: courier: pop3/imap funktionieren nicht

Post by pico78 » 2005-07-01 20:27

static: danke nochmal für die hilfe, aber ich habs jetzt :-)

keine ahnung warum, aber nachdem ich das courier-imap rpm installiert habe funktioniert alles tadelos...

gruss markus