Exim und vExim - Mailadressenprobleme

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
erland
Posts: 21
Joined: 2004-11-22 00:08

Exim und vExim - Mailadressenprobleme

Post by erland » 2004-12-09 10:23

Ich benutze exim und für das Mailadressenanlegen vExim.
Heute habe ich parallel 2 Weiterleitungen angelegt.

Einmal
test-test@domain.de, die weitergeleitet wird auf abc@domain2.de
und dann noch
test@domain.de, die ebenfalls weitergeleitet wird auf abc@domain2.de

die zweite Mailadresse funktioniert. Bei der ersten bekomme ich den Fehler:

Code: Select all

          test-test@domain.de
                      Unknown user
    
zurück, obwohl die Adresse auch eingerichtet ist. vExim trägt die Adressen ja über mysql ein und da scheint das erstmal soweit richtig in der DB zu stehen ...
Mir scheint es so, als wenn exim Probleme mit "-" im Localpart hat. Gibt es da irgendwelche Lösungen um das zu fixen?

Gruß Erl

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Exim und vExim - Mailadressenprobleme

Post by dodolin » 2004-12-09 10:44

Das ist eine FAQ und sie wurde bereits mehrfach auf der vexim Mailingliste beantwortet.

Vielleicht sollte man das mal ins vexim Wiki eintragen oder noch besser: gleich in das Howto auf debianhowto.de...

http://keylime.silverwraith.com/piperma ... .html#3037
http://keylime.silverwraith.com/piperma ... .html#3123

erland
Posts: 21
Joined: 2004-11-22 00:08

Re: Exim und vExim - Mailadressenprobleme

Post by erland » 2004-12-09 13:03

Vielen Dank für die fixe Antwort.

Hatte bisher nur auf deutsch rumgegoogled und nichts gefunden!