postfix/sasl/pam_mysql.so problem

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
mikeiv
Posts: 32
Joined: 2003-10-05 12:53

postfix/sasl/pam_mysql.so problem

Post by mikeiv » 2004-09-13 18:15

ich habe vor kurzen auf meine rootie ein backport bpn postfix installiert (von backports.org) dieses dann aber wieder entfernt wegen mehrerer problem. seit dem hab ich ein kleines problem mit meinen postfix (das ja mit den woody paketen schon sehr gut lief)

postfix benutzt eine mysql db für die user (laut dem tutorial von: http://workaround.org/articles/ispmail/)

das empfangen von emails mit courier-pop3 geht. das senden an emails auf dem server geht auch, die emails landen in den richtigen maildirs.

jedoch das senden von emails von den email adressen am server geht nicht. ich hab sehr lange herumgeforscht bis ich schlieslich in der /etc/pam.d/smtp gelandet bin.

wenn ich testweise: auth required pam_permit.so einfüge, kann man ohne login/pw senden über den server, wenn ich jedoch das einfüge (laut tutorial, was ja schonlief):

auth required pam_mysql.so user= passwd= host= db= table= usercolumn= passwdcolumn= crypt=1

geht es eben nichtmehr. meine logs sagen mir dann das:

/var/log/auth: Sep 13 18:11:27 hxxx PAM_unix[16932]: authentication failure; (uid=103) -> **unknown** for smtp service
/var/log/mail.log Sep 13 18:11:29 hxxx smtpd[16932]: warning: unknown[80.xx.xx.xx]: SASL PLAIN authentication failed

in der /var/log/mysql.log ist auch kein versuch einer verbindung. ich würde mal sagen es geht deswegen nicht weil er nicht zur mysql db verbindet. die frage ist nur warum er das nicht macht, bzw was ist seit dem backport anders?

hat jemand von euch eine idee oder einen tip der mich weiterbringt.

P.S.: postfix läuft jetzt gerade nicht im chroot

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: postfix/sasl/pam_mysql.so problem

Post by Roger Wilco » 2004-09-13 19:36

mikeIV wrote:auth required pam_mysql.so user= passwd= host= db= table= usercolumn= passwdcolumn= crypt=1
Da fehlen ja alle Zugangsdaten. Woher soll denn PAM wissen, wie und wo du die Benutzerdaten gespeichert hast?

mikeiv
Posts: 32
Joined: 2003-10-05 12:53

Re: postfix/sasl/pam_mysql.so problem

Post by mikeiv » 2004-09-13 20:43

die zugangsdaten sind schon drinnen, aber die poste ich hier nicht ;)
ich connecte ganz normal zu localhost zu den richtigen tables, das ganze lief ja genau mit denn einstellung schon, bis ich auf die dumme ide gekommen bin das backport von postfix 2 zu probieren.

mikeiv
Posts: 32
Joined: 2003-10-05 12:53

Re: postfix/sasl/pam_mysql.so problem

Post by mikeiv » 2004-09-14 15:09

so hab nun herausgefunden das PAM die /etc/pam.d/smtpd.conf überhaupt nicht liest. ich kann emails an locale domains schicken jedoch nicht an andere.

ich frage mich nun ob der fehler bei PAM liegt oder bei SASL? kann es sein das postfix sasl nicht benutzt seit meinen backport experiment?

ich hab mal alle config files hier angehängt.

/etc/postfix/sasl/smtpd.conf

Code: Select all

pwcheck_method: pam
/etc/postfix/main.cf

Code: Select all

setgid_group = postdrop                                                                                          
biff = no                                                                                                        
                                                                                                                 
# basic settings                                                                                                 
myorigin = ***.net                                                                                         
mydomain = ***.net                                                                                         
myhostname = ***.net                                                                                       
mydesitination = h***.server***.net, localhost.server***.net, localhost                             
mynetworks = 127.0.0.0/8                                                                                         
                                                                                                                 
# virtual domain and delivery settings                                                                           
transport_maps = mysql:/etc/postfix/mysql_virtual_domains.cf                                                     
virtual_maps = mysql:/etc/postfix/mysql_virtual_forwardings.cf mysql:/etc/postfix/mysql_virtual_email2email.cf   
virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_domains.cf mysql:/etc/postfix/mysql_virtual_mailboxes.cf 
virtual_mailbox_base = /home/vmail                                                                               
virtual_uid_maps = static:1010                                                                                   
virtual_gid_maps = static:1010                                                                                   
virtual_mailbox_limit = 51200000                                                                                 
message_size_limit = 10000000                                                                                    
content_filter = smtp-amavis:[127.0.0.1]:10024                                                                   
                                                                                                                 
# settings for authenticated SMTP                                                                                
smtpd_sasl_auth_enable = yes                                                                                     
smtpd_sasl_security_options = noanonymous                                                                        
broken_sasl_auth_clients = yes                                                                                   
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_relay_domains                 
smtpd_sasl_local_domain = $myhostname                                                                            
smtpd_require_helo = yes                                                                                         
smtpd_helo_restrictions = reject_invalid_hostname                                                                
smtpd_use_tls = yes                                                                                              
smtpd_tls_cert_file = /etc/postfix/smtpd.cert                                                                    
smtpd_tls_key_file = /etc/postfix/smtpd.key 
/etc/postfix/master.cf

Code: Select all

smtp      inet  n       -       n       -       -       smtpd                                                    
#628      inet  n       -       n       -       -       qmqpd                                                    
pickup    fifo  n       -       n       60      1       pickup                                                   
cleanup   unix  n       -       n       -       0       cleanup                                                  
qmgr      fifo  n       -       n       300     1       qmgr                                                     
#qmgr     fifo  n       -       n       300     1       nqmgr                                                    
rewrite   unix  -       -       n       -       -       trivial-rewrite                                          
bounce    unix  -       -       n       -       0       bounce                                                   
defer     unix  -       -       n       -       0       bounce                                                   
flush     unix  n       -       n       1000?   0       flush                                                    
smtp      unix  -       -       n       -       -       smtp                                                     
showq     unix  n       -       n       -       -       showq                                                    
error     unix  -       -       n       -       -       error                                                    
local     unix  -       n       n       -       -       local                                                    
virtual   unix  -       n       n       -       -       virtual                                                  
lmtp      unix  -       -       n       -       -       lmtp                                                     
                                                                                                                 
# Interfaces to non-Postfix software. Be sure to examine the manual                                              
# pages of the non-Postfix software to find out what options it wants.                                           
# The Cyrus deliver program has changed incompatibly.                                                            
                                                                                                                 
cyrus unix - n n - - pipe flags=R user=cyrus argv=/usr/sbin/cyrdeliver -e -m ${extension} ${user}                
uucp unix - n n - - pipe flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)          
ifmail unix - n n - - pipe flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)                 
bsmtp unix - n n - - pipe flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -d -t$nexthop -f$sender $recipient
smtp-amavis unix - - y - 2 smtp -o smtp_data_done_timeout=1200 -o disable_dns_lookups=yes                                                                              
127.0.0.1:10025 inet n - y - - smtpd -o content_filter= -o local_recipient_maps= -o relay_recipient_maps= -o smtpd_restriction_classes= -o smtpd_client_restrictions= -o smtpd_recipient_restrictions=permit_mynetworks,reject -o mynetworks=127.0.0.0/8 -o strict_rfc821_envelopes=yes
/etc/pam.d/smtp

Code: Select all

auth required pam_mysql.so user=vmail passwd=*** host=localhost db=email table=users usercolumn=email passwdcolumn=password crypt=1                                  
auth sufficient pam_mysql.so user=vmail passwd=*** host=localhost db=email table=users usercolumn=email passwdcolumn=password crypt=1
Last edited by mikeiv on 2004-09-14 15:16, edited 3 times in total.

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: postfix/sasl/pam_mysql.so problem

Post by captaincrunch » 2004-09-14 15:14

so hab nun herausgefunden das PAM die /etc/pam.d/smtpd.conf
Sollte das nicht auch vielleicht eher /etc/pam.d/smtpd heißen?
Last edited by captaincrunch on 2004-09-14 15:15, edited 1 time in total.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

mikeiv
Posts: 32
Joined: 2003-10-05 12:53

Re: postfix/sasl/pam_mysql.so problem

Post by mikeiv » 2004-09-14 15:15

CaptainCrunch wrote:Soolte das nicht auch vielleicht eher /etc/pam.d/smtpd heißen?
ah mein fehler das ist tipfehler hier im posting

sascha
RSAC
Posts: 1345
Joined: 2002-04-22 23:08

Re: postfix/sasl/pam_mysql.so problem

Post by sascha » 2004-09-14 15:16

Benutzt du sasl2? Da gibts kein pwcheck_method: pam mehr. Benutze den saslauthd.

mikeiv
Posts: 32
Joined: 2003-10-05 12:53

Re: postfix/sasl/pam_mysql.so problem

Post by mikeiv » 2004-09-14 15:21

ich habs geschaft ;) CaptainCrunch hat mich gerade auf eine idee gebracht. die datei heist zwar richtig /etc/pam.d/smtp aber die muss in der gruppe postfix sein sonst geht es nicht.

*kopfauftischwerf* und das hat mich jetzt 3tage lang genervt.