Website wird nur schwer ausgeliefert...

Apache, Lighttpd, nginx, Cherokee
Bonkknogger
Posts: 23
Joined: 2014-04-19 12:39

Website wird nur schwer ausgeliefert...

Post by Bonkknogger »

Hallo liebe Community,

ich habe hier mal eine eher Blöde Frage...

ich habe 2 vServer von Contabo, da bin ich zufrieden für das was ich brauche ist die leistung okay. Freund von mir hat bei Hetzner aus der ServerBörse einen Server, aber hier gibt es probleme.

bei mir werden meine Websiten sauber ausgegeben. Keine Verzögerrung bei der Ausgabe Dynamischer Seiten.
bei meinem Kumpel auf dem Server das komplette gegenteil .

HTML Seiten oder PHP Seiten die nicht Dynamisch arbeiten werden sauber ausgegeben. Wenn aber nun eine Streamanzeige für einen Shoutcast Server oder etwas anderes (Wordpress Seiten ganz schlimm) dazu kommt fängt der Webserver an zu straucheln und verzögert die ausgabe um bis zu 30 Sekunden.

der Witz an der ganzen geschichte ist aber , auf allen servern laufen die selben Konfigurationen sowie einstellungen was für PHP relevant ist. Es ist auch alles Up to Date.

Daher versuche ich zu verstehen, was hier schief läuft. Vlt hat jemand da eine Hilfreiche Idee? Wenn ich mir htop oder die ganzen Apache Logs anschaue finde ich keine Störungen welche die verzögerrung verursachen könnte. kann mir jemand vlt tips geben wonach ich suchen muss oder hat vlt sogar nen lösungsvorschlag?

Alle Server laufen mit Debian 10, Ver 15.1 Distrib 10.3.23-MariaDB, 4.19.0-10-amd64, php7.3

User avatar
rudelgurke
Posts: 406
Joined: 2008-03-12 05:36

Re: Website wird nur schwer ausgeliefert...

Post by rudelgurke »

Tjoa, auf dem physischen Server auch mal die Hardware prüfen ob dort alles in Ordnung ist, ob die firmware Pakete alle da sind und dann in den aktiven Diensten das Logging ein wenig nach oben schrauben, um zu schauen was da klemmt.
Ein kurzer Blick mit htop wird da wenig Einsicht bringen, vmstat, MySQL Prozessliste usw. usw.

Geht darum erst einmal einen Ansatz zu finden, an dem man "forschen" kann.

Bonkknogger
Posts: 23
Joined: 2014-04-19 12:39

Re: Website wird nur schwer ausgeliefert...

Post by Bonkknogger »

ja, mir fehlt jeglicher ansatz bzw fehlte. ich werd mir das mal zu gemüte ziehen. Danke

Bonkknogger
Posts: 23
Joined: 2014-04-19 12:39

Re: Website wird nur schwer ausgeliefert...

Post by Bonkknogger »

also den Thread kann ich nun erstmal schließen. Das Problem ist nicht unmittelbar mit dem Webserver selber sondern eher ein IP Routing Problem was behoben werden muss.

Dennoch danke für die Denkanstöße hier in dieser angelegenheit.